HitFilm 3 Express is not starting

LamsterLou Posts: 3
edited July 2015 in HitFilm

I am new to this and really do not know what is happening- I have logged in on the activation app but every time I open HitFilm 3 it takes around 10 seconds then the app opens for around 0.1 seconds then just instantly closes! No information or signs telling me what happened! I tried reinstalling but that didn't help! Does anyone know a solution to this?


  • Ady
    Ady Posts: 1,531 Enthusiast


    Could you maybe provide some information on your system please?


    That way we can have a look at why things aren't working correctly for you.


  • OS: Mac OSX 10.9.5
    RAM: 4GB

    Sorry but I don't know GPU and Cpu! And how to find it but hopes this helps! Don't worry if it doesn't because I'm useless with computers!

  • PaulOcone
    PaulOcone Posts: 1
    edited July 2015

    I have the same problem. My specs are:

    OS X 10.9.5

    2.5 GHz Intel Core i5

    16 GB 1333 MHz DDR3

    AMD Radeon HD 6750M 512 MB

     (And LamsterLou, you can get this by clicking "About this Mac"  in the Apple menu, and then clicking "More info".)

    vVJIMBOVv Posts: 1

    I too am having this issue, My specs are


  • I am having the exact same problem with this!!! Please help

    2.5 GHz Intel Core i5

    8 GB 1600 MHz DDR3

    Intel HD Graphicx 4000 768 MB

    OS X 10.8.5 (12F2542)

  • Ady
    Ady Posts: 1,531 Enthusiast


    Sorry for the problems you are experiencing, could you all please contact support here.

    There we can help you on a one to one basis. 

  • ryukin37Hotmailcom
    edited July 2015

    Same problem here

    Processor  2.5 GHz Intel Core i7

    Memory  16 GB 1600 MHz DDR3

    Graphics  Intel Iris Pro 1536 MB (Nvidia GT 750m)

    Software  OS X 10.9.5


  • rbibi
    rbibi Posts: 1

    Same thing for me :

    OS: 10.10.4

    CPU: 2,5 GHz Intel Core i5

    RAM: 8 Go 1333 MHz DDR3

    GPU:AMD Radeon HD 6750M 512 Mo


    Previous HitFilm 2 Express worked fine !

  • Ady
    Ady Posts: 1,531 Enthusiast
    edited July 2015

    Hi everyone,

    This appears to be an issue with people running HitFilm 3 on a standard user / secondary account. In order to run the software without this problem, please make sure when launching the software, you are doing so on an admin account. 

    If this is not currently possible with your system please contact support here who can guide you through the process of running it on non-admin accounts.

    (NOTE: You will still need access to an admin account to make the changes necessary )

    We will release an update to fix this shortly but for those affected it can be fixed by adhering to the information above & running the software on an admin account.

    Sorry for any inconvenience caused.


This discussion has been closed.