Everything is slow after update to Express 17.0.11715.56097

joealarson
joealarson Posts: 3 Just Starting Out*

Immediate regret after updating to the latest version of Express. Everything is slow. Cut a clip... Hitfilm locks up. Move a clip... Hitfilm locks up. Ripple delete a section of a clip... Hitfilm locks up. Change the scale of a clip... Hitfilm locks up. Try to move a clip in the frame... Hitfilm locks up.

It unlocks a second later and I can continue working, but this stuttering workflow doesn't work for me.

Computer properties:

Processor AMD Ryzen 7 2700 Eight-Core Processor       3.20 GHz

Installed RAM 32.0 GB

Device ID B448AE8C-2FFA-4A13-89CD-DAC740DF121C

Product ID 00325-95871-55356-AAOEM

System type 64-bit operating system, x64-based processor

Pen and touch Pen and touch support with 10 touch points

Is there a new setting turned on by defaut? Is there something in my old template that's slowing it down? Did the way it handles an old setting change? What's the problem here?

Comments

  • Andy001z
    Andy001z Posts: 3,152 Ambassador

    What gpu? Is your system using?

  • littlehausbigcity
    littlehausbigcity Posts: 54 Just Starting Out*

    Also, did you transcode? What cameras are you using and are they AVC/HEVC, AKA, H.264/265? If so, then you may be slowed down by that, along with your GPU.

    I discovered that if you are bouncing along towards the bottom of specs, especially with GPU, then it'll be worse with HF 2021.2 a bit. Best to transcode to an edit friendly codec, of which H.264/265 are not, and if you were able to get away with it before without transcoding, then you will likely now.

    Just something to be aware of. Before, I used to get away with just transcoding the GoPro as H.265 is not taken AT ALL in HF, let alone Premiere Pro CS4, but I understand later versions of PP can.

    That said, still recommended to transcode to an edit friendly codec anyway as both H.264/265 can bring even powerful PC's to their knees when editing.

  • tddavis
    tddavis Posts: 5,096 Moderator

    @joealarson It sounds suspiciously to me like the new timeline caching might causing your issue unless you have disabled it. AFAIK, it is on by default and a number of users are having an issue with it on their systems.

    To disable it go to FILE (marked with poor arrow), drop down to OPTIONS (Which I can't get a screen grab of), then click on CACHE (marked with another poor arrow)then uncheck the box with the blue check and for good measure click Delete timeline cache (marked with a really bad arrow)😁 I do hope that this is causing your problem and gets things going your way.

  • FilmSensei
    FilmSensei Posts: 3,108 Expert

    @joealarson The developers are very much aware that some users are having issues with the newest update, and they are asking that anyone who is having issue contact them to get as much information as they can to get to the bottom of it. Please contact support with as much information as you can. It really helps!


  • joealarson
    joealarson Posts: 3 Just Starting Out*
    @tddavis I did find that before making this post, and it didn't help.

    @Andy001z As I put in the initial post: AMD Ryzen 7 2700 Eight-Core Processor 3.20 GHz

    @littlehausbigcity This has been on all kinds of files. From my GoPro, from my Cannon a6300 (uncompressed). I don't think it's the compression. And I posted my specs. Do I look like I'm "bouncing along towards the bottom of specs"? I could maybe put a few more gig ram in it, but this ain't a slouch of a machine.
  • littlehausbigcity
    littlehausbigcity Posts: 54 Just Starting Out*
    edited October 12

    You still have not listed your graphics card, CPU is fine, but it can be held back by a middling graphics card or are you using the built in graphics feature of Ryzen?

    Agree your Ryzen CPU is fantastic, better than my Core i5, fourth gen processor. That said, your GPU needs to be mentioned as it can be your bottleneck.

    You mention GoPro (H8/9/10), best to transcode as it uses H.265 (with earlier versions being likely H.264), so neither are not an edit friendly codec, and if your GPU is low spec, then that's a double whammy for you. Also, you say you are running a Canon A6300? Or do you mean the SONY A6300? If Even uncompressed, that's a lot of bandwidth to deal with, so without knowing what GPU you are using, we don't know if it is adequate or a bottleneck. I run two cameras, and need to transcode both now to enable adequate editing experience with the latest update to Hitfilm (2021.2) as both are compressed H.264/265 cameras, but I run both at 1080P due to the fact that the Canon Vixia maxes out at 1080P (30fps) or interlaced at 60fps, but since HF does not like interlaced footage, I run that camcorder at 1080/30P, so the GoPro matches that.

  • sathon
    sathon Posts: 2 Just Starting Out*

    Similar issue here with the latest update on my 3950x/5700XT on Windows 10. I opened a support ticket and will await their response. On the upside, the project I did manage to complete seemed to export faster than usual.

  • Andy001z
    Andy001z Posts: 3,152 Ambassador

    Hi, as mentioned above, I asked for you graphics card details. It looks like your Ryzen CPU is not a G generation which means it does not have GPU processing on board, therefore you most likely have some other kind of GPU in your system, like an NVIDIA card or a AMD card.

  • joealarson
    joealarson Posts: 3 Just Starting Out*

    @littlehausbigcity Ah, yes, I did forget the video card. Thank you. NVidia GeForce RTX 2060

    I suspect the bottleneck is not my video card.

    The GoPro was tested after the Sony (Yes, you are correct) A6300. It was that footage that I first noticed the problem.

  • littlehausbigcity
    littlehausbigcity Posts: 54 Just Starting Out*

    Then your best bet, transcode both as H.264/265 are not edit friendly, something like Cineform or similar is better for editing with. I run GoPro H9 and a Canon Vixia, both use H.264/265 and am finding that both need to be transcoded to something better than what both use by themselves, and use the same codec for both so the CPU/GPU does not have to deal with more than one codec during editing. Right now, it is, and the Canon is left at H.264 so it's a double whammy for the CPU/GPU to deal with.

  • NormanPCN
    NormanPCN Posts: 4,081 Enthusiast
    edited October 14

    AVC/H.264 will typically get the best overall timeline edit performance in Hitfilm when a reasonable hardware decoder is used. The AVC media must be 8-bit and 4:2:0 for HW decode. 4:2:2 AVC media cannot be hardware decoded. Likely because of this the proxy files in the new HF version are using the AVC codec (suitably chosen encoding specs of course). Camera media encode settings vary widely. I have no comment about what devices have a reasonable HW decoder and what does not. For the record I have a GTX 1080 (like to have a 3070 but...). HEVC/H.265 decodes about the same as AVC on my machine (UHDp30 tested).

    Compared to HW decoded AVC media, Cineform performance in Hitfilm often kinda sucks. At least in some simultaneous stream composite tests I had previously performed. Various codecs. The timeline media stream ingest in Hitfilm is (has been), ahem, poor and unless the decoder is fast as hell (like a HW decoder), then Hitfilm can/may suffer. When it comes to Cineform, everyone is using the same decoder. The Cineform source code SDK directly. Now Cineform does have a performance capability that Hitfilm does take advantage of. The ability to decode to lower resolutions faster. aka Half res timeline setting. This should be quite useful for UHD editing.

  • TheBenNorris
    TheBenNorris Posts: 2,032 Staff

    @joealarson could you send any of this problematic media to our support team, along with some more information, such as:

    • Is hardware decoding enabled?
    • Exactly what actions cause the slowdown
    • Is the timeline cache enabled?
    • Is this in the editor or the comp?

    Thanks in advance, I'm hoping we can identify the cause of this issue with a little help from you guys:

    ww.fxhome.com/ask

  • FXhomer211623
    FXhomer211623 Posts: 5 Just Starting Out*
    Same problem here on the latest update and it is not related to my hardware. I immediate noticed the problem as I was editing a large 1 hour long documentary with hundreds of cuts. I jumped versions at the end of the project and immediately noticed the delay on dragging and moving clips in the timeline. Before this update it was smooth and quick, I could select a large amount of clips and move them instantly with no delay problems.

    Now it is slow to respond when moving a clip and will hang for a few seconds when I move clips around.
  • FXhomer211623
    FXhomer211623 Posts: 5 Just Starting Out*
    @TheBenNorris to answer your questions.

    Is hardware decoding enabled?
    - Yes
    Exactly what actions cause the slowdown
    - Dragging clips in componsite shot
    Is the timeline cache enabled?
    - Yes
    Is this in the editor or the comp?
    - In the comp

    System:
    HitFilm Pro
    Windows 10
    i7-8700K CPU 3.7GHz
    32 GB RAM
    Radeon RX 560 4GB
    Radeon RX 570 8GB
  • Stargazer54
    Stargazer54 Posts: 3,431 Ambassador

    @FXhomer211623 Try disabling Timeline Cache. If that doesn't help try disabling Hardware Decoding, as well.

    Also make sure your GPU drivers are updated from the manufacturer. Please also log a support ticket so the devs will have more information to run these issues to ground.

  • TheBenNorris
    TheBenNorris Posts: 2,032 Staff

    @FXhomer211623 if possible please could you contact support with the project reproducing this issue? We have no reproducable projects to hand currently so it would be greatly appreciated if you could help us locate the source of this issue.

    www.fxhome.com/ask

  • kibe00
    kibe00 Posts: 1 Just Starting Out*

    THANK YOU!! This was exactly what was making my worklow stutter, and now I don't have to use half an hour of editing time looking at Hitfilm preparing to crash 😊


    For reference:

    • i9-10850k
    • GTX 970
    • 32GB RAM
  • tddavis
    tddavis Posts: 5,096 Moderator

    @kibe00 Glad that helped you out in the short term, but please consider opening a support ticket with Support proper to help them run down the issue that you had and others are running into at www.fxhome.com/ask as Ben Norris requests above please include :

    "send any of this problematic media to our support team, along with some more information, such as:

    • Is hardware decoding enabled?
    • Exactly what actions cause the slowdown
    • Is the timeline cache enabled?
    • Is this in the editor or the comp?

    Thanks in advance, I'm hoping we can identify the cause of this issue with a little help from you guys:"

    I'm sure it will be most appreciated.