HitFilm process no longer closing after application close?

MatthewJenkinson
MatthewJenkinson Posts: 5 Just Starting Out*
I discovered this after the most recent update (2021.2)

Normally, when I'm finished editing a video and I've closed the application, I'll archive or delete the source files I used to create it, but I found that I couldn't because they were still open in the program.

Does it just take a while to close now or will it never close unless I kill it with task manager? It would be pretty annoying to have to do that every time, and I don't want it using up my CPU while it shouldn't be doing anything.

Best Answer

Answers

  • websurfer1111
    websurfer1111 Posts: 2 Just Starting Out*

    It does it on my PC too, continues running in the background. Though Express 2021.2 closes after a while, like 2 or 3 minutes or more for good.


    Additionally on my end, Express 2021.2 super-lags as long as there are any pre-rendered timeline files left, now that this new feature exists. It makes it tedious to edit stuff on the timeline and almost impossible to edit key frames. I turned off the new background feature and deleted the pre-render timline files and its lo longer lagging in that regard. Unfortunately it didn't fix the laggy opening of projects that's now a thing. And I can't detach a layer from a parent layer. I'm waiting for over 20 minutes by now, when I posted, it's ridiculous.

    And I can't go back to the previous version, because I already converted it to a 2021.2-Project... I will probably have to wait for an update or a patch.

  • TheBenNorris
    TheBenNorris Posts: 2,034 Staff

    @MatthewJenkinson sorry to hear you're having trouble, I have a few questions to try to close in on this issue:

    • What is the process that remains open?
    • Does the issue occur if you simply open HF, new project, exit?
    • Did you do any pre-renders, proxying or exporting?
    • What are your system specs?

    @websurfer1111 could you also answer the questions above, as well as these:

  • MatthewJenkinson
    MatthewJenkinson Posts: 5 Just Starting Out*
    @TheBenNorris Sorry I'm not so active on the forums, so the reply is a bit late. This occurred after exporting - that's the important detail.

    It's the HitFilm Express process that remained open.
    The issue wouldn't occur starting a new project then exiting as it requires external files to be open in the application to reproduce.
    I'm on Windows 10 using an AMD Ryzen 7 2700x CPU, and NVIDIA RTX 2070 Super GPU.
  • Triem23
    Triem23 Posts: 20,080 Ambassador

    @TheBenNorris FWIW I have occasionally (maybe 1 in 20 times) had Hitfilm fail to release a process on exit. Often the render client, sometimes the QT server. This dates back to Hitfilm 2017. My 1 in 20 estimate could be wrong since these are times when I've closed Hitfilm then decided to open it again.

    Never bothered reporting it cuz it's been intermittent, and a manual close in Task Manger is easy.