Proper light with alpha channel

SnowYou
SnowYou Posts: 6 Just Starting Out*
Hi !

I'm trying to make some animations for events such as follow / subscribe, I need it to be transparent to let the background visible
The thing is, I'm trying to use some particles and lights, but after exporting it under AVI files, every light particles become a big white circle instead of a soft light, most particles have weird surrounding color artifacts and the soft gradient mask doesn't apply anymore

Do you know a way to export while still keeping the soft light and particles even with transparency ?

Thank you !
Snow.
Tagged:

Best Answer

  • Triem23
    Triem23 Posts: 20,188 Power User
    edited July 2021 Answer ✓

    What are you doing with the video after - opening in Hitfilm, or a playback app like VLC?

    Note VLC in particular doesn't correctly support transparent video, so your export might be correct, but your media player might be incorrect.

    Bring the video back into Hitfilm, toss it into a Comp Shot and put something else under it to see if it looks right in Hitfilm.

    If it DOESN'T, right click your transparent video in the Media Bin, look for Alpha, uncheck "From File," and toggle Straight/Premultiplied. If either looks correct, then 1) the file rendered correctly (and the issue was your media player) 2) you've learned the proper setting for later compositing. I assume you're rendering a transparent element for re-use in Hitfilm?

    If neither works, we may have found a bug, or your GPU drivers need an update. Next time I'm on my PC I'll run a test myself.

Answers