"Alpha Over" Equivalent in Hitfilm

DrIgnatiusCole
DrIgnatiusCole Website User Posts: 50 Just Starting Out*

Hello, I hoping this is newbie problem, and that I am misunderstanding something fundamental with Hitfilm.

I have a problem with some composite shots not combining with the alpha channel properly. Here is picture which points out what the problem is. On the left is my composite from blender which I will post below. For context:

  • I am using a technique to reduce render times for volumetrics by combining 2 separate renders of the volmx one done in Eevee and the other in Cycles with de-noising. Also the cycles render settings are specific to the scenes, volmx and background, and therefore render much faster. Altogether there are 3 layers in this composite.
  • The main scene has everything but the volume, and the volume layers has everything except the volume held out - as an alpha channel.
  • Blender has the "Alpha-Over" node, which I think is the reason why it is composting "correctly" (ie the way I intend) and I can't work out why I can't find an equivalent in HF.
  • Although I should in theory make composite shot first to mix the volume, I should still have alpha channels allow through the background, or block the background depending on the texture.

Note the bubbles which are not allowing through the background, and the fish which should be blocking the light. I double checked the EXR files and re-composited in blender - ie reconstructed my composite from my render file with the exr files incase something funky happened. But there isn't they composite as I expect.

I can't help the feeling I have missed something really obvious. I have reconstructed the composite as closely as possible in HF using the same blend modes and colour adjustments, but what I should see simply by putting just one volume layer on top of the main scene without any corrections (using "normal" blend mode), is the colour of the background coming through the bubbles, and the fish blocking the light.

I could post single frames of the composite, 1 from each layer if it would help. But hopefully (certainly) it is something I have not understood.

«1

Comments

  • tddavis
    tddavis Moderator, Website User Posts: 5,018 Moderator

    @DrIgnatiusCole You are in an area that is so far over my head in both Hitfilm and Blender. I have used Alpha Over one time but never understood what it was doing except that it worked 😀but I cannot help but wonder in Hitfilm if the Blend mode might play a part in the issue you ate having? If you haven't tried switching them already you might try screen instead of add or vice versa. That, however, is only a guess and does not come from any knowledge on the subject.

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    Well thanks for your response, but you can bet all your body parts that I have tried every blend mode possible.

    Alpha-Over is a special node in Blender compared to the normal "mix" node and what I would have suggested were anyone not able to make headway is I could supply the compositing blend file and a frame from each of the 3 layers so you can try in HF and Blender.

    Alpha Over, as far as I understand does pretty much what it is saying, you put the alpha layer on top of a base layer to composite.

    Something is not being read with the alpha layers in HF though and I can't work out what the blend mode should be. I would have though "normal" is just a basic mix mode.

    In blender, Alpha Over is the main method of mixing render layers, but we have the mix node in order add in processed effects, which you can see from my blender composite. I do the composite in Blender to make sure that I am getting everything I need for compositing in HF - checking to see it will work well enough. HF has much more sophisticated effects and processing. So I send my blender compositing to a preview, and take render outputs (with any pre-processing) directly to file for use in HF.

  • tddavis
    tddavis Moderator, Website User Posts: 5,018 Moderator

    @DrIgnatiusCole I was fairly certain you had tried other blend modes, but thought I'd mention it anyway. The absolute and hands down expert in Blender/Hitfilm here is @spydurhank. He does all sorts of multi pass and swapping scenes between Hitfilm and his custom build of Blender called Filmer. I am one of the Beta testers for him, but really it's a disservice to him with the little I know about it. Hopefully, he can weigh in on your issue today sometime. And, if you haven't heard of Filmer before, check out some of the videos he has on his website showing what he has it doing:

    I think the water droplets on the viewport of the TIE fighters is probably my favorite vid...but Iron Man is a close 2nd.

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    Oh god of course! Frank...he has been incredibly helpful in the past....I'll hit him up with an email, but I'll get him to respond here just so people with the same problem can find it.

  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,149 Expert

    Hey Thanks Terry @tddavis 😀

    Hey @DrIgnatiusCole , good to hear from you again

    I'll do a quick video for you in a bit after a few cups of coffee, I kinda understand your question but then... I kinda don't, I woke up a little late today and I'm still drowsy 😴 so for now, 😀

    Could you post some more screengrabs of your compositing setup in Hitfilm?

    Also of the Volume pass by itself... maybe put it in it's own Comp. I just need to see if there is transparency, are we able to see the Hitfilm background Checkerboard pattern behind your Volume pass? The checkboard lets us know that we can see through parts of the image.

    If you do see the Checkerboard, then your Volume pass can simply be placed above your other compositing passes and You would control the Volume pass with the Opacity in the Transform settings, you could then use something like the Curves effect. You probably shouldn't use blend modes with this type of image because the math performed by blend modes on colors and values is also performed on the alpha channel which is transferred to any render passes below the Volume pass.

    If you want to use the Volume pass with Blend modes like add, screen or multiply... first,

    as above, Create a Comp from your Volume pass. Give it an identifying name. I'll call it "New"

    Create a new Black plane and move it below your Volume pass in the timeline. And you're done.

    This "New" Comp which has whatever name that you gave it can now be dropped above all your other passes using the Add and Screen type Blend modes.

    If you wanted to multiply, then you'd create a white plane and place it below your render pass.

    Anyway, yeah. 😀Just a little food for thought till I wake up.

    Later.

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    Hi Frank,

    The compositing set up is fairly simple, initially I simply want to achieve the same effect from Blender and I have stripped everything back to just the Volmx (Vmx) layer and the Main Scene (DN - for de-noised). I am attaching 3 frames and a blend file so you can see how it works. Can you get the alpha channels to work the same way in Hitfilm?

    In fact I can attach the hfc file as well.


  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,149 Expert
    edited July 9

    @DrIgnatiusCole ,

    Just got a chance to check out your files... erm... may be better if we can video chat.

    Lemme know when you have time. 😀

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    Oh ok, I could probably do something tomorrow...or probably Monday. I'll email.

    But in the meantime, can you really not achieve the same effect in HF as in Blender? The reason I hope you could answer here is because it really very helpful to be able to google terms when encountering problems like this...so in the spirit of interest helpfulness...

    Double checking your post, there is nothing so unusual about my passes I don't think. I use the different blend modes to achieve different effects, and the more I use the smoother the volumetrics from cycles become. The reason for that is each mathematical process introduces rounding and variations from the original image that smoothes out the image...the effect I am looking for. It doesn't always work, and sometimes you do a lot, and some times you do a little and sometimes do none at all.

    It's very similar process for mixing in music, using parallel compression, reverb, filters, delays, with mastering the audio equivalent of grading.

  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,149 Expert

    Ah,

    Should'a explained. The Alpha Over node is the equivalent of stacking/compositing layers like we would do in Hitfilm so it is technically possible. 😀

    Look at the pic below. The volume passes are below everything and the main 3D scene or "render pass" is on top. I've simply stacked them on top of each other and didn't use Blend modes. This is the exact same thing as using the Alpha Over node.

    The only weird thing about your Comp setup is the actual transparency in both of your Cycles and Eevee Volume passes. There are no holdout materials for the ocean floor, the fish and debris like the large pipe. Each of your Volume passes has pixels behind and in front of the 3D scene, making difficult to comp in because there is no holdout material to tell the Volume passes where they should fall in the 3D scene.

    If you had other passes like a depth pass or a material ID pass, I could walk you through it without you having to re-render your volume passes with the correct holdout materials.

    In this pic I simply re-ordered the layers stack so that one of the Volume passes is above the main 3D scene render pass and I'm controlling it with the opacity slider.

    The only problem with this is that the volume passes don't really comp in very well with the depth of the rest of the 3D scene.

    Best practice is to... in the individual Filmer Volume pass "Scenes" have all geometry with one material. Black is just fine and will render very fast. So you'd need to Render your Volume pass with the rest of the 3D scene/objects having a single black material. Doing it this way will allow you to comp in the Volume passes very easily.

    Yeah let me know when you can chat. Worst case, I can show you how to get really. really fast render times for volumes... if it comes down to that. There are several ways to get you squared away. 😀

    Think of it this way... You've basically rendered out your own stock footage in the form of the Volume render passes. These volume passes don't have any masks telling them where to fall or be in correlation to the scene. So the transparency in the alpha channel itself is the problem. The render passes can't tell where the volume should be... in front or behind the fish for example... or that large pipe in the foreground... or that cool mountainy range in the background.

    Frank.

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    Hmmm....

    All of my materials were held out in outliner and I can see that there are alpha channels there. Also the composite works in Blender as expected.

    But to change all of the materials for the volume pass would be extremely fiddly, and necessitate initiating a separate render. It might render fast, but that sounds like asking for trouble. There is the inevitable re-renders because something wasn't right, or there is the alternative shots from the same scene. If I make any changes....that sounds really...I mean I guess you made it work....

    The way I am working, I set up the scene, once I'm happy with it I make a linked copy, either set to EV, or Cycles, or both. I then set up the output nodes on the main layer taking the unprocessed images and use the composite node to output a preview of my Blender composite. Any changes I make in one scene is reflected in the other, except for whether a collection is on or whether or not it is held out.

    I then CLOSE the blender file, and open terminal and render headless. Owing to bugs in blender, many files will not render in UI mode (no it is not a memory problem). I then open the file on a remote machine and set up the output path to the same location, save as a version of the file rendering remotely, and command line render with that. I then simply drag that same file on all the other machines I am running that renders with Optix and they all render using the placeholder method.

    The EXR's have alpha channels and composite in HF, just not always correctly as I am showing here. Though they do composite.

    My understanding is that the volume should go OVER the base layer which is the main scene. That works in Blender - why not HF?

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*
    edited July 10

    "This is the exact same thing as using the Alpha Over node."

    No it's not Frank - or at least I don't get that result in Blender. If I use the alpha over node and put the main scene below and the volume above I get the result I expect, with the fish blocking the light from the volume, and the light from the volume "through" the bubbles.

    If I do this with HF I do not get the same result. You should try it.

    "There are no holdout materials for the ocean floor, the fish and debris like the large pipe. Each of your Volume passes has pixels behind and in front of the 3D scene, making difficult to comp in because there is no holdout material to tell the Volume passes where they should fall in the 3D scene."

    There ARE holdouts for the materials, but I didn't notice that for the seabed. It shouldn't matter though, because the volumes alpha channels should let light from the seabed through. There is nothing of the seabed that should be in front of volume. It's not good practice though - so that's a mistake.

    The fish SHOULD block light and the bubbles SHOULD let light pass through. I don't understand why it does in Blender but not in HF. I'll work out a time tomorrow so we can video chat.

  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,149 Expert

    Ah,

    Check out your first pics above.

    You're using a Color Mix node to comp two volume passes together and another color mix node to comp the volume passes with your main scene... the Factor slider for the Color mix node performs the same function as an "Opacity" slider in the Hitfilm Transform properties. This is the part where you're having trouble so instead, while in Hitfilm, you use the layers opacity to control the intensity of the volume. I'll explain better below but you basically need a black background to comp your images onto. Your images all have transparency and your trying to use math via blend modes and in your case... you really don't want to perform any math functions on the alpha channel.

    What you want to do can be done but... I'd really suggest altering your approach with the way that you're using the alpha over node. This way the problem won't ever bother you again. If you decide that you want to keep using the alpha over node in your particular manner... this problem will always come up.

    Because you don't have a black background... your volume pass is not drawing the correct order of occlusion for your objects in the scene

    You need the fish and all other objects in your scene to occlude the volume.

    So if I was doing what you did and set up two extra scenes for volume,.. one for Cycles and one for Eevee,. I'd make sure that the same objects exist in each file. The Volume passes are simply rendered onto a black background

    In Hitfilm, you need a plane with a solid color, preferably black so that you have something opaque onto which you can comp the other three passes.

    You did something more like this... see the checker pattern?

    You should try to avoid this because things won't work very well.


  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    Hi Frank,

    "You're using a Color Mix node to comp two volume passes together and another color mix node to comp the volume passes with your main scene... the Factor slider for the Color mix node performs the same function as an "Opacity" slider in the Hitfilm Transform properties. This is the part where you're having trouble so instead, while in Hitfilm, you use the layers opacity to control the intensity of the volume. I'll explain better below but you basically need a black background to comp your images onto. Your images all have transparency and your trying to use math via blend modes and in your case... you really don't want to perform any math functions on the alpha channel."

    Yes I know all this. I don't think you have understood quite what I've done - or what my question is:

    I KNOW I am mixing the two volume renders BEFORE it goes to the alpha over node. I know the the factor node performs the same function as opacity in HF. I don't see why I need a black background to comp the volume on to, but maybe that's what needs to happen in HF. That seems strange - I don't need to do that usually.

    The 2 volume passes DO have all the same objects held out. They are linked scenes, and the EV pass was "copy linked" scene from the cycles. So they are identical. In this particular case I was trying NOT to alter any of the lighting in the EV scene relative to the cycles scene. What you can do is create a collection independent of the linked scenes if you need to do this.

    The trick is to blend the two volume passes BEFORE they go to the alpha over node. That way you get the smoothing from EV applied to the cycles - and you get a nice effect. They should have the same alpha channels and the blend should not effect the alpha - and don't in Blender. At least I don't think they do. When I view the output of those two mixed images, I see the alpha exactly as I would expect.

    So what I am doing is creating the right combination of lighting and blending of the volumes that can then be composited on to the main image - you have to think of the mixed volume layers as my finished volume layer. When I use the alpha over node in Blender I am getting the result I expect, but I do not get the same result in HF.

    Just to simplify things for a moment - just take the cycles volume layer and the background - ignore the EV layer. (Remember the EXR files you have a preprocessed so nothing has been done to them).

    • In Blender, combine the 2 layers using the alpha over node, with the Volume OVER the main scene.

    The result is as I would expect. The fish are blocking the light (the alpha channel in the volume from the fish as hold out) and the light is passing through the bubble.

    • In HF put the main scene below and just the cycles volume above.

    What blend mode will result in the same result as in Blender? Because just using normal mode does not result in the same effect.

    You do not need to set up additional scenes for the volume pass Frank. This is how I have been doing the whole project. You create linked scenes in Blender/Filmer, and you can set different render settings for each scene. So for the volume in cycles, you can turn the number of light bounces down, glossy, transmission etc, play with volume light bounces between 0 and 2, and try to keep the samples high. You can then duplicate THAT scene and set it to render in EV. You can use both or either. Generally, lighting that works for one does not for the other, and lighting that creates a good effect on both composited together doesn't look good on each independently, so at some point you decide how it's going to be done.

    All you need to do is make sure that the volume is turned off altogether in the main scene, and everything else held out or turned off in the volume scenes.

    I generally want to do final compositing in HF because there are a greater range of effects available. But I want to make sure that I have gotten what I need for it to look good, so I do some rough compositing in Blender - for example I might want to take some glossy passes, or transmission, or emission, so I do some fooling around in Blender and if I get something I like the look of I output the PRE-processed images to OpenEXR file output and send it off to be composited with the preview.

    So the question is still can you get the same result in HF as you can with the alpha over node in Blender? Are you suggesting that in order to do that I should output the volume renders with a black background and then use demult in HF?

  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,149 Expert
    edited July 11

    Mhh... this is why video chat is way better. 😀

    I understand everything that you're doing... for real, I can tell by the files that you sent me. The problem still exists in Hitfilm though right? There's a reason for that. Please allow me to help you with that. 😊

    The pic below is using your node setup. You can see a white fringe outlining all the fish and bubbles. The fringe is the alpha channel.

    Here's what happens to your node setup when I add exposure nodes.

    Here is my node setup. No fringe and the volume passes fall where they should without blowing out the fish.

    You can see in my setup, that I'm using the alpha channel of each Volume render pass as a factor for the color mix nodes.

    And I can control the visibility of each Volume render pass with the two color mix nodes.

    And blowing up the volume a little bit with exposure nodes.

    😀😀😀

    EDIT

    Forgot to say yes,

    If you render onto a black background, then you can just use "Demult" but the added bonus is that you can use blend modes. It's a bit different when trying to use blend modes with images that have transparency.

    In Hitfilm, you'd simply throw each volume pass into it's own comp and add a black plane below it in the render stack.

    Throw your main scene into it's own comp then, toss in the two volume pass comps above it in the layer stack. You can either use "add", or "screen" blend modes or you can use "Demult".

    The only real reason that I suggested a video chat was to let you know that you're using the Alpha node in a weird way and it doesn't really work... which you can tell by my examples above in the fringe around the alpha channel. The main take away is that you have a problem... if you keep doing what you're doing, then this problem will always exist for you. But you can avoid this problem forever if you either, follow my node setup above and then incorporate your desired compositing nodes... or, if you simply render out these passes onto a dark or black background.

    In Hitfilm all you've gotta do, as I've already said but again... yes, it's much simpler and easier to comp in these particular render passes if they have a dark or black background by using blend modes or "Demult"

    Frank

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    Ahhh....now we're getting somewhere....this is really helpful.

    Let me parse this...

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    With my node set up I do not get the fringe. The composite looks pretty spot on to me. Take a look at the image at the top of my post. Also in yours the background doesn't look quite right. I just double-checked and my seabed and landscape background were held out.

    I also played through the animation preview and it's spot on - there is no alpha channel bleeding through at all. So I am not sure how much further on I am.

    PS. I know it might be good to chat...but for now this is really helpful. I need to stop and really think about what you're saying and check your images. Once I have worked out what is going wrong, then we can chat about how to do it right.

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    Hi Frank,

    Ok I have spent the last 2 hours or so experimenting with your node setup in Blender...but it isn't giving me the results I expect.

    • There is no way to control the mix between the two volumes. Using the EV to multiply the cycles volume for example, gives a very nice result. That can then go to be composited with the main scene.
    • The background in the main scene is made lighter by the node set up with no way to control that (that I can see). The background should be barely visible. I have found a couple of ways - partly experimenting with your avoidance of the alpha-over node, but you have to mix the volumes first the way I did in my original blend file.

    Regardless, I cannot understand why the frames will not composite correctly in the most simplest way in HF. Any type of composite in blender gives expected results, but I can't work out why it isn't working HF.

  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,149 Expert

    Here's what I did.

    I simply opened your file and opened the compositor, the file is exactly as you sent it to me, and this is what I see, there is a visible fringe in the alpha channel around the fish and bubbles.

    When I connect only one of the Volume passes in the Compositor...

    You can see that the volume is visible all the way from the background up to the foreground in the transparent areas and in front of that large pipe. See the dark globs in the transparent areas?

    If I add a black background to the volume passes, I can then comp it in easier.

    The alpha over node in Filmer = Set matte effect in Hitfilm.

    Color factor slider in Filmer = Layer opacity in Hitfilm.

    We'll talk after you've had a think. 😀

  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,149 Expert

    You know what? I'm an idiot, I keep skipping this part.

    Why it works in Filmer right off the bat... because the "Outlier" tells the Compositor that the two other scenes in your .blend file are being rendered and have holdout objects. The Compositor takes into account the correct camera depth drawing order and everything is comped in as expected. You don't actually need the alpha over nodes as you can see in my node setup.

    Why it doesn't work as expected in Hitfilm... where you can use the Set Matte effect, to a certain extent, as a stand in function for the Alpha Over node in Hitfilm, it won't work as expected because it's not like you can re-produce the exact same 3D scene in Hitfilm that exists in Filmer/Blender which is what the "Outlier" does as explained above.

    If only some smart guy could do this for Hitfilm...

    Oh wait. 😋

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    Ok so,

    When I set up the composite in Blender, in a fresh blend file, using the exr layers, frames of which I sent you, I do not get any fringe around the images. Everything composites exactly as I expect.

    There are a couple of ways to do it, but usually I have to feed a little of the original scene in, ideally using a blend mode that doesn't brighten the image or the whole of the image (a number of the work well giving slightly different results), every time I get pretty much the composite I expect. Or I can reduce the opacity of the volumes but usually that is less successful.

    • Basically, mix the 2 volume layers
    • Send to an alpha over node (or mix node with an alpha from one of the layers as factor)
    • Mix with main scene on the alpha over node, or mix node with the alpha as mix factor.

    Voila. Looks as expected. Tweak colours blah blah.

    So if I just do a simple composite with the alpha over node, in blender I get expected results, in HF I do not.

    I have never needed to use a black background, and I do not need to assign different materials in Blender/Filmer.

    Remember I am taking the EXR frames - there is nothing magical about outliner - it just creates alpha channels for the held out objects. Obviously this means if it is within the volume you get more volume in front of the object and less alpha depending on how far back. I have done this on countless scenes and it has worked, but I am not sure it has been working properly. Judy has been remarking that my blender composites look better.

    So you are saying "set matte effect"? I haven't encountered that yet...I'll have a look to see if I can find it.

    As an aside, I am also surprised how dull and featureless the rusty train looks in HF compared to my unprocessed Blender image - even with everything turned to full quality...I mean hopefully that's just the viewer in HF and not something funky going on with exr's or anything.

    Right so "Set Matte Effect". Ok...

  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,149 Expert

    Add an Exposure effect to your render in Hitfilm. Turn the gamma up a little and then play with the exposure if needed. Raising the gamma will make the image/rusty train look closer to what it looked like in Filmer.

    This is why a lot of renders look really cg in Hitfilm. I'm glad you can tell the difference. I can tell, and I'm super nit picky about how things look. 😀

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    Hi Frank and anyone else following this.

    There is something fundemental missing with these EXR clips in Hitfilm.

    I just dragged in the same clips into Da Vinci Resolve and they composited perfectly - exactly as expected. A bit darker than in Blender but that's easily fixed.


  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    ANSWER:

    Hitfilm is bringing these clips in as Premultiplied by default. But they should be brought in with the alpha channel set to "straight".

    Go to the clip and click on the little cog and check the section for Alpha which is set to "premultiplied". This might be why Frank is able to bring his clips into HF without any problems, because he is putting the clips over a black background.

  • tddavis
    tddavis Moderator, Website User Posts: 5,018 Moderator

    I have not just been following, been copying and pasting everything (including screenshots) into a text document for future reference. Didn't want to stifle the flow of info by commenting until a solution was outlined 😁

    Slight little format differences like this and the whole 24 bit PNG no-alpha vs 32 bit alpha are super hard to run down.

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    Ok, I have been through some more of my renders and MOSTLY the composites are right - with the default being pre-multiplied. Switching to "straight" results in more of the alpha bleeding through. In seems special cases it should be set to "straight". So not entirely sure why it was a problem in this case - I am using same methodology on this render as I was on the others. At least we got there in the end.

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    One last thing - I have been going through all the composites, and it seems wherever there is transparency involved, the status of whether it should be pre-mult or straight seems to be an issue.

  • tddavis
    tddavis Moderator, Website User Posts: 5,018 Moderator

    Out of curiosity, have you tried any of your tests with PNG and transparencies? I'm thinking there are 2 types of EXR, I believe and Hitfilm only supports 1. Maybe that has something to do with the quirk??

  • DrIgnatiusCole
    DrIgnatiusCole Website User Posts: 50 Just Starting Out*

    HF only supports Open EXR not multiEXR.

    I have been mostly rendering to multiEXR and then extracting the Open EXRs using blender afterwards.

    No I am not using PNGs - I have been told they are the spawn of Satan and must be avoided like the errr....plague....too soon?

  • tddavis
    tddavis Moderator, Website User Posts: 5,018 Moderator

    Ha. PNG has been my format of choice for sequences, but OpenEXR does retain more info concerning luminance and bloom data I have found. Never tried the multiEXR since I knew HItfilm didn't support it but I am interested in the layer depth data there if they ever do.

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,822 Ambassador
    edited July 12

    @DrIgnatiusCole @tddavis @spydurhank

    Side note - there is a Feature Request thread for multichannel EXR support. If you haven't yet, you should go Vote Up.

    Comment on PNG: not Satan spawn, but, typically only 8-bit/pixel, and, of course, you want to keep your full 32-bit data.

    Comment on color depth: DrIgnatius I don't recall seeing it come up in this thread, but your project settings are set to a 32-bit color mode, correct? 8-bit and 16-bit would obviously have an effect on composting.

    Bug at high color depths: HF 15-2021.1 have a bug with 16-bit and 32-bit LINEAR color. Seems to be flipping normals on 3D models directly imported into Hitfilm. I have no idea if this affects straight compositing of EXR (I haven't tested), but it might be worth checking between 32-bit FLOATING and 32-bit LINEAR to see if they composite differently.

    Otherwise, I leave you in Frank's hands.

    Good catch on the premultiplied/straight.

    Comment on straight vs premultiplied: STRAIGHT is when the element is created over a transparent BG and all transparency information is in the alpha channel. Rendered elements are more likely to be straight alpha. Premultiplied alpha affects color data in the RGB channels and assumes the element was isolated from a background color. The color data is altered for a smooth transition re: original background. This applies to elements isolated from photos or video clips. It CAN apply to rendered elements, like companies that supply stock on YouTube (or other sites) in formats that don't support alpha (hi, mp4) with a separate alpha pass. Example: I have some fireball on black stock from storyblocks where the fireball footage is followed by a grayscale version intended as a Set Matte source all in a single mp4.

    In general most stock assets are premultiplied, so it's the correct default choice for most situations, but, in this case, obviously it wasn't. At least you caught it (eventually)!