I receive a dll error when I open Hitfilm Express 15.1

PaulStarrPaulStarr Website User Posts: 18 Just Starting Out

I attach the image. Does anyone know how to fix this?

Many thanks


  • [Deleted User][Deleted User] Posts: 0 Enthusiast
    edited October 2020

    Are you downloading on WiFi? Looks like corruption, or anti virus deleting critical file(s)

    In your situation I would uninstall HitFilm via programs & features and download it again. Toss the installer you already downloaded

    When was the last time it was working, and whats different now?

  • PaulStarrPaulStarr Website User Posts: 18 Just Starting Out
    edited October 2020

    Thank you for your response. I downloaded on ethernet cable.

    I literally deleted v15 of Hitfilm this morning because I was getting exactly the same error. But when I loaded v15.1 I received the same error again, as posted. I know it is exactly the same error because I screen shot them both.

    I've had this error since 8 August 2020 when I originally loaded v15. The software still loads after the error. I waited for the update to see if that solves it, but it didn't, which is why I'm asking now.

  • [Deleted User][Deleted User] Posts: 0 Enthusiast
    edited October 2020

    Ok then, since august, that's a pretty long time.

    Do you know what CCleaner is? It's a tool which helps keep Windows more tidy and organized. You can use this tool to clean your registry and that's what I recommend you should do.

    Uninstall HitFilm again before running CCleaner so it'll also catch your current installation

    Right under the clean tab there's a registry tab. Check box everything and clean.

    Download and install HitFilm again, does the error appear?

    If it does, please list your PC specs, Windows tab/search -> dxdiag -> Save. Once saved locate the .text file and copy and paste the contents here.

    The actual clean tab is more for getting rid of unused space, cache etc. It can also cause issues with passwords and browsers, if you're not sure what it does after checking certain boxes. I don't recommend using it for other cleaning than cache and leftovers.

  • PaulStarrPaulStarr Website User Posts: 18 Just Starting Out

    I did some research and it seems the error is associated with the driver for GeForce video card. It says it needs updating. When I tried it my drivers are up to date. I’m trying the GeForce website now.

  • [Deleted User][Deleted User] Posts: 0 Enthusiast
    edited October 2020

    Good, it might be as easy as that.

  • dappergeniusdappergenius Website User Posts: 1 Just Starting Out

    It's probably Intel and not Nvidia. Nvidia's tools keep your drivers up to date, your PC/Laptop manufacturer, however, not so much. I experienced the same issue on my Acer with an Nvidia card, and all the forum posts pointed to Nvidia drivers, but mine were up to date. After giving FXhome some negative feedback on an uninstall, I remembered rebuilding a laptop and how I installed Intel's latest DCH drivers over the Lenovo drivers that had not been updated in years.

    You will not be able to do this with Intel's software assistant. You will have to find the driver and download the ZIP file with the driver in it. Don't use the install package. This is the second link on the left side of the page, once you find your driver on Intel's site. Don't get the driver from a third party site.

    Once you have unzipped the driver, go to Device Manager and update the Intel video driver. Search for the driver on your PC and find it in the Unzipped driver folder.

    Now that the DCH driver is installed, the DLL error will go away, and you will be able to use the Intel assistant to keep things up to date, just like Nvidia does.

  • [Deleted User][Deleted User] Posts: 0 Enthusiast

    If @dappergenius suggestion isnt helping, try disbaling the integrated graphics (Intel/Radeon) all together, you don't need it.

Sign In or Register to comment.