Export Error (GL Out of memory, Bad allocation)

WeskerEnd Posts: 7 Just Starting Out*

Hello, I've been using Hitfilm Express for a while, it's really good, this free version offers more than I may ever need, thank you.

I've been creating some dumb YouTube videos, and one of them rendered at 1080p got destroyed by YT's conversion+codec artifacts, at some point it's like watching a 360p video, and I know it is not anyone's fault, that's not the point here.

Since that video, I've switched to exporting at 4K so that I can keep more of the quality. My first video had an export error, GL out of memory, at around 47%, I just restarted my computer and tried again, it worked without problems. The next video I had no problems.

Today, I haven't had any success with a new video, first I got GL Out of memory at ~10%, then I got Bad allocation at 72%, then another Bad Allocation at 98%. It's a 5m20s video, rendered at 4K/60fps, target bitrate 65Mbps, max 70Mbps, [email protected], full render takes 30~40 minutes.

There isn't much reported about this, it looks like GL out of memory is my GPU running out of available VRAM, and bad allocation seems to be my free RAM running out. The thing is, it is always random, it isn't a composite shot, or effect, or anything, which leads me to believe it's a hardware fault or some app bug.

I own a ryzen 2700x 8c/16t, GTX 1060 6GB, 16GB RAM (2x8GB @ 3200MHz). This RAM is some random chinese brand, but not only have I used windows 10's built in memory test when I first bought and installed it, today I've used a bootable Memtest86 pendrive to check the memory for errors and had none reported, and I haven't had any system crashes or game crashes to think that this would be the reason, still I made sure to check it.

Windows 10 fully updated, latest GPU drivers.

So, am I trying to do something my hardware can't handle? Is it a bug? What next step can I try to resolve this if so? When the render fails, the video is perfect up to the point it stopped, shame I can't somehow continue.

Thank you.


  • TheBenNorris
    TheBenNorris Posts: 2,042 Enthusiast

    @WeskerEnd It may be worth submitting a ticket to support to see if they can help. The "randomness" of the error could be affected by many things, including where else your RAM is being used whilst rendering.

    Are you using any effects in your exports, or are they fairly bare-bones?

  • WeskerEnd
    WeskerEnd Posts: 7 Just Starting Out*

     It's all simple edits, I have fade-to-color on the start and end (Transitions>Fade to...). The rest is picture masked + video masked, being around 28 clips each of ~10 seconds.

    I have a picture of a character to the side and a video of me using it in the middle right, 26 total.

    I didn't use the computer while rendering, no background apps or browser, I also deactivated GeForce Experience's overlay to make sure it wasn't at fault.

    Thank you for helping, I'll check when possible how to submit a ticket and do so.

  • Andy001z
    Andy001z Lord EarthPosts: 3,633 Ambassador

    Are your gpu drivers up-to-date?

  • WeskerEnd
    WeskerEnd Posts: 7 Just Starting Out*

    Hi Andy, yes they are.

  • TheBenNorris
    TheBenNorris Posts: 2,042 Enthusiast

    @WeskerEnd I would definitely suggest sending us a support ticket then, as something does not seem right and we would like to look into this more.

  • I've encountered GL_Out_Of_Memory once or twice in my exporting too. I have pretty close to same PC specs as you, Wesker. May I ask, did you ever come up with a solution?

  • WeskerEnd
    WeskerEnd Posts: 7 Just Starting Out*

     @driftwoodstudios I answered you but after editing my post it was removed.

    Anyway, I didn't find a fix, I did things to try and avoid that. At first I lowered the target and maximum bitrate.

    Second thing can't be done the same way anymore, when I finish editing and want to export, I put the project in the export queue, save it, completely restart my computer and HFE to make sure gpu vram is free, and when I opened HFE, I went straight to the Export window without loading my project.

    That can't be done anymore, the latest HFE version doesn't allow you to get to the export window without loading any project, so to solve that I just created a blank project without anything, so that I can open it and use the export window.

    I did get this error again once or twice but a computer restart helped avoid it.

    Also keep in mind I just use it to edit dumb YouTube videos, your mileage may vary if you use professional stuff.

    I don't have access to my original answer, but I think that was it, can't do anything if they didn't approve it or whatever happened.

    Hope you still find it useful, good luck.

  • cronixxs
    cronixxs Posts: 1

    I have this same problem, Im going to restart my pc (specs rtx 2060, ryzen 5 3600, 2x 4 gb 2411 speed)

  • I have a GL_OUT_OF_MEMORY bug on a 1080p video that's 3 minutes long. my specs are GA_78LMT USB 3 Fx-6300 GTX 1650 super 4gb     8gb 2300mhz Corsair vengeance ddr3 RAM. And I don't think the power supply has anything to do with it but just for specs its a 500W EVGA 80+ bronze. I haven't encountered this error before and for some reason the error popped. I need help finding a fix to this as i upload often and really want to get this video out. Thanks 

    From David

  • Andy001z
    Andy001z Lord EarthPosts: 3,633 Ambassador

    Hi thread, while the forum is a great place to get loads of help problems like this often need FXhome support, having a support ticket if the best way of getting a response from the team at fxhome. Find looks to the support ticket logging on this site or I have out a handy link on my Vfxlists site https://tagpacker.com/user/VFXLists?t=Hitfilm_Support

  • Stargazer54
    Stargazer54 Posts: 3,967 Ambassador
    edited June 2020

    @lesleyelias Make sure to do system updates including GPU drivers.  Failing that contact support

  • fxhomer276313
    fxhomer276313 Posts: 1 Just Starting Out

    This bad allocation problem has been driving me crazy on a 10 minute simple video project of mine. Finally, I changed the power and sleep settings in my computer and extended them to an hour. I found that my computer was going to sleep during the rendering process and may have limited access to memory and processing power at a critical time. It may have been luck. But that is what worked for me.

  • Triem23
    Triem23 Posts: 20,412 Power User

    @fxhomer276313 Ack! Y'know that's actually one of the things written on my list of "first step troubleshooting" that I often overlook.

    And you're right - computer going to sleep in the middle of a render will absolutely mess things up.

  • sbeben
    sbeben Posts: 1 Just Starting Out*

    I was having this exact same problem exporting a relatively short project. I gave up and decided to split the project but when I went to the end of the video to get the second half I realized that I had forgot to set the contents, which meant the Hitfilm was exporting more than it had to. It was only like 10 seconds but it was the difference between not being able to export at all, to a slow, successful export. Basically what I'm saying is just remember to check you set the contents.