Cannot drag & drop media onto the timeline

Nuwanda HamburgPosts: 177 Enthusiast
Good evening & sorry to bother you.
I just bought Hitfilm and cannot place a video sequence onto the Editors timeline.
I checked the Project setting - they are matching the video properties.
If I am now try to drag&drop a sequence onto the Editors timeline I only see some kind of "prohibition sign" (is it called like this??). I watched the tutorials and cannot see that I'm making anything different like shown there.
(I run Hitfilm Ultimae Full Version on a Win7 64bit PC.)
Many thanks for your kind replies.


  • SimonKJones
    SimonKJones Posts: 4,370 Enthusiast
    Hi Nuwanda, sorry to hear you're having problems.
    Please check out this article and let us know if it helps:
  • Nuwanda
    Nuwanda HamburgPosts: 177 Enthusiast
    Hi Simon,
    GREAT - now it works ! Thank you :D
  • IamJoshuaDavies
    IamJoshuaDavies Staff Posts: 363 Staff
    Great to know Nuwanda - let us know how you get on with the software. Be sure to check out the roadmap video below for more information on some of the things we'll be working on over the coming days, weeks and months. :)
  • just to add I too had this problem and was confused as all hell as to why it wasn't working! also wasn't allowign me to put in effects or properly play with my camera track/ but i've switched off the tablet features and sure enough it works. PHEW!
  • SimonKJones
    SimonKJones Posts: 4,370 Enthusiast
    Good to hear, Uber. We're working on a proper fix for the drag and drop issue - it's a strange one!
  • chr
    chr Posts: 1
    Hi Guys,
    I was having this same problem and This is the only thread which seemed to have a solution, However, The link that Simon posted appears to be broken; it just takes me to the "your questions" page on my hitfilm profile could somebody please post the instructions on how to fix this or direct me to where I can find the answer? 
  • SimonKJones
    SimonKJones Posts: 4,370 Enthusiast
    This bug was related to Wacom tablets, which were preventing drag and drop from working correctly in the program. This was fixed quite a while back, so it's unlikely that you're encountering the same problem unless you're running a VERY old version.
  • KozmoMod
    KozmoMod Posts: 1

     Can someone tell me the fix? When I click the link, it just takes me to which is just I list of my questions. I cannot view the article. I am running HitFilm 4 Express. I too get the black prohibition sign when I try to drag a video to the timeline. I do use a Huion H610 Pro.

  • NNxTricky
    NNxTricky Posts: 1
    edited January 2017

    I cant drag on and drop either please help

  • I'm having the same problem .Can't drag videos .Please help


  • Silafiann
    Silafiann Posts: 1
    edited March 2017

    Is there a Hitfilm staff aroud here ? I have the same probleme using Express it says "invalid media" and in properties i can see "The media couldn't be imported" :/
    It's in ".MOV" and the properties are matching (29.9 fps ; 1080px720p)

    thanks for your help !



    EDIT: Since I installed Quicktime and did a copy (duplicate) of the files, it magiccallyy works ! don't ask me why or if Quicktime is necessary but now it works, hope it will help you !

  • Triem23
    Triem23 Posts: 20,280 Power User

    @Silafiann Quicktime is absolutely required for MOV files, so it's a good thing you downloaded it! 

  • saraah
    saraah Posts: 2

    I'm having the same problem, but the link Simon sent wasnt found??

  • CedricBonnier
    CedricBonnier Posts: 1,235 Staff

    @saraah Could you try to right click the HitFilm icon and run as administrator?

  • CedricBonnier
    CedricBonnier Posts: 1,235 Staff

     @saraah could you please contact support if you haven't done so already?

  • Aladdin4d
    Aladdin4d Posts: 2,466 Enthusiast

    @saraah If you're running Windows, are you able to drag and drop files using file explorer like normal? I don't know if it would affect HitFilm or not but I just ran into a problem where you couldn't drag and drop anything in Windows. The fix was left click on a file and hold it, then tap the Escape key.

  • mariamusiclover
    mariamusiclover Posts: 2
    edited December 2017

    I think I might have figured out why some people get that "prohibition sign". I also experienced it.

    I like playing video games and I like recording my gameplays. When I tried editing my recorded gameplays, I couldn't drag and drop the video file in the editor timeline. My screen recorder recorded everything in wmv format. However, when I tried putting another type of video file (mp4) in the editor timeline, it worked. I was able to drag and drop it there.

    So,  I'm guessing it has something to do with the type of video file (which in my case, is kinda bad cause my screen recorder can  only record in wmv)

    I'm not sure if this is important, but I think I should mention that I'm using Hitfilm 4 express (update 8) on a window 10 PC.

    By the way, how do you update hitfilm?? in case the version I have isn't the latest version, how do I update it? usually softwares, have a button that says "update software" or something like that, but I can't see anything like that in hitfilm's menu. (sorry if this is a stupid question, I'm a newbie)

  • Triem23
    Triem23 Posts: 20,280 Power User


    Yes, Hitfilm can't accept WMV. You have options: you can transcode or change screen recorders.

    Recent generations of both AMD and Nvidia GPU ship with free screen recording software you might already have. OBS is free, BB Flashback has a free version. Other users might have other suggestions.

    Hitfilm Express 4 is end of life. The current version, Hitfilm Express 2017 is a separate product, not an update to 4. You can download it for free by going to the menu, top right of the page, and selecting Hitfilm Express. If you have add ons make sure you download Express 2017 with the same email you used for Express 4. This way existing add-ons should move forward to the new version. 

  • CedricBonnier
    CedricBonnier Posts: 1,235 Staff

    @mariamusiclover @Triem23 HitFilm has always supported .wmv videos. Usually this codec does not perform well so it is a good idea to transcode but it does work. Are you able to play the video in the trimmer panel?

    You can get the latest version of HitFilm Express by following this link:

  • Triem23
    Triem23 Posts: 20,280 Power User

    @CedricBonnier 1) I stand corrected. 2) I'm an idiot for standing corrected, because I ALMOST double checked the specs page, but didn't. 

  • @CedricBonnier

    Nope, I couldn't play the file in the trimmer panel. In the end, the only way I was able to edit my gameplay, was by converting the file from wmv to mp4 :D


    I guess, you right :) I might have to convert the wmv files or change screen recorders. I'll try the OBS.

    Thank you very much for your suggestions :)

  • ami3
    ami3 Posts: 1

    I hope someone is still active here. I cant actually click and drag my music track to the master thing. I can't explain, but I'll try to click and drag but I just can't. It doesn't move the music track. It's not my mouse or my trackpad. I just simply can't. I really want to know why? I don't want to have to download a different version. I don't know if it's because I'm on a mac? Please help.

This discussion has been closed.