Artifacts in exported footage

Robin
Robin Posts: 1,659 Enthusiast
edited August 2011 in Post-production techniques
Well I just rendered a short clip for my next Brickfilm. It looks really awesome, thanks to Hitfilm, and viewing it in the Windows Media Player gave no problems. But when I imported it into Sony Vegas, it had very strange artifacts over a couple of frames, which I highlighted in this screenshot (You have to view it in full size to see them):
[IMG]http://img6.imagebanana.com/img/t7ko0e3k/thumb/vegas_fail_markup.png[/IMG]
Exact information about the render:
MP4, H.s64 (obviously, as there is no other codec yet), 8 seconds, 1280x720, 15fps, progressive, square pixels, 24-bit RGB, (project is set at Color Bit Depth: 8-bit integer), Profile: Main, Level 4.0, Variable Bitrate, 1pass, Target 10 Mbps and Max 15 Mbps.
No sound.
If it helps diagnosting the problem, I can provide the project file, but it might be quite big with all attached media.

Oh and yes, I love explosions... :3

Comments

  • SimonKJones
    SimonKJones Posts: 4,370 Enthusiast
    edited August 2011
    Looks like rather extreme compression artifacting. If you import the file into HitFilm, do you see the same glitches?
  • compression problem maybe try to save and render your prject on Hitfilm and finally import your new file on Sony ?
  • Robin
    Robin Posts: 1,659 Enthusiast

    Looks like rather extreme compression artifacting. If you import the file into HitFilm, do you see the same glitches?
    No, they aren't visible in any other program I tried, including the Windows Media Player, the VLC Player, the Quicktime player and HitFilm... Only Sony Vegas seems to have this problem.
    Also as I said, they are only visible for about 3 or 4 frames in the middle of the video, everything else is fine... But these 3 or 4 frames still are really visible and annoying, especially as I'm filming my stop motion in 15fps.

    compression problem maybe try to save and render your prject on Hitfilm and finally import your new file on Sony ?
    Uhm, not sure what you mean by that... I rendered the video in hitfilm and then imported it into vegas, that's what I did...?
  • RossTrowbridge
    RossTrowbridge Posts: 399 Enthusiast
    Is this happening inside Vegas in the Video Preview window? Or is this happening in your output file from Vegas? If it is in the Video Preview window, make sure your preview setting is set at Best>Full. Otherwise you'll see video degradation in that window. But Vegas will still output okay. If it is happening in the exported file, you will need to tweak your compression settings.
  • Robin
    Robin Posts: 1,659 Enthusiast

    Is this happening inside Vegas in the Video Preview window? Or is this happening in your output file from Vegas? If it is in the Video Preview window, make sure your preview setting is set at Best>Full. Otherwise you'll see video degradation in that window. But Vegas will still output okay. If it is happening in the exported file, you will need to tweak your compression settings.
    Well I didn't test that before so I tried it now, and in the rendered file the artifacts are there, but also the every second frame seems to be just a blank green frame in the rendered video... o.O
    Oh, and I also noticed that this problem is reproducable, I got it again after I rendered the video in HitFilm again. :/
  • SimonKJones
    SimonKJones Posts: 4,370 Enthusiast
    If it's only showing in Vegas it would seem to be an issue with how Vegas is handling the mp4 compression. Have you tried changing the mp4 settings when exporting?
  • Robin
    Robin Posts: 1,659 Enthusiast
    Have you tried changing the mp4 settings when exporting?
    I thought about that but didn't simply because I just didn't know what settings to change and how... Any suggestions on that?