Trying to add a HitFilm Effect to Movie Studio

JowaMoJowaMo Website User Posts: 7
edited August 2015 in Post-production techniques

In Movie Studio Plat 12.0 I am trying to "add a Hitfilm effect", but I keep getting the same error:

"An error occurred during the current operation. The file could not be created."

I have tried doing this with Hitfilm running in the background and not running, but it still doesn't work.

I am using MSP 12.0 and Hitfilm Express v. 2.0.3010.30403 64bit. I am running this on win8.1-64.

Any ideas?

Comments

  • JowaMoJowaMo Website User Posts: 7

    I have Quicktime player vs. 7.7.8 installed.

    I have both HF and MS installed on my D drive, and I have moved all the cache/temp/projects/etc.. folders over to D as well. Could this be causing an issue?

    My C drive is an SSD. So I try to keep as many programs off of it as possible.

  • JowaMoJowaMo Website User Posts: 7

    Ok for some reason it is just not working in the MS project I have been working on. When I start up a new MS project it works fine.

    Something go screwed up with that project, and it wont allow HF to start.

    I had originally installed both programs on my C drive, and then I changed my mind and reinstalled them on my D drive, but I started that project while both programs were still on the C drive.

    Could that have messed things up? Is there a way to unmess it up, or do I jsut have to start from scratch?

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,228 Ambassador

    I see two possible things going on. First is that moving the programs broke the linking (BTW, when installing MS and HF make sure you install VEGAS FIRST! Otherwise the Hitfilm plug-in architecture won't install correctly. So it's also possible that when you'd installed on C initiall you put in Hitfilm first, then Vegas.

    If in doubt, uninstall, run a registry cleaner, then re-install.

    The second possibility depends on what media you were trying to send to Hitfilm. Hitfilm can only accept actual video files and picture files from Vegas. Vegas cannot send anything involving Vegas generated media to Hitfilm--so if, for example, you were trying to send a Vegas Text object to Hitfilm for processing, well. You can't. ;-)

    Once you get everything working, don't forget that Vegas looks at the Hitfilm project's EDITOR timline and NOT at any composite shots. So, whatever you want to bring into Vegas from Hitfilm, make certain it's on the editor timeline.

    @SimonKJones I had the same issue on my PC (i72470QM @2.4 GB, NVidia 580GTXm 2GB, 16 GB RAM, Windows 7 Pro 64-bit) with Hitfilm Pro and Express 3. In my case the issue was solved by adding the Youtube account over and over again. eventually it took. I'm also having another issue where, about half the time, a YouTube upload ends with an "Upload Error" message from Hitfilm, although the file has actually uploaded correctly.

  • JowaMoJowaMo Website User Posts: 7

    It appears that HF can't do anything with cuts made from the trimmer. I guess that is what you meant by "Vegas generated media."

    I can use HF effects on split clips with no issue, but not the trimmed ones.

    I should have spent some time on tutorials and such when I started with MS and HF, but both programs were so intuitive I just ran with them. This is the first real issue I have had with either.

    I will probably be upgrading to the pro versions of each program the next time I see a good sale drop.

    Thanks for the help.

     

  • NormanPCNNormanPCN Website User Posts: 3,945 Enthusiast

    Vegas 12 did, maybe still does in 13, have a bug in that it cannot use the the "add Hitfilm" effect to subclips. Simple trimmed clips were fine, so maybe you created a subclip from the Vegas trimmer window and used that, as opposed to simply sending trimmed media to the timeline.

  • JowaMoJowaMo Website User Posts: 7

    That is exactly what I did. All the clips I made were from the trimmer. 

    That's why it felt like something was broken, because I couldn't get any of them to work right.

    and knowing is half the battle..

    Thanks again.

  • Aladdin4dAladdin4d Moderator Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,509 Enthusiast
    edited August 2015

    @JowaMo Eye Scream Factory/Mac Video Promo just dropped a good sale on HitFilm 3 Pro - 50% off so $149.50 instead of $299.00. Even though it's Mac Video Promo the sale is good for either Win or Mac versions.

    http://www.macvideopromo.com/products/hitfilm-3-pro-for-mac-or-win?mc_cid=f3dc668f84&mc_eid=99459db48b

     

  • NormanPCNNormanPCN Website User Posts: 3,945 Enthusiast
    • "All the clips I made were from the trimmer. "

    You can use the trimmer to trim your media to the timeline. Just don't create a subclip from the trimmer. Then the Hitfilm integration should work.

  • icc7icc7 Website User Posts: 8

    "Eye Scream Factory/Mac Video Promo just dropped a good sale on HitFilm 3 Pro - 50% off so $149.50 instead of $299.00. Even though it's Mac Video Promo the sale is good for either Win or Mac versions.

    http://www.macvideopromo.com/products/hitfilm-3-pro-for-mac-or-win?mc_cid=f3dc668f84&mc_eid=99459db48b"

     

    Can I buy from that website?

Sign In or Register to comment.