How To: Copy / Paste Mask

BriReddBriRedd Website User Posts: 98 Just Starting Out
edited August 2015 in Post-production techniques

I've created a mask on an image layer and I want to copy and paste the same mask onto a grade layer.

Using the Controls panel, I've located the mask I want to copy and right click to choose "copy".  Then I locate the empty mask layer for the grade layer and "paste".  Though it looks as if the mask has been pasted in place in the Control panel, there is no mask in the viewer.

I'm I approaching this correctly? 

Comments

  • StormyKnightStormyKnight Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,726 Ambassador
    edited August 2015

    What you'll want to do is- in the layer panel, select the mask you want copied, right click, select copy. Now go to your grade layer and where it indicates 'masks', right click on 'masks' and paste. If you want to add more masks to the grade layer, always paste by right clicking on 'masks' and the new mask will be placed below the previous ones in the 'masks' list.

    Hope that helps!

  • BriReddBriRedd Website User Posts: 98 Just Starting Out

    @StormyKnight - Thanks for the reply.

    I've tried copying and pasting in both the Control Panel & the Layers Panel - still not working. It looks like a mask is pasted in the panel but the viewer doesn't show a mask or the effects the mask would have.

    If I highlight the original mask, the outline shows up in the viewer. If I highlight the pasted mask - nothing. Seems pretty straight forward but it's not happening.

    Scratching my head on this. 

  • BriReddBriRedd Website User Posts: 98 Just Starting Out

    Ok, I found what's happening: the image layer was scaled down before creating the first mask. Now when I copy and paste this mask, it comes in at the unscaled size of the image. So, the mask must take on the original proportions of the layer regardless of it's current size in the viewer. After pasting into a grade layer, the mask is huge and has to be scaled down to fit (all of the measurements / settings of both mask are the same after pasting yet one is huge?).

    Is this normal behavior?

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,281 Ambassador

    Yea. By scaling the image down first, you gave the mask a default internal size of 100%, based on the relative scale of the parent layer. 

    So, you scale a 4000x2000 image down to 2000x1000 (25%). You copy the mask, paste it into the 1920x1080 (100%) grade layer and the mask thinks it needs to scale up because it's parent went from 25% to 100%.

    Solution. Change your viewer to "Layer" Mode. Then you are basically drawing your mask at 100% zoom. Then it will scale properly. 

  • BriReddBriRedd Website User Posts: 98 Just Starting Out
    edited August 2015

    @Triem23 - Thank you!

    What I'm trying to do is have a couple of layers use the same mask shape and have the mask stay the same size even if I scale the layer up or down.

    I've tried creating a mask on a separate Plane layer and using the "set mask" effect (on the layer I want masked) to designate that Plane layer as the mask without luck (no masking). Not sure why.

    Suggestions anyone?

  • NormanPCNNormanPCN Website User Posts: 3,945 Enthusiast

    "Set Matte" accesses the layer before masks and effects. You can put a grade layer just above the layer you want "flatten" the masking and such and then reference the grade layer in Set Matte. I learned this method from a Hitfilm tutorial project. Or make the layer you want to flatten an embedded composite.

     

  • RobinRobin Website User, HitFilm Beta Tester Posts: 1,671 Enthusiast

    @NormanPCN is right. The grade layer approach works fine and lets you still keep all the layers on one timeline, but it's not as flexible as the pre-comp approach when you're dealing with a lot of effects and layers.

  • BriReddBriRedd Website User Posts: 98 Just Starting Out

    @NormanPCN, @Robin - Thanks for the replies!

Sign In or Register to comment.