How to STOP particles (solved)

LupusbaloLupusbalo Website User Posts: 37

I have a particle system emitting - say 10O particles on the first second then become inactive.
So I have 100 part. now (life is say 30s) which are moving around (whatever moves they have)

At some stage I want to STOP them all completely
- setting speed to 0 did nothing (BTW don't understand why!!)

Any idea?

Lupusbalo

Comments

  • RobinRobin Website User, HitFilm Beta Tester Posts: 1,671 Enthusiast

    Keyframing the speed to 0 will only affect particles that are spawned on/after that keyframe. If you want to stop particles later, you have a few other possibilities.

    • I assume you want them to stop all at once, so basically freeze the complete effect. The easiest way to achieve this would be to keyframe the "Time Scale" property under the "General" group of the particle simulator layer. Using constant keyframes, having it at 100% and then drop to 0% will freeze the effect at that point. Using linear or smooth keyframes you can also gradually make them stop.
      You could also use a more complicated system utilizing mobile emitters and killing them off with a keyframed force, but for just freezing the effect this is probably a little bit overkill.
    • If you want them to stop individually after they have lived for a certain amount of time, you have to adjust the speed curve in the lifetime panel (you might have to make that panel visible by clicking the 9-squares-grid icon next to the undo/redo-buttons and selecting it). That way you can alter almost all properties of particles over their individual lifetime.
  • StormyKnightStormyKnight Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,726 Ambassador

    Do you want a sudden stop or gradual?

    I don't know if the particle emitter can freeze particles in one place but you could, at the point where you want them to stop, export one frame and bring the PNG file back in at the exact point where they stop. This wouldn't work if you intend on moving the camera around though as the content of the PNG frame wouldn't be in 3D space.

    Or another option that's a little easier, create a new composite shot and bring in the composite shot containing the particle simulator. Add the speed effect to the new composite and key frame the first frame at it's default. Set a second key frame just before the frame where you want the particles to stop and keep the same speed. Advance 1 frame and set the speed effect to 0. If you want a gradual stop then advance however many frames you want before setting the speed effect key frame to 0

    Hopefully this is what you're looking for. I'm sure someone else will chime in with another way. I'd be interested to see if there's a way to keep the three dimensional aspect so one could move the camera around or through the particles

  • RobinRobin Website User, HitFilm Beta Tester Posts: 1,671 Enthusiast

    @StormyKnight And there, another two methods. :D Although I'd say your second method is the same as my first, just using the speed effect instead of the timescale in the simulator itself.

    In the end, many roads lead to rome, just try them and see what works best!

  • StormyKnightStormyKnight Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,726 Ambassador

    Robin - LOL......when in Rome........

  • LupusbaloLupusbalo Website User Posts: 37
    edited May 2015

    well guessed, Yes! initialy, I intend to move the camera around particules
    You just confirm that particules are not 3D, that's what I discovered lately!!
    anyway your methods definitely work .... and I'll keep them both

    thank you all, guys!

    I'd try something else to have 3D!

    Lupusbalo

  • RobinRobin Website User, HitFilm Beta Tester Posts: 1,671 Enthusiast

    @Lupusbalo Well actually the particle simulator is completely 3D, you can freely move the camera through them, it's one of the things that made HitFilm unique from the start. How do you come to the conclusion the particles are not 3D?

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,303 Ambassador
    edited May 2015

    @Robin,while the particle sim calculates positions in 3D space, with image-based textures, the individual particles are 2D objects. With the desired camera move, he may be seeing particles flattening as the camera rotates. 

    He could try making sure the particles billboard to camera (but that's not always how one wants the particles to align) . 

    And, of course using a 3D model as the particle texture results in truly 3D particles. 

    That said, in software like Trapcode or Particle Illusion, it's the same-2D image particles in 3D space. Element 3D uses 3D models as particles, but can't use image textures, so, really Hitfilm's ends up being your best, most flexible system, overall. 

  • LupusbaloLupusbalo Website User Posts: 37
    edited May 2015

    @Robin, as Triem23 said particules system is 2D simulating 3D

    the exemple below will show what we mean:
    a 3D model, plus 4 particules with a layer texture (1 frame)
    and a camera rotating around the scene

    https://www.dropbox.com/s/i2qxloz9ftqkmzq/test particules as layers with moves.mp4?dl=0

    @Triem23, I was wondering if this solution would work
    I'll try it ASAP (a 3D model as particule texture)

    Lupusbalo

  • RobinRobin Website User, HitFilm Beta Tester Posts: 1,671 Enthusiast
    edited May 2015

     @Triem23 Ah, of course. Didn't think of the particles themselves :D But yes, having 3D modles there is also possible, which then makes it full 3D.

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,303 Ambassador

    Lupus, I don't have time to check your project, but I bet your particles and model are compositing in 2D mode. Check the composite mode toggle to 3D Unrolled for both layers and the particles will correctly wrap and occlude the model. 

    Robin is correct that the particle sim is true 3D in true 3D space (but set your layers to 3D Unrolled!) I was just noting that image and video particles are 2D images while 3D model particles are abso-fraggin-loutely 3D in 3D.

    Hitfilm gives you the option to composite 3D models and particles as 2D layers so you can add effects directly to the object layer, or as a truly 3D unified space--but effects can't be used directly on the object: just adjustment layers.

  • Chris2014Chris2014 Website User Posts: 53

    I'd asked a similar question on the hitfilm youtube channel (but no answer) about the particles still moving whatever setting I used, following this demo:

    I looked closely at the settings on the tutorial to get the same values, but although SPEED is at zero, if I press play there's still creation and disapperance of buidings, tried different parameters, if I lengthen LIFE, it slows dramatically, and still new buildings are created. I'm missing something but what ?

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,303 Ambassador

    Chris, there's a step in the video Simon goes over very quickly: the "Particles per second" property of the emitter needs keyframes. On frame two, particles per second should be zero. On frame 1,crank it up. You want every particle to spawn on frame 1.

  • RobinRobin Website User, HitFilm Beta Tester Posts: 1,671 Enthusiast

    @Chris1014 You could use the time scale for that, too. Might have some difference performance-wise, I don't know.

  • SimonKJonesSimonKJones Moderator Website User, HitFilm Beta Tester Posts: 4,450 Enthusiast

    Sorry for not responding on YT! Yeah, the trick there is to spawn however many particles you want on the first frame, then drop particles per second down to 0 so no more appear. You can then set the lifetime to maximum so that they stick around for as long as you want.

  • RobinRobin Website User, HitFilm Beta Tester Posts: 1,671 Enthusiast
    edited May 2015

    @SimonKJones although we still have a relatively low limit for the maximum lifetime if I recall it right. Would be good to have more flexibility there in the future ;)

  • SimonKJonesSimonKJones Moderator Website User, HitFilm Beta Tester Posts: 4,450 Enthusiast

    Perhaps - the upper limit is 60 seconds currently, which is actually REALLY long for a single shot. 

  • RobinRobin Website User, HitFilm Beta Tester Posts: 1,671 Enthusiast
    edited May 2015

    For most scenarios, fair point, and you can probably extend it artificially by using the time scale (I find myself mentioning that control quite often lately :D ). I'm thinking of a few situations where you would have a slow simulation (clouds or something like that) in an extended static shot, where you'd additionally use timeshift to have all particles at the beginning, so that cuts off the lifetime too. But yeah, that's situation is quite artificial, so I guess :I'm just an idealist :D Is there any technical reason though to even have a limit on it?

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,303 Ambassador

    100,000 particle per second cap, if I remember rightly with a 60 second lifespan means each emitter can have 6 million active particles. On my system, I have maxed out my GPU with far less than that. My guess is it's a semi-arbitrary limit, but done so innocent users don't crank things up and make their GPU suicide in despair... 

    But, with Time Scale, Robin did find a workaround. 

  • RobinRobin Website User, HitFilm Beta Tester Posts: 1,671 Enthusiast

    Hehe, I couldn't resist trying that out. Put the default particle simulator in a comp, maxed out lifetime and particles per second. I then just jumped to a frame somewhere around 1 1/2 seconds in... Took 10 seconds for HitFilm to respond again, then the viewer was just all white, another 10 seconds and it showed a dense ball of white particles. I didn't dare going down further on the timeline though :D

  • Chris2014Chris2014 Website User Posts: 53

    brilliant, thanks!

Sign In or Register to comment.