Very strange Vegas 12 artifacting.

NullUnit
NullUnit Posts: 791 Just Starting Out
edited February 2015 in Practical Filmmaking

I have a strange and very frustrating problem that just appeared on Vegas 12. I bring it up in these forums because so many of us use Vegas and this forum is better than Vegas's.

I have a video clip shot on a Canon G10, mts format. I put it directly into Vegas 12 without converting it, which always works fine. I edit tons of work video this way with no problems. This time, in a specific spot there is a green band of artifacts that appears across the bottom of the clip for 3 or 4 frames. It looks a lot like the type of artifacts you might get from digital tape in the old days (this clip was shot on memory card). It appears in the same place every time and also appears on renders.

Here is the catch: This artifact does not appear if I play the same clip in VLC media player or windows media player on the same computer. This problem also does not appear if I play the clip on a different computer, even if I play it in Vegas 12 on that computer! So, its only happening on this particular clip on Vegas 12 on this particular computer.

Any ideas why this would be happening? I rebooted the computer, of course and I also reinstalled Vegas 12. My video card drivers are also up to date.

Comments

  • rgbii
    rgbii Posts: 965 Just Starting Out
    edited February 2015

    That is strange.

    Just going to throw out a few things.

    Whatever setting you have for GPU usage in Vegas, toggle it the other way.

    Latest drivers? Build of Vegas?

    As a work around, can you render it to DNxHD with something that doesn't exhibit the issue?

  • duffman
    duffman Posts: 235 Enthusiast

    Is the clip in question still on camera? If so try saving it to a different location.  How did you port it over to the computer from camera? Did you use the Vegas Device Explorer?  It can be found under the view menu or via CNTRL-ALT-7. I work with Canon MTS files.   Have had problems from time to time when I use the Canon utility to port my files. Lines in frames and edge jitters. I don't use it anymore. @rgbii lists a good point 12 never has liked having GPU acceleration, try turning it off.

  • NullUnit
    NullUnit Posts: 791 Just Starting Out

    duffman/rgbii - I actually copied it off the card with the canon utility that exports and muxes the files. The software that comes with it, pixalia or something like that. Yeah, its very clunky, but has always worked ok for me.  I didnt know vegas can do the same, though I used to use vegas to bring in video from my old digital tape camera on firewire. I'll try it in the future. Does vegas mux (combine) the files? I also did have gpu acceleration turned off.

    I ended up working around it by editing the file on a different computer running vegas 12. It worked out ok, but I really hate problems like this because they are so random and unexplainable. Reminds me of the bad old days of video.