hitfilm 3 viewer zoom problems

I would like to see my entire shot in composite mode (like the layer option displays) , but the viewer only shows a cropped frame.

Is there a way to make the viewer show the entire frame like the layer option does?

Comments

  • AxelWilkinson
    AxelWilkinson Staff Administrator, Imerge Beta Tester, HitFilm Beta Tester Posts: 5,249 Staff
    edited February 2015

    You can change the Zoom level of the viewer, using the Zoom menu in the bottom right corner (the magnifying glass and numbers). The viewer always shows your entire shot, unless you zoom in to a level where the whole shot won't fit in your Viewer window.  Select the Scale to Fit option in the Zoom menu, and your frame will fill the viewer window, whatever size you have the Viewer set to.

    I'm not entirely sure that's what you are asking, but hopefully it helps.

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,795 Ambassador

    Sounds like your media is larger than your composite shot. Use the transformation controls for your media layer to scale it down to fit. 

  • bryannelson
    bryannelson Website User Posts: 5

    ah yes! It was a scale problem ahah, thank you both for your help!

  • Mikival
    Mikival Website User Posts: 2

    I wonder why I cant do that! I tried "scale to fit" but the video isn't like the trimmer one!!! In the trimmer I see a full frames video, like I recorded it.In the viewer I see just a part of the video, it is like zoomed. Like I said before, I' ve tried scale to fit in both (trimmer and viewer) but in the last one i see the image zoomed.

    what should I do?Im a beginner in editing and its the first time with HitFilm :)

    sorry for my bad English

  • Mikival
    Mikival Website User Posts: 2
    edited September 2016

    I menaged to do it, but the quality between the two videos (trimmers and viewers) isnt the same... how can I do to get an identical video?

  • earshad86gmailcom
    earshad86gmailcom Website User Posts: 1
    edited September 2016

    I'm having the same issue. Was watching this tutorial  " how to convert photos to incredible 3D screens" and every time I create a new composition, the image is wayyy too zoomed in. Tried this with express and the hit pro trial. Tried this with personal images as well. This is extremely frustrating - help!

  • Cervier
    Cervier Website User Posts: 156 Just Starting Out
    edited September 2016

    earshad86gmailcom My guess is your picture is bigger than what your timeline is set to receive. For instance, if your project settings are 1080p, that's 1920x1080 pixels, but the picture you want to work with is, say, 6000x4000.

    So the trimmer will scale down its display to something like 12% so you can see all of it, but that's just so you have an idea of what your media is.

    Then you put it into a comp whose "real" workspace is 1920x1080. That viewer will display a "1920x1080 window" of your 6000x4000 image. And the scaling drop-down box at bottom right of the viewer doesn't scale your media, but the display.

    So if you want your whole image to fit inside the 1920x1080 settings, you must select it on the timeline, go to the CONTROL tab, Transform and change the scale there.

  • AxelWilkinson
    AxelWilkinson Staff Administrator, Imerge Beta Tester, HitFilm Beta Tester Posts: 5,249 Staff

    @earshad86gmailcom - that tutorial requires the Pro version of HitFilm, as it uses resolutions well above the 1920 x 1080 limitation of HitFilm 4 Express. Is it possible that you are using the Express version of the software? If so, you will need to reduce the scale of the image layers in order to fit them into the available space.

  • KARKINOS
    KARKINOS Website User Posts: 1

    i had the same problem  but for me it was cause i had my tv connected as an external display (which i didn't use for hitfilm) so as soon as i disconnected the tv it worked perfect.

  • OscarUnique
    OscarUnique Website User Posts: 20

    Incredible HitFilm doesn't have custom zoom in the viewer. This program lacks lots of practical functionality, use of wheel on the editor, volume control on the trimmer, and on an on.

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,795 Ambassador
    edited August 2017

    @OscarUnique mouse wheel is custom zoom in the viewer window, along with the menu in the lower right. As a dev pointed out to you the mouse wheel has different functionality for the mouse wheel on the timeline depending on if you are holding down CTRL or ALT/OPT on the keyboard. FCPX, Avid, Premiere, Vegas Pro and Resolve all lack volume controls in the Trimmer, so I don't see the issue there (the Trimmer by default plays volume back at 100% volume. If things are too quiet on the Trimmer, that's badly recorded audio. 

    Now, do you have to keep reposting the same complaint in different threads every couple of days, especially since 3/4 of your complaints are incorrect (and previously answered) and your 4th complaint is about a feature most NLEs don't have? 

    Rather than dragging up two-three-five year old threads, I would suggest the Wishlist Thread is the proper place for feature suggestions. 

    https://hitfilm.com/forum/discussion/38770/the-hitfilm-wishlist-what-features-do-you-want#latest