Rename doesn't always work.

rgbiirgbii Website User Posts: 965 Just Starting Out

I've noticed recently if I've been in HF3Pro for a while, if I right click and select 'Rename', it doesn't let me rename it - it behaves as if I didn't select rename. Once this starts to happen, it continues to happen until I exit HF3Pro and open it again. It always works fine when I've recently start HF3Pro, it's only after I've been in it a while that this starts to happen.

Anyone else noticing this issue?


  • Stargazer54Stargazer54 Moderator Moderator, Website User, Ambassador, HitFilm Beta Tester Posts: 2,723 Ambassador

    Haven't notice that, but I use F2 most of the time to rename.   See if it still happens when you hit F2.

  • rgbiirgbii Website User Posts: 965 Just Starting Out
    edited February 2015

    Yes, I have tried to hit F2 and didn't get a response once it starts to happen.

  • SimonKJonesSimonKJones Moderator Website User, HitFilm Beta Tester Posts: 4,450 Enthusiast

    I've not encountered this. Are you able to create reproducible steps to make this glitch kick in? Is it after doing a particular series of actions, or is it a time-based thing (eg, it happens after 30 minutes)?

  • duffmanduffman Website User, HitFilm Beta Tester Posts: 235 Enthusiast
    edited February 2015

    Was just working on a project and had this happen. It seems it happen after you get  X number of  layers.  I wasn't paying attention to when it started but I had : 5 layers, a light,  2 points, all set to 3d. Had all of these on timeline went to change the names of the points, trying both F2 and the menu, nothing....


  • rgbiirgbii Website User Posts: 965 Just Starting Out

    @SimonKJones I haven't noticed anything other than I know I've been running it for a while, but can't say for sure it's time based.  Since 3 Pro came out, I've worked on a number of smaller, quicker projects, but recently am on a larger project where I'm doing more and spending more time in it. 

    @duffman when I notice it I do have a lot of layers, but if I exit and come back in, I can rename again, even if it has a lot of layers.

  • duffmanduffman Website User, HitFilm Beta Tester Posts: 235 Enthusiast

    @rgbii...the same. Close the project and re-open then rename works.

  • rgbiirgbii Website User Posts: 965 Just Starting Out

    @duffman did you stay in HF and just close/open the project, or did you exit HF? 

  • rgbiirgbii Website User Posts: 965 Just Starting Out
    edited February 2015

    I have more information on this, though the steps below are intermittent in producing the problem. For me, they'll do it most of the time, though occasionally I can get it to happen a lot.

    Seems to have to do with which window/panel has focus.  If the layer window doesn't have or get focus when you right click on a layer, it's not going to let you rename. I've been able to reproduce this both on Windows 7 and Mac.


    Start HF3Pro and create a new composite.

    Float the viewer panel (this is  a MUST for the problem to occur). Make sure you can see the layer name/control area.

    In the composite, add a plane.

    From here down, don't do any extra clicking, other than what's mentioned.

    Click in the viewer's panel tab bar, but not on a tab (not the title bar, the unused area to the right of the tabs).

    Click on the viewer tab.

    At this point, the viewers tab bar should be blue, indicating it has focus.

    Right click on the plane layer name. If the layer tab bar changes to blue, the rename will work, but if the viewer tab bar stays blue, clicking on rename will not work.

    There seems to be a couple of ways this can happen. I've also caused the problem by clicking on the viewer tab, then clicking on 'preview', let it run a short while (how long doesn't seem to matter), then clicking on it again to stop it, then trying to rename.   I've also had it happen just by using the preview (without clicking the viewer tab or tab bar) when the layer panel was active - clicking the preview changed the viewers tab bar blue, but this method doesn't seem to be as consistent in causing the problem.

    Again, you know it will happen if the viewer tab bar stays blue instead of the layer tab bar changing to blue when right clicking on a layer.

    Note that now that I know what's going on, I can just click on the layer panel and get around it, but for someone that doesn't know what's going on or how to get around it, might be an issue. It's also annoying.

    While it's in this state, clicking on a layer will show it selected, but if the layer panel's tab bar is not blue/selected, things such as F2 will not work either. I think there may be other issues while in this state too.

    Here's a video showing the problem.  If you need more info or have trouble duplicating this, let me know.


  • aarondcaarondc Website User Posts: 264
    edited February 2015

    Hmmm sometimes it's not obvious where the focus is - and i hit F2 and nothing happens and then re-click on the thing I want to rename and I can now rename hitting F2.

  • aarondcaarondc Website User Posts: 264

    It can also get confusing with the blue surround seeming to indicate where the focus is when in fact it's somewhere else. Added a Wish list item based on this behaviour.

  • rgbiirgbii Website User Posts: 965 Just Starting Out

    @SimonKJones - I'm curious if you where able to duplicate this problem using the steps mentioned a few posts up. I'm able to pretty consistently get it to happen.

This discussion has been closed.