Hitfilm freezing and crashing constantly

NilsHanf
NilsHanf Posts: 3 Just Starting Out
Hello guys,
my Name is Nils and I'm using Hitfilm express for editing youtube videos for over 3 years now. I've never had any issues with Hitfilm and everything went fine so far. However since 3 months or so my Hitfilm keeps crashing, when doing most simple things like cutting video parts in half or moving clips in the timeline. It keeps freezing, then there is the pop up saying "no response"... I tried to fix the problem in several ways, I reinstalled the program, tried to troubleshoot etc.
I'm completely clueless...
My system specs are:
Ryzen 7 1700x
AMD Radeon RX590 Sapphire pulse (8gb)
16gb ram
Hitfilm is installed on a SSD
I really love video etiding and Hitfilm is just one of the best softwares for what I want to do. So before resetting my entire Windows, does anyone have a clue, whats going on?
Nils :)

Answers

  • NilsHanf
    NilsHanf Posts: 3 Just Starting Out
    (I've asked this question before, but somehow I don't have access to it anymore)
  • Stargazer54
    Stargazer54 Posts: 3,967 Ambassador

    Best is guess is the AMD gpu driver. There is a compatibility issue with newer drivers. Try reverting back to the "Recommended" AMD Adrenaline 2022.5.2 version.

  • ImAPurple
    ImAPurple Posts: 2 Just Starting Out*

    Ive been having this problem for the last couple months also. I tried other editing software and I do not like them as much as I like Hitfilm. My temporarily solution is to turn off "Hardware decoding and encoding" in the rendering settings. But I feel like this needs to be addressed and brought aware to the team at Hitfilm.

  • CedricBonnier
    CedricBonnier Lead Developer (HitFilm) Posts: 1,245 Staff

    We are being told by AMD that they are about to release a new driver update that will include the fix to hardware decoding so we are eagerly waiting on that.

    If the next update doesn't fix it we will disable hardware decoding in HitFilm for AMD GPUs. It's a bit extreme but we have been promised an update since Sept last year and there isn't much we can do other than passing the steps to reproduce to AMD and wait for a fix to be made public.

    Sorry about the inconvenience this is causing.

  • Stargazer54
    Stargazer54 Posts: 3,967 Ambassador

    @CedricBonnier Thanks for update on the AMD driver issue! I figured you guys were at the mercy of AMD and waiting on them. Rolling back the driver in the meantime is a valid fix.

    I keep thinking there should be a sticky at the top of the forum covering the issue and instructions for AMD users on how to roll back.

  • ImAPurple
    ImAPurple Posts: 2 Just Starting Out*
    @Triem23 I was not asking a question. I was simply trying to help this guy out since you seem to want people to jump through hoops to then tell them that it cannot be fixed...

    @CedricBonnier helped with an update on what's actually happening. Thank you good sir. Keep up the good work as Lead Developer. We all love the program! All aside this hiccup that is out of your control.
  • Triem23
    Triem23 Posts: 20,401 Power User

    @ImAPurple Stargazer, above had already given the OP the correct answer for the OP, because @Stargazer54 and I learned that from @CedricBonnier months ago. His post here is actually the first time he's said that the next driver should fix the problem. (Fingers crossed, Cedric!)

    Your comment was you were having a similar problem, and your solution was to turn off GPU decoding. Fine. Asking for you specs was to determine if you have an AMD card, in which case I would have recommended you revert your GPU driver as Stargazer noted. Then you would be able to turn your GPU encoding back on and gain the faster performance of the GPU.

    I was trying to help you, not make you jump through hoops to tell you the problem can't be fixed.

    You go on to say this needs to be brought to Staff attention to be fixed. Cedric's answer informs you they were aware of the The issue, worked on it for months and a solution might be at hand.

    In the meantime, once again, you never listed your system specs. Do you have an AMD GPU? In that case apply the driver reversion. Are you NVIDIA? If so, you do NOT have the same issue as the OP. That would help determine if this is a new problem that might need to be brought to the attention of the dev team.

    Once again, I've been trying to help you.

  • virgio80
    virgio80 ItalyPosts: 1 Just Starting Out*

    Hello everybody.

    I fixed it by doing what @CedricBonnier said, that is disable hardware decoding in HitFilm.

    Now it doesn't freeze and crash.✌️

    Thank you.🙏

    P.S. I have a Ryzen 5 5600x CPU and Radeon RX 6600 XT GPU.

    Adrenalin version: 22.11.2

  • Triem23
    Triem23 Posts: 20,401 Power User

    @virgio80 if you roll back your AMD Driver to 2022.5.2 you should be able to have GPU decoding on. Or, since things are working now you may decide to leave it off for now. Either way works!