Hitfilm crashing when I press the space bar or play button.

Drake
Drake Posts: 3 Just Starting Out*

Hello,

I've been having a lot of issues with this, "bug" in hitfilm. I can do everything else except play the video without the whole software crashing. I recently had some trouble with my graphics card so I deleted and reinstalled my drivers which fixed all other issues, and I deleted and reinstalled Hitfilm.

Here are my specs:

  • CPU: AMD Ryzen 5 3600
  • GPU(s): MSI Evoke OC Radeon RX 5700 XT 8 GB
  • Operating System and version: Windows 10
  • HitFilm version: 2022.3 (19.2.3.0)
  • Total RAM: 16GB
  • Model name: None I built this PC
  • Every time I press, play/spacebar, it plays the video and then when I pause it again Hitfilm just crashes.

I also triple checked and all my drivers are up to date. Like mention above I've uninstalled and reinstalled everything and reset my computer a billion times. I really don't know what the issue is.

I would appreciate anyone's help on this! I use hitfilm a ton to edit my videos and I really need it in working order pretty urgently. Thank you for your time and help!

Comments

  • Andy001z
    Andy001z Lord EarthPosts: 3,632 Ambassador

    Hi, that is some great information, just a couple of extra things, what version of Hitfilm are you running and what licence?

    and what media codec and type is it you are trying to play back. (have you tried downloading from the net a video file and playing that in Hitfilm, does that also crash or just your media?) oh and what size 1080p 2k 4k?

    Also maybe check to see what your caching options are, maybe turn it off and see if that helps?

    Otherwise I would log a ticket (note weekends are not support hours)

    https://fxhome.com/support

  • Stargazer54
    Stargazer54 Posts: 3,967 Ambassador
    edited November 2022

    @Drake I believe there is still an issue with newer AMD graphics drivers. Please make sure that you install the "Recommended" version (currently "Adrenalin 22.5.1 Recommended (WHQL)"). The Optional drivers have a bug in hardware decoding.

    [EDIT] Also, disabling hardware decoding may help - although that can affect overall performance. But worth a try.

  • Drake
    Drake Posts: 3 Just Starting Out*
    @Stargazer54 Thank you! I think that probably is the issue. I'll try that!
  • Dibz
    Dibz QA Tester Posts: 178 Staff

    @Drake, please do reach out to our support team if you are still experiencing issues after changing the GPU driver.

  • Drake
    Drake Posts: 3 Just Starting Out*

    @Dibz Stargazer54 hit the nail on the coffin. Hitfilm is working perfectly now! Thank you all so much for your help!

  • luvlylavnder
    luvlylavnder Posts: 1 Just Starting Out

    I had the same issue of hitfilm crashing after pressing play, switching to Adrenalin 22.5.1 Recommended (WHQL) also fixed this for me.

    Thanks

    HitFilm version: 2022.3 (19.2.3.0)


    PC Specs

    CPU - AMD - Ryzen 7 3700X 3rd Generation 8-Core - 16-Thread 3.6 GHz (4.4GHz Max Boost)

    GPU - Gigabyte Radeon RX 5600 XT GAMING OC-6G

    OS - Windows 11 Home Version 22H2

    RAM - 32GB

    No Model - Custom Built PC