CamTrackAR full screen

Fixitinpost
Fixitinpost Posts: 2 Just Starting Out

Kind of a simple question but how do you get videos made with CamTrackAR full screen using hitfilm pro 16

Comments

  • Fixitinpost
    Fixitinpost Posts: 2 Just Starting Out
    When the video from the app is imported to hitfilm it’s 1920x1440 and I render it out in 1920x1080 but the video isn’t full screen it’s got the letter boxes on the sides
  • Triem23
    Triem23 Posts: 20,276 Power User
    edited November 14

    Pedantic terminology note - black bars at top and bottom are "letterboxing" black bars at the sides of the screen are "pillarboxing."

    Now to answer your question.

    There are several places in the workflow where you could end up pillarboxed - and every single one is, ultimately, user error. Let's figure out which step you need to adjust.

    First is when you create your Project Settings. In Hitfilm you really should create your project at the resolution and frame rate you want to export at, otherwise you have potential problems. 1920x1440 is taller than 1920x1080. You should make certain your project is 1920x1080.

    Next, when you add your first clip to the Timeline, because 1920x1440 is taller than 1920x1080 it should look like the top and bottom of your frame are chopped off. If you see your entire image then at some point you have told Hitfilm to override your Project Settings and to change the Project Settings to match the first clip you have added to your Timeline. You can check this by going into the File Menu at the top left of the interface and selecting Options. In Options move to the Prompts and Warnings tabs and check "Prompt me when the media doesn’t match editor timeline ." This will re-enable the pop up dialog which comes up when media doesn't match the Timeline. If you select either option and check "Do Not Show Again," then you are setting a default behavior for Hitfilm and the only way to change it is to go back to the Options menu and re-check the prompt...

    Side note - While you're in Prompts and Warnings make sure EVERYTHING is checked. Everything in this menu will set a default behavior in Hitfilm if you select "Do Not Show Again" in a pop-up. Do NOT click "Do Not Show..." until you have read the section of the Hitfilm manual discussing these Options and understand the behavior you are setting as default. We get a lot of user Support questions that start with that user accidentally setting a default behavior they don't want. Personally, I NEVER check "Do Not Show Again" on any pop up and use the warning to double-check myself. This Options page is section 3.2.6. Honestly, it's most likely that this is where you've gotten yourself in trouble.

    Now, again, you should be editing at 1920x1080, so the top and bottom of your frame should be cut off. You might have to drag things up and down to reframe.

    Next is Export Settings. The "1080p" Export preset might actually be set to width/height "From Source," which means it's actually exporting at 1920x1440. Since this is taller than 1920x1080 your media player is scaling the video down to fit the vertical frame leaving pillarboxing. I'm not on my computer to check, so it might be set to a true 1920x1080, in which case the "Scale" setting in the Export preset is set to "Keep Aspect Ratio." Keep Aspect Ratio is the default, and prevents the frame from being distorted if the export resolution uses a different aspect ratio from the timeline. 1920x1440 is a different aspect ratio from 1920x1080, but it will lead to pillarboxing.

    Let me correct myself here - I don't have CamtrackAR (I'm Android), but it's a reasonable guess that the Composite Shot is being created at 1920x1080. Which means you'll either need to click the gear/cog icon near the bottom left of the layer stack and change the Comp Shot to 1920x1080 (chopping off the top and bottom), or create a new 1920x1080 Export Preset and change the Scale Option to "Center" (chopping off the top and bottom).

    To hit the main point one last time, 1920x1440 is taller than 1920x1080, so, if the top and bottom of your image aren't chopped off when you're editing, then your export won't be a full frame at 1920x1080. You'll have pillarboxing.

    Another option is to work in your Comp Shot at 1920x1440 then drag the Comp to a 1920x1080 Editor Timeline (or embed your 1920x1440 Comp in a 1920x1080 Comp). This is what will enable you to drag the frame up and down (if there's something you want that's chopped off). Doing this step in the original Comp is tricky because you'd have to adjust all the tracked points as well. Either way, this is where that "Prompt me when media doesn't match Timeline" warning is important.