Mixamo animations with HitFilm Pro 2022.2 and Blender 3.3 LTS no longer working

RoliKreis
RoliKreis Posts: 13 Just Starting Out*

Hi

I am using HitFilm 2022.2 Pro

I use 3D models and animations from mixamo.com. We always had to "clean" the Mixamo animations in Blender to use them in HitFilm. Here are two tutorials from Film Sensei

1. Mixamo Character Walk Cycle Animation in HitFilm! https://youtu.be/8ROmDWb7B1c

2. Mixamo Animations: A New Streamlined Method! https://youtu.be/NP961pFqFCA

But now, this approach is no longer working with Blender 3.3 LTS. It’s still working when you use Blender 2.93 LTS

Questions

Does anybody have the same problems with Blender 3.3 LTS?

Does anybody have a workaround with 3.3 LTS?

Is it planned to support animations from Blender 3.3 LTS?

Some project details:

Have a look to the animation lengths and fps

Original files from mixamo, converted with Blender 3.3 LTS, and Blender 2.93 LTS

-> The red files are not working.


Comments

  • FilmSensei
    FilmSensei Posts: 3,153 Expert

    @RoliKreis It's funny you should post this. I just completed a tutorial where I imported a Mixamo FBX animation directly into HitFilm without using Blender and it worked perfectly. I'll have to check to see what the situation is with Blender. This is very interesting. Thanks for posting. 😀

  • Triem23
    Triem23 Posts: 20,276 Power User

    @FilmSensei I haven't checked in Blender 3.xx, but believe Blender 3 versions pushed a lot more base functions into the node system, so may have changed the way FBX is handled. Animations might have to be imported into a Geometry Node now. Just a guess...

    @RoliKreis the typical possible issues with FBX in Hitfilm are either material opacity being shifter to 0% and/or material colors being shifted to black. Typically the "Blender wash" fixes this in Blender, but it can be fixed directly in Hitfilm.

    The 3D importer in Hitfilm has a "filter bar" at the top of the material settings box, so typing "Opacity" there will show only Opacity for a quicker check (if needed, bring Opacity to 100%), then typing "Color" bring up just the color. Change things to a mid-gray or white as needed.

    If cleaning up in Hitfilm I suggest starting a new project for the import. Take your model into a Composite Shot, fix the materials and save this project in the same directory as the original model. Now, in any projects you want to use the model in you can use Import Composite Shot to import the setup from the saved project so you don't have to make the adjustments again. In fact, you can also tweak the settings you'll need to do on the model's layer (turn on Cast Shadows, reflections, etc in the layer's Material Properties), and any point rigs used and save with the model project. Then, in your animation project you can copy/paste the model from the imported comp to a different comp and, again, all your setup steps are done.

  • FilmSensei
    FilmSensei Posts: 3,153 Expert

    The reason for "washing" the animation through Blender is to get the rigging right for HitFilm.

    I haven't downloaded the most recent version of Blender (I'm in Blender 3.0.0), but I just tested it with Remy using the Crouching to a Stand animation and it still works. I washed it through Blender 3.0.0 and then brought it into the newest version of HitFilm Pro no problem.

    The reason my upcoming tutorial works is because the model I use comes already properly rigged.

  • RoliKreis
    RoliKreis Posts: 13 Just Starting Out*

    @Triem23 Thanks for the tips, but importing the model itself is not a problem. I only have problems with the animations.

    @FilmSensei For testing with Blender, I used the same mixamo model and animation as you did in your video: Jolleen, Walking. It would be interesting if that still works for you with Blender 3.3 LTS or not.


  • RoliKreis
    RoliKreis Posts: 13 Just Starting Out*

    @FilmSensei Is the new tutorial where you imported a Mixamo FBX animation directly into HitFilm without using Blender already available on Youtube?

  • FilmSensei
    FilmSensei Posts: 3,153 Expert
    edited November 1

    @RoliKreis I haven't released it to YouTube yet. I just completed creating it yesterday. The reason it worked without needing Blender is because the models I used were pre-rigged and ready to go. I will have to try out Blender 3.3 LTS. Like I said, I'm still on Blender 3.0.0.

    Edit: I downloaded Blender 3.3.1 and tested it using the Jolene walking animation and it worked perfectly.


  • RoliKreis
    RoliKreis Posts: 13 Just Starting Out*

    @FilmSensei : Thanks for checking that out from your side! That gave me the incentive to check the whole thing again in Blender 3.3.1.

    It looks like a bug in Blender, when the animation has 30 fps: https://developer.blender.org/T99876

    A user reported that the bug was fixed, but now back: Cenek Strichel (cenda): Problem is back in 3.3.1, 3.3.2 RC. So I guess it will be only a matter of time until it will be fixed in Blender 3.3.x

    The problem occurs when frame rate of the animation is 30fps. I changed it to 29.97. With that setting, everything is working fine in Hitfilm!

    Blender 3.3.1, frame rate

    Hitfilm Pro 2022.2, imported animations


  • FilmSensei
    FilmSensei Posts: 3,153 Expert

    @RoliKreis Wow, interesting. Thanks for the update!