HitFilm 3 issue with Canon DSLR 1080p video

fredclips Website User Posts: 228
edited November 2014 in HitFilm

Created a new project PAL 25fps, 720p
Import 1080p 25fps video from canon Kiss X4. These are mov files that I have worked with a lot in Hitfilm 2.
Crash 1. Drag clip to timeline, answer do NOT change editor to match clip. HF3 crash. (greyed out)
Problem 2. Same again. This time clip appears in timeline. But only the first frame. Only black when scrubbing alone timeline in trimmer and editor. trimmer says "Video Frame Cannot be Loaded" when scrubbing along timeline.
Crash 2. Open project again. Videos never appeared in media windows, just the 'openning circle' thing. Then crash.
Next: Tried importing clip into new project, this time media window shows the file name with an ! as the media imagine and the message "File Error"

Opened hitfilm 2 again, tested videos again without trouble on timeline and trimmer. Everything looks good. This is the same camera and video files I've used many times in the past. (Hitfilm 2)

My PC is an
Windows 8.1
i7, 16gb RAM
3gb ASUS R9 280x video card


  • IamJoshuaDavies
    IamJoshuaDavies Staff Administrator Posts: 360 Staff
    edited November 2014

    Can you recreate this issue with just a single small clip? Could you upload the clip for our QA team to test here next week?

    We know there are issues when importing many .mov clips in both HitFilm 2 and 3 due to restrictions of QuickTime being 32-bit on Windows and we're working on those but this sounds different.

  • emma24xia
    emma24xia Website User Posts: 85

    It's better you could run a test with a smaller video clip, or maybe transcode the video clip could help because it worked for me.

This discussion has been closed.