waste of time

astro46
astro46 Posts: 1

Hitfilm express has been a horrible experience. I downloaded because it was recommended on a website. I can't get past the program opening to wanting activation. one box takes me to a screen that says nothing about activation. another gets me somewhere to download a license file. then what? i tried putting the license file in with program files but this makes no difference. what are people supposed to do with the downloaded license file?

same window demanding activation every time it opens. after logging in it tells me it is already using one activation; do i want to delete it?

never mind trying to actually load a video and attempt editing (not an experience that I would forward to, based on my experience so far).

Comments

  • triforcefx
    triforcefx United StatesPosts: 1,480 Moderator

    This sounds like unusual behavior that I’ve never seen before.

    Typically, the activation screen simply asks you to log in to your account, which activates the product.

    Please redownload the software from this page and try again. For the Pay what you Want screen, simply set the slider to 0 and continue.

  • Triem23
    Triem23 Posts: 20,595 Ambassador

    Hitfilm Express should cheerfully activate the first time you run it by entering the email address used to download it, which should be the same email you've used for your forum account.

    Consider visiting FXhome.com/account and hitting "deactivate" before any attempts to reinstall. Sounds like something odd happened with your activation. FWIW, I've never had installation issues across 15 versions of Hitfilm and 7 PCs.

  • KirstieT
    KirstieT Posts: 1,192 Staff

    If you're still having issues after taking the advice of our great ambassadors above @astro46 please contact our support team who should be able to help: fxhome.com/support