Posterize with motion blur on.

assensy
assensy Posts: 42 Enthusiast

[HitFilm Express] I have a moving variable speed static image (jpg) that I use to do a pan effect. I've turned on motion blur to make it look natural in the fast moving moments. In the composite shot everything looks fine (it sees and renders as it should). When I put it in the editor, the quality drops disastrously. There is posterization before and after the fast motion moment. This is how it appears on screen and this is how it is on the final render. When I turn off the motion blur in the composite shot, the video gets fixed.

I tried on different computers and the problem remains the same.

Composite shot:

Editor:

I tried with hardware rendering on and off. No difference.

Comments

  • Stargazer54
    Stargazer54 Posts: 3,740 Ambassador

    Check your settings under the drop down next to Options on the right side of the timeline.

    Discussion of what these options mean are in the online manual by clicking Help at the top of the HFE interface, Section 4.8 "Introducing the Viewer". If you have it set to Fastest it will ignore effects. Fiddling with these controls can help speed up the display but normally you want to leave it at "Draft". These settings do not affect the rendered output.

  • assensy
    assensy Posts: 42 Enthusiast

    @Stargazer54

    I probably didn't write it clearly enough. My English is pretty bad.

    The problem is the final rendering. I don't think it has anything to do with the preview in the editor. In the compositing everything is OK. When I insert the composite shot into the editor the posterization appears.

  • Stargazer54
    Stargazer54 Posts: 3,740 Ambassador

    Can you post an example of the rendered output from HF?

    I'm still a little confused. You said that the problem is not the viewer but "When I insert the composite shot into the editor the posterization appears." - which sounds to me like the viewer. So seeing the rendered output would help.

    What rendering preset are you using? You might try making a copy of the rendering preset that you can customize and increasing the Bitrate or set to Constant Bitrate. Just guessing. Generally speaking "YouTube 1080p HD" should be sufficient for most projects.

    Again, make sure you make a copy of the preset to fiddle with. You don't want to modify the Built-in Presets.

    Or you could try exporting as "GoPro Cineform" that should provide with highest quality, but still with some compression. "Uncompressed AVI" is self explanatory, but will give you a much larger output file.

  • assensy
    assensy Posts: 42 Enthusiast
    edited April 15

    Here is an example. One file is exported via composite and the other via editor. Both have the same preset: 10-15 mbps. I tried both with 20 mpbs. The posterization remains.

    The posterization is best seen in the sky. 

    I also tried with the HitFilm Pro demo. On pause in the editor it has the same problem. I haven't exported, why I think in the demo the export is blocked, and there is no need. The result will be the same.

    Composite shot (no posterization) :

    Editor (there is posterisation):


  • Stargazer54
    Stargazer54 Posts: 3,740 Ambassador

    When you say "Editor" in the second example I assume that what you mean is the rendered output file and what it looks like on playback?

    If you are talking about are the horizontal lines in the output:

    That is not posterization (which is an effect) but rather banding. This happens when the the render code cannot make a smooth ramp between adjacent and like colors. You see that a lot in gradients. Make a nice gradient in Photoshop and then render it out as video and you will usually get the banding problem in the output file. Welcome to computer graphics - banding has been a problem for all of us at one time or another.

    Again, the best bet is to either increase the "bit depth" or render out uncompressed.

    You can increase bit depth by going to File, Options, Render and increase Default Color Bit Depth above "8-bit integer" (which is the default). Unfortunately, if you are on HF Express I believe you have to purchase an add-on to get it above 8 bit.

    Have you tried rendering with Cineform (which should do 10 bit) or Uncompressed AVI (as suggested)?

    You might want to read through this thread as it goes over bit depth - https://community.fxhome.com/discussion/51303/color-bit-depth-on-export. Also refer to section 4.2.4 - Render Options in the manual.

    Tagging @Triem23 @NormanPCN for a sanity check.

  • NormanPCN
    NormanPCN Posts: 4,122 Enthusiast
    edited April 17

    Banding can happen in compressed output and smooth sky is where this typically occurs. Bitrate increase cures this, if compression was/is the culprit. Poor encoders might not allocate enough available bitrate to a smooth sky. They see a lack of detail and think, hey I can save bitrate for other detail stuff, and push it too far and induce banding. The OS encoder Express uses seems to be on the poor side of things from the traffic I've seen across this forum since Express switched.


    We just have a lot of inconsistent data/reports from the OP. The report about them trying Pro might indicate the issue has nothing to do with exported output, as no export was done, but then other reports are about the exported output ("The problem is the final rendering.").


    I don't know of any standard processing the editor timeline just simply does to composites placed there. Again, we don't know anything about the OP composite and editor timeline specs/settings.

  • Stargazer54
    Stargazer54 Posts: 3,740 Ambassador
    edited April 17

    @NormanPCN Thx. Yep kind of hard to decipher the issue fully.

    @assensy After trying some tests with a gradient I can replicate what I believe you are seeing in the actual Viewer window. And I must clarify how this can be fixed. Go to Project Settings and click the Rendering tab and select 16 bit Float (instead of the default "8 bit Integer"). That should clear it up. At least this works in HF Pro. Again if you are on Express I think you have to purchase an add-on to access this feature.

  • assensy
    assensy Posts: 42 Enthusiast

    @Stargazer54 I was going to say the same Composite Shot, render it through the "Composite Shot" panel and the "Editor" panel. In the first case there is no problem, in the second case you get posterization. This only happens when "motion blur" is on, and only a little while before and a little while after when the effect is active.

    @NormanPCN Thank you. It's about HitFilm Express. The explanation for me is that HitFilm uses two different encoders. One when rendering through the "Composite Shot" panel and a second when rendering through the "Editor" panel. I can't explain it any other way.