Parts of video are low quality on export

zackarara
zackarara Posts: 4 Just Starting Out*

So, I've been having this problem for a while now. All of the original footage i export is in .AVI at 4K60FPS. Whenever I export a video, It becomes pixelated only for a few seconds and then it goes back to normal. It really ruins the video for me because I always want the best quality I can get.

This above is an example of the pixilation while the picture below is just a second prior.

In the viewport the clip should've ended up like this


These are my export settings,

I use very high export settings and I am ok with it being a huge file size.

Tagged:

Comments

  • Stargazer54
    Stargazer54 Posts: 3,758 Ambassador

    @zackarara Are you having this issue with the file playing back from your local drive or from being played back on YouTube?

    Just in case you are seeing this on YouTube it could be the Settings (gear icon) in the lower right of the player window. Click that, go to Quality and if the checkbox is on Auto, the video will playback at a lower resolution until YouTube determines your endpoint playback can take more quality and then increases the bandwidth. Try setting the checkbox to 1080p to force it to start at 1080.

  • zackarara
    zackarara Posts: 4 Just Starting Out*
    @Stargazer54 No, this is from my export before I upload it to YouTube, It's playing off my computer. I always check my videos before I upload them because I know that YouTube itself will compress my videos and I don't want them to look bad.
  • Fish
    Fish Posts: 1 Just Starting Out

    I'm having the same problem. Must have something to do with the encoding of the export. Changing the variable bitrate to constant fixed it for me. However this is more a workaround than a fix...

  • zackarara
    zackarara Posts: 4 Just Starting Out*

    @Stargazer54 No, this is from my export before I upload it to YouTube, It's playing off my computer. I always check my videos before I upload them because I know that YouTube itself will compress my videos and I don't want them to look bad.

  • zackarara
    zackarara Posts: 4 Just Starting Out*

    @Fish Yes, switching to constant fixes it for the most part even though its just a work around. there must be some way to get variable to work.

  • Stargazer54
    Stargazer54 Posts: 3,758 Ambassador

    @Fish Always best to convert from Variable Frame Rate to Constant Frame Rate. The simple explanation is that VFR does not always contain all frames and approximates them to speed up playback. VFR is a delivery codec scheme and not generally suited for video editing. Video editors need every frame present to do frame accurate editing, otherwise you force the software and your system to stop and think about the missing frames to make them up on the fly - this slows things down. So, CFR is preferred to optimize your editing session.

    Note: Variable "Bit Rate" is not an issue. But Variable Frame Rate is.

  • Triem23
    Triem23 Posts: 20,604 Ambassador

    Your variable bit rate settings are incorrect. In VBR the "Max Bitrate" should be 150% of the "Target" bitrate. For a 300mbps Max your target should be 200mbps. By setting them to nearly identical values you've fed the encoder bad starting data.

    At 300mbps data rate you're hitting a point of diminishing returns on file size vs quality. You're better using Cineform (PC) at 10-bit, no Alpha, Medium Quality, or ProRes (Mac). If, after a Cineform/ProRes export you want to transcode the file to MP4 you're better using a third party transcode like Handbrake, which had more control over the encode than Hitfilm.

    Are you on Windows 11 by any chance. Hitfiilm Express uses the OS native encoders, but there seems to be a pixelization issue on Win 11 machines. Hitfiilm doesn't support Windows 11 yet.