HitFilm 2021.2 is now available for download!

philipwesson
philipwesson StaffAdministrator, Moderator, Website User, Ambassador, HitFilm Beta Tester Posts: 386 Staff
edited September 23 in General

You can download the latest versions from the following links:

HitFilm Express

Hitfilm Pro

(Make sure that your license is still valid to receive the latest updates!)

Comments

  • tddavis
    tddavis Moderator, Website User Posts: 5,059 Moderator

    Yah!!! But every blessed time when I am away from home on the daughter's laptop or my phone...🤣🤣

  • TheBenNorris
    TheBenNorris Staff Administrator, Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,009 Staff

    Woohoo! Enjoy everyone! Some really cool stuff in here (and some cool stuff already in development for the next updates too!)

  • Neptunos
    Neptunos Website User Posts: 73 Just Starting Out*

    Still no Mac M1 support? At least some optimizations if running via Rosetta?

  • Manhit
    Manhit Website User Posts: 45 Enthusiast

    Proxies! Thank you, thank you!

  • premiere_studios
    premiere_studios Website User Posts: 115 Enthusiast

    Very Excited for this update!!!

  • jtjutsvfx
    jtjutsvfx Website User Posts: 81 Enthusiast
    edited September 24
  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,936 Ambassador

    RIP RAM preview, helloooo Proxies and Timeline Cache!

  • jtjutsvfx
    jtjutsvfx Website User Posts: 81 Enthusiast
    edited September 23

    I am assuming that this is happening because I am running HitFilm on a low end old pc but HitFilm seems to have become very unstable since the this update. I can hardly get the software to make a proxy and most of the clips that I import have very glitchy thumbnails(see pic)

    Also, the cache timeline feature always gives me this error whenever I try to use it.

    This is probably not a glitch and is probably related to my computer but I thought it might be worth mentioning.


    Is anyone else experiencing this?

    These new features are so exciting and I can hardly wait to use them!

  • TheBenNorris
    TheBenNorris Staff Administrator, Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,009 Staff

    @jtjutsvfx as with all issues like this, please provide specs and ensure your drivers are updated. As far as I can tell a few users are having issues due to outdated drivers.

  • jtjutsvfx
    jtjutsvfx Website User Posts: 81 Enthusiast
    edited September 23

    You don’t have to worry about this Ben!😊 I will look into it a little more. I’m pretty sure my old computer is the culprit this time. It’s super old and under HitFilms minimum system requirements so I really just have to get a long overdue hardware upgrade.✌️

  • iamkhanproductions
    iamkhanproductions Website User Posts: 393 Enthusiast

    Happily switching to blender ..

  • SolidSnake2003
    SolidSnake2003 Website User Posts: 144 Enthusiast

    Is the Cosmos and Electro effects available for Express users? I don't see anything that says it is Pro Exclusive.

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,936 Ambassador

    @SolidSnake2003 Cosmos, Electro and Superglow are Pro-exclusive, as is FBX camera import/export.

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,936 Ambassador
  • WhiteCranePhoto
    WhiteCranePhoto Website User Posts: 924 Enthusiast

    I can't wait to try this version out!!! And fortuitously, I have a loaner UMP 12K from Black Magic to review right now... :)

  • littlehausbigcity
    littlehausbigcity Website User Posts: 45 Just Starting Out*

    Just upgraded yesterday myself and already this morning, found a glitch. the titler is wonky and why no presets for that function (as in creating my own). When I went to center justify my text after using it, and got it to justify center, but it turned mostly dark and then hit control Z to back out until it looked correct and then I could not get it to justify center.

    I have updated drivers for my graphics card and had to reinstall the VCRuntime140.dll file (and the entire C++ visualizations 2015-2019 from Microsoft as a Windows Update nixed them.

    Also, there was a Windows update when I had to reboot after the current Hitfilm update.

    The other issue is, where is the scrub feature? Before Control left/right arrow got me to scrub by a frame, now it does not seem to do it and no instructions on how to create proxies so don't know if I'm to do anything or not, however, improved support for HEVC, still have to transcode or it is seen as an unsupported file when I go to import into the NLE.

    Computer is still the Dell Optiplex 9020 with the NVIDIA Geforce 610GT graphics card running the older 4th gen Core i5 (5470) processor on 16MB of RAM, unless that's been changed, Triam said that this card will be OK for at least a year, maybe 2.

    As it is, I'm already editing a video project and just discovered this issue.

  • Chalky64
    Chalky64 Website User Posts: 31 Just Starting Out*

    For some reason I cannot download the Windows version of this update. The page itself loads, but no matter what I try when I click the (Windows) download link I get (in Firefox 92.0.1):

    Secure Connection Failed

    An error occurred during a connection to 1-213-10440-2.b.cdn13.com. Peer received a valid certificate, but access was denied.

    Error code: SSL_ERROR_ACCESS_DENIED_ALERT

       The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.

       Please contact the web site owners to inform them of this problem.

    If I try via Edge I get:

    The connection for this site is not secure

       1-213-10440-2.b.cdn13.com sent an invalid response.Try running Windows Network Diagnostics.

    ERR_SSL_PROTOCOL_ERROR

    and from IE11 I get:

    Cannot securely connect to this page

    This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner

    The Mac version (.pkg file) downloads fine without any errors.

    Help?

  • stephenallenson
    stephenallenson Website User Posts: 1 Just Starting Out*

    I'm only a casual user and didn't take the 2021.1 upgrade since I din't use Boris. I'd been using the previous release incredibly happily. 2021.2 is giving me some real performance issues (and yes my drivers are up to date) and the base machine is only a couple years old.. If I run the software for more than about 30 minutes it starts to get incredibly laggy; moving clips around with the mouse is almost impossible; it's a total nightmare. Feels like there's some serious memory leakage going on. I'm uninstalling and reverting to the previous version which worked brilliantly with no performance issues at all. I'm pleased that other folk are finding the new features great and worthwhile, but from my perspective a fantastic piece of software has now been broken. A real shame.

  • nerdrupted
    nerdrupted Website User Posts: 13 Just Starting Out*

    Hi, since updating to this newest version I have been having issues with Hitfilm Express. The program becomes very slow whenever I try to cut a clip or delete a gap. I had no issues with performance with the previous version.

    Is there any way to fix this?

    All my drivers are up to date and the computer is less than a year old.

  • BertoBNF
    BertoBNF Website User Posts: 8 Just Starting Out*

    Man, I normally don't update right away but for some reason I did today and it was a huge mistake, very slow and now I get pixelated portions of my video after I render them out. I made the other mistake of saving my project after updating and now I can't even use the older version because it won't open them. I knew that after I saved but I had no idea of the render issues. It's been a nightmare, I won't be able to get my projects out because of the issues. I'll either have to wait for a patch or reinstall the old version and re-edit for hours to recreate the videos I made. I have a Dell Inspiron 15 7559 with 16GB RAM with NVIDIA GEFORCE GTX 960M and yes I updated my GPU driver and same issues continue.

  • RobbieMatthews
    RobbieMatthews Website User Posts: 3 Just Starting Out*

    2012.2 is persistently freezing when attempting to play my project. Even older projects display this problem.

    Symptom is the sound is playing but no video, and then as soon as I hit pause the whole thing freezes completely.

    I have rolled back to the previous version and it works fine.

    (It will render fine, it just doesn't let me see what I'm working on.)

  • assen
    assen Website User Posts: 3 Just Starting Out*
    Again, I see no reason to update Hitfilm Express. I do not see anything new in this update. Only possible problems with stability and speed. I continue to use Version 2021.0.
  • TheBenNorris
    TheBenNorris Staff Administrator, Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,009 Staff

    Hi all, just want to jump on here to say that I'm sorry you're having performance issues. This seems to be a pattern with a fair few users and I'm keen to get to the bottom of it and get you all on track with the other awesome features in the update.

    First of all, I'd like to ask that anyone with issues please provides full specs for their machine. This includes CPU, GPU, RAM and Windows version. A named laptop or desktop is not enough information, and stating the age is also not enough. This is to help us close in on the issue and save everyone time in the long run.

    Additionally, you can disable the timeline caching by going to Options->Cache->Create Timeline Cache In Background. This should potentially help with some of these issues, please let us know if that is the case.

    If you are having visual issues, such as pixelation and compression, please provide screenshots where possible, as it will help us identify if this is an issue with the software or perhaps a simple fix.

    If you are having continuous issues I also recommend contacting our support team directly, as they can help you and will make sure you have all of the important, required information: www.fxhome.com/ask

  • BikerWise
    BikerWise Website User Posts: 1 Just Starting Out

    Hi,

    I have just updated Hitfilm Express to the new Version 2021.2 and although the update went well, I immediately found problems once I started a new project by opening a template I have used with out issues for a year. Once I imported my GoPro and phone video, also a Relive map along with photos. I found that when trying to scrub through the Relive video (Low res free version) on the Trimmer it kept going blank? "video frame cannot be displayed" it will scrub through very slowly and play through, but if you go too fast or pick points into the video it goes blank?? the GoPro and phone video scrubbed through OK but not the Relive footage? Also have an issue with very Jerky playback in the timeline? that's as far as I have got with this new Version 2021.2 of Hitfilm Express. If there is no easy solution I think I will have to go back to the previous version. I have found all previous updates to be an improvement on the last and not had any problems.

    My Operating System:

    Processor AMD Ryzen 7 2700 Eight-Core Processor       3.20 GHz

    Installed RAM 16.0 GB

    System type 64-bit operating system, x64-based processor

    Edition Windows 10 Home

    Version 21H1

    Installed on ‎19/‎08/‎2020

    Graphics Card NVIDIA GeForce GTX 1660 Ti

    I would appreciate any advice.

    Regards Tony.









  • TheBenNorris
    TheBenNorris Staff Administrator, Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,009 Staff

    @BikerWise this seems to be a different issue to the one everyone else is having, that said, I think it's time I lock this thread as it's getting difficult to keep track of all issues.

    I ask that anyone having issues please makes a new thread - even if another thread sounds similar, that may not be the case - and adheres to the support posting guidelines.

    Alternatively, it would be beneficial if you contacted support directly so we can get any information required about these issues: www.fxhome.com/ask, thank you.

This discussion has been closed.