Need help on getting rid of the lag for Hitfilm.

abyn
abyn Website User Posts: 5 Just Starting Out*

Today after I imported a clip everything is laggy af, as soon as I try to preview the clip I can't do anything. Does anyone have any way to help me?

Comments

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,935 Ambassador

    Not unless you actually give useful information.

    We'll need your system specs - CPU, GPU, OS, RAM and Storage.

    We'll need to know details about the video clips. For this you'll need to download MediaInfo (free) and create a TREE report to paste here.

    That said, there is little to be done other than to maybe optimize your video files using other (free) third-party tools before import to Hitfilm. Which is why I'm asking for the MediaInfo report.

    Otherwise, Hitfilm - like all NLE/VFX programs - is dependent on your hardware. If you're having issues playing back a single video clip then I'm already 90% certain when you list your hardware specs you're going to be told you have a slow or weak computer by editing standards.

  • abyn
    abyn Website User Posts: 5 Just Starting Out*

    Hello, my CPU is Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz  3.60 GHz, GPU is a Geforce RTX 2060, OS is 19043.1237, I have 32 GB of RAM, and 342 GB of storage free. With that finished here is the full screenshots of the tree report:


  • triforcefx
    triforcefx United StatesModerator, Website User Posts: 1,271 Moderator
    edited September 17

    @abyn If I had to guess, the issue is the 120 FPS framerate on your clip. HitFilm runs frame rates in “real time” meaning if you have 120 Frames Per Second video, HitFilm will try to play all 120 frames in a single actual second, and HitFilm doesn’t handle that many frames very well. Additionally, if it’s different from your project settings, HitFilm has to decide which frames to drop (if your project is set to 30fps for instance, it has to drop a whopping 75% of frames for 120 FPS video!)

    Is this supposed to be a slow motion video? If so, in HitFilm, click the cog next to the clip in your Media bin, which will open the Media Properties window. On Frame Rate, uncheck the From File box and then type in your project’s Frame Rate. Now hit OK. Now when you import your clip, it will play back in slow motion and shouldn’t be choppy. If you wish to speed it up, you can use the various speed tools in HitFilm (I personally prefer the Rate Stretch tool if I don’t need to ramp it)

    If this is supposed to be played back in “real time” (for instance, 120 FPS game footage), you’ll need to send your clip through Handbrake again and set the FPS to whatever your project settings’ FPS is.

  • abyn
    abyn Website User Posts: 5 Just Starting Out*