Transparent plane makes black lines on 3d-Model

Fotografitti
Fotografitti Website User Posts: 18 Just Starting Out*

I have a 3d model created in blender, which is supposed to make the scene where I position video clips.

It works fine, except that each videoplane as 3d-plane leaves a black line on the model.

I tried everything I can think of... shadows, receiving shadows, materials in the model, deactivating bumpmaps, turning of lights, moving layers up and down etc.

Also when I create just a transparent plane and put it into 3d space, it leaves a black line.

It seems to have something to do with the camera, as in perspective view, its not visible.

The black line cuts everything like the tonge and its not limited to the actual size of that layer, seems to go through the entire space.

It makes a real cut throught the model. Maybe I made something wrong in blender - I am new to blender.

Just found, where the planes intersect, they cut the model:

and here is the scene in perspective view:

here looks everything fine 😪

Comments

  • Stargazer54
    Stargazer54 Moderator Moderator, Website User, Ambassador, HitFilm Beta Tester Posts: 3,268 Ambassador
    edited August 6

    Hmm.... could be a clipping plane problem with the camera? If you are bringing in a composite shot into another composite shot you might try setting the imported comp to 3D Unrolled and see if that fixes it.

    Maybe need a little more info on how your set up is arranged and how the layers are stacked.

  • Fotografitti
    Fotografitti Website User Posts: 18 Just Starting Out*

    Thx for the fast reply. I will try that tomorrow. But as I wrote, it also happens when I create a transparent plane from hitfilm.

    So I suspect it will happen as well with just the model and any plane. As far as I tried, one cannot 3d-unroll a composit shot (which was 2D) ans use it properly in 3d space.

    Maybe its an issue with the alpha-channels of the planes?

  • Fotografitti
    Fotografitti Website User Posts: 18 Just Starting Out*

    Now, I could narrow it further: It only is visible with DoF activated. with DOF deactivated in the camera only appears under very steep angles towards the respective plane.

    Oh, I hope someone with knowledge can point me to a solution here. Or maybe something wrong with my copy of Hitfilm?

  • Fotografitti
    Fotografitti Website User Posts: 18 Just Starting Out*

    also

    No, an unrolled comp shot is not movable at all. It seems as unrolled doesn't work in 3d-space

  • Stargazer54
    Stargazer54 Moderator Moderator, Website User, Ambassador, HitFilm Beta Tester Posts: 3,268 Ambassador
    edited August 7

    @Fotografitti "No, an unrolled comp shot is not movable at all. It seems as unrolled doesn't work in 3d-space"

    Not sure I follow you here. 3D Unrolled is actually designed to allow you to move a comp and the objects in it around in 3D space. Have you set up your planes as 3D and not default 2D? I assumed that you had to be using 3D planes to place them where you did in the scene.

    Again, a screen grab of your layer stack for both comps would be helpful.

    As to the DOF issue, it could very well be a bug.

    But to further explain the problem with the clipping plane - here I have a 3D model (at the bottom of the stack) in a comp called D7-for-HF. Notice that it is set to 3D Plane

    I then created another comp called "test" and drug in the first comp, set up some parenting, added a target point joined to the parent and made a fly by move with the camera Alignment set to look at the target layer. Even with the D7 comp set to 3D unrolled I still get the clipping plane.

    It only goes away when I go back to the first comp and set the model to 3D unrolled in first comp.

    Hopefully that explains what happens with clipping plane and 3D unrolled. And this is why I thought that is what I was seeing from your screen grabs.

    The fact that you see this with DOF (which is also a function of the camera) suggests to me it is perhaps a bug with the camera. Again grabs of your layer stacks in your comp shots would be helpful.

  • Fotografitti
    Fotografitti Website User Posts: 18 Just Starting Out*

    THX for the further explanation - regarding the "unrolled comp shot" - this was not stated clear from me: in my many attempts I also set a 2D composite shot as 3d unrolled, but this doesn't work at all.

    Again I can send a picture of my layer stack tomorrow, but I have the palate as unrolled 3d-object at the bottom and all the other videoclips as 3d-planes on top as well as some lights

    I also believe that it is a bug. Maybe the reason, its not to often noticed, is because that the palate in my composite shot is the so big in the scene - not just a moving object.

    I had to scale the object to 600% - so I tried also lower scaling and to scale it in the model dialog as well as in the world transformation, but didn't make a difference.

  • Fotografitti
    Fotografitti Website User Posts: 18 Just Starting Out*

    Here my composit shot. As soon as switch the 7th layer from unrolled to 3d-plane, the cut lines in the floor dissappear.

    Was I wrong to want to use it 3d-unrolled? Using Hitfilm Pro version 2021.1 . Upgrade period endet in april :-(

  • Stargazer54
    Stargazer54 Moderator Moderator, Website User, Ambassador, HitFilm Beta Tester Posts: 3,268 Ambassador

    @Fotografitti Still trying to wrap my head around your scene. (And thanks for the screenshot). Still would be helpful to see the stacks for the other comp shots.

    But, after trying to duplicate what I think your set up is, try setting your Model layer 7 to 2D and put it at the bottom of the stack. Keep your other composite shots with the plane layers set to 3D Plane and see if that clears it up.

  • Fotografitti
    Fotografitti Website User Posts: 18 Just Starting Out*

    @Stargazer54

    "...try setting your Model layer 7 to 2D" ?? You probably meant 3D... well just 3D works, but then I have a hard time to animate movements through the model.

    So its not possible to use 3D unrolled if you have panes that intersect the model in 3d space?

    I tried a different model, I just downloaded. The same.

    Very easy to replicate: 3d-model unrolled, an intersecting transparent plane. All layers, including camera Depth Field activated. The cracking line changes with the blur and aperture in intensity.


  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,824 Ambassador

    @Stargazer54 does NOT mean for you to set your Model Layer to "3D". Don't do that.

    Model Layers and Compositing Modes

    • Model Layer in "2D" compositing mode: The model is calculated, rendered to that layer as a 2D image, then passed to the layer's Effects stack for processing. "2D" model (and particle) layers render occlusion in layer stack order. If there are two 2D model layers in a comp the layer on top always renders "in front" even if the model is "farther away"
    • Model Layer in "3D" compositing mode: The model is calculated, rendered to that layer as a 2D image, then passed to the layer's Effects stack for processing. The 2D image layer can then be re-positioned in 3D space - but you're moving a 2D image on a flat card around. "3D" layers are always rendered with correct depth relative to each other, but, since the model is calculated in 3D space, rendered to a flat image, then the flat image itself is moved in 3D space, this is a great way to mess up your renders. This mode is useless 99.99% of the time.
    • Model Layer in "3D Unrolled" compositing mode: The model is calculated, but is NOT rendered. Further layers are calculated but the 3D Unrolled model layer is not rendered until Hitfilm hits a fully 2D layer (photo/video/plane with masking or keying on it) or the top of the layer stack. When multiple model or particle sim layers exist in 3D unrolled they occlude each other correctly based on distance to camera (instead of layer order), but you cannot add effects to 3D unrolled model layers.


    Embedded Composite Shots and compositing modes.

    • Embedded Composite Shot in 2D mode: The Composite Shot is calculated and rendered. The 2D image of the rendered Comp is treated as any other video layer in the main com.
    • Embedded Composite Shot in 3D mode: The Composite Shot is calculated and rendered. The 2D image of the rendered Comp is treated as any other video layer in the main comp - as a 2D image being moved in 3D space.
    • Embedded Composite Shot in 3D Unrolled mode: If your original Comp is all 2D elements then 3D Unrolled is useless. It's the same as 3D mode. If your original Comp contains elements in 3D space - like 3D models or 3D plane/video/photo layers being moved in 3D space then having the Embedded Comp in 3D Unrolled mode means the 3D placement of the original comp is preserved and you can re-position/rotate the embedded comp in 3D space. The best visualization for this that I can think of starts at about 3:30 in this tutorial:

    Stargazer already did some explaination with screen shots about 3D models in embedded comps.

    @Fotografitti There may be some language issues happening here. I believe you are German? While your English is infinitely better than my German (or whatever your primary language is), reading this thread I'm having trouble parsing exactly how you've set things up and what you're asking.

    Try this: (I'm using your screen shot in the post directly above this one for reference)

    • Set your model layer back to 2D.
    • In the Controls for the model layer look for the Properties tab. In Properties, look for "Depth Source" layer. Select the 3D plane layer as the Depth Source layer.

    "Depth Source" Layers work with model or particle layers in 2D compositing mode. Basically a Depth Source layer is always calculated in 3D space correctly with the layer giving correct occlusion and allowing effects to be added to the model layer. This was a feature added in Hitfilm Pro 12.

    One last consideration

    I'm one of the Hitfilm Beta Testers and, last year while testing HF 16 I literally spent two weeks of testing doing nothing but checking how Hitfilm deals with scale with varied imported model types, and I'll tell you that HItfilm has some issues with FBX models that just don't occur with other formats. Right now, unless you're using a model that also has FBX animation (like something from Mixamo), DON'T use FBX. You'll get better results if you take the model into Blender and convert it to OBJ. If there are multiple materials just make sure you assign the base color of each material to something unique.

  • Fotografitti
    Fotografitti Website User Posts: 18 Just Starting Out*

    @Triem23 Thx a lot for ur comprehensive explanation and although before I started this thread I often read in similar threads when you explained "Model Layers and Compositing Modes". But i was fixated on the idea that a model hast to be 3d unrolled.

    What I am trying to do is simply move the camera along the 3d-model and place some videoclips into the scene. it works when I leave the model on 2d.

    But there still seems something odd to me: My clips have an alpha channel (greenscreen clips with the little monsters)

    When I follow your last instruction and set the model layer to 2D and the depth source to a 3D plane layer, the model becomes invisible; as soon as the layer has an alpha channel, the model dissapears.

    It isn't even selectable as depth source layer as soon it has an alpha-value below 255.

    When I use a white test-plane as depth source layer for the model and then set its alpha to 254, the model disappears immediately.

    Maybe this is neccessary, but I don't understand it right now.

    Anyway, leaving the model layer on 2d does the job ;-)

    THX again!

  • Fotografitti
    Fotografitti Website User Posts: 18 Just Starting Out*

    @Triem23 I have to correct myself- I doesn't do the job! What I stated with the cutting lines remaines a fact, at least for my Hitfilm Pro installation.

    As soon as a 3d-plane is placed in a 3d object and you want to keep 3d, which is to say to have the right occlusions when something from the model would occlude the 3d-plane, then only 3d-unrolled does the job.

    If I then activate depth of field, cutting lines become visible on the model anytime a plane has an alpha-channel.

    Activating "depth source layer" doesn't work for 3d-planes with alpha-channel - they are not selectable.

    Setting the alpha-value on a 3d-plane lower than 255 which is selected as depth-source layer for a 3d-model makes the model dissappear.

    Maybe, I am expecting to much, because I want to place clips in a 3d-model-scene?

    Or something with my installation is wrong, but right now I would say its a bug.