2 issues with auto volumetrics

CasualScrub
CasualScrub Website User Posts: 10 Just Starting Out*
edited July 10 in HitFilm

Hello,

I am trying to use the auto volumetrics effect to make light rays that come through clouds and trees, but I have 2 issues with the effect, and I was wondering if I could get tips on how to fix, or at least minimize these issues. Here is a preview of one clip I edited using the auto volumetrics effect:

https://streamable.com/69rbgs

1) When I use the effect, it creates a dark spot near the location that I use as the light source position (although not at the exact location). It's not very noticeable in screenshots, but you should be able to see it in this preview. It starts on the left side of the screen in this clip, and then moves over to the right.

Side note: the effect also creates a dark circle, but this is not as serious of an issue as it sort of looks like a lens flare so I'm more willing to keep it if necessary.

2) The light rays from the volumetrics effect have a random flicker that I can't get rid of. You can see it if you look at the rays that hit the islands on the sides of the scene. This is not as much of an issue as the dark spot, but it still does not make any sense to me, and I would like to be able to get rid of it if I could.

Is there anyone who could explain to me the cause of these issues, and how to fix them? I would greatly appreciate it!

Comments

  • Andy001z
    Andy001z Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,134 Ambassador

    Not sure,

    check you blend mode of the layers.

    can you share a screenshot of the settings for the auto volumetric.

    Ta

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,969 Ambassador
    edited July 11

    Besides your settings - @Andy001z is right in that a Screenshot would help - are the Volumetrics on a media layer or Grade Layer?

    General recommendation. Put the Volumetrics on a Grade Layer, but, BEFORE the Volumetrics in the Effects chain you want to add "Hotspots" (Hotspots keeps pixels above a threshold and knocks the rest to black) adjusted to keep just your sun, tlhen a Blur of about 5-10 pixels. This isolates the pixels that act as the "light source" and the blur helps control flicker. Set the blend mode of the Volumetrics effect to "None" and set the Blend Mode of the Grade Layer to Add or Screen.

    Andy, for future reference Hotspots and Blur are a great combo before either Light Rays or Auto Volumetrics.

  • CasualScrub
    CasualScrub Website User Posts: 10 Just Starting Out*

    @Triem23 thank you for your advice! I was able to make it at least slightly better, and hopefully with time I will get better and better at using the effect.

    @Andy001z I'm gonna write up everything I did and leave some screenshots here if you're still interested

    My volumetrics and light rays effects are on a grade layer. Originally I had the grade layer set on normal blend and the lighting effects set on add blend mode, but today I changed the grade layer to have screen blend, and the lighting effects to be on normal blend. This, in conjunction with the use of the hotspots effect, seems to have fixed the issue with the dark spots. Unfortunately I can't get the light rays to stand out on the side islands quite as well, so I decided to manually mask a screen mode blend layer to help get better highlights on the islands.

    The flickering I fixed by masking out the transparent part of one of my composite shot layers. I have no idea WHY this worked, but trial and error showed that this layer was causing the flickering, and this was the way I figured out how to fix it.

    Here's the finished result! https://streamable.com/48dgu7