HitFilm 16.1 keeps crashing

hehlijah
hehlijah Website User Posts: 1

I've been using HitFilm Express for a while and this is the first time I've had problems. I was editing a video and everything seem fine, and then all of a sudden the program crashed, seemingly for no reason. At first I wasn't too concerned, but now whenever I try to reopen the project I was working on, the program crashed when I try to edit anything in the timeline. I just got a new computer a few months ago, and it's fully decked out, so I highly doubt it's a hardware issue. I've tried everything I could think of, but to no avail so far.

Part of what's strange is that the program operates fine until I try to interact with the clips on the timeline. I've been able to import new media, scrub back and forth on the timeline, and play the whole project from start to finish with no problems, but the second I try to edit a clip, the program shuts down.

Does anyone have any suggestions?

Comments

  • Stargazer54
    Stargazer54 Moderator Moderator, Website User, Ambassador, HitFilm Beta Tester Posts: 3,338 Ambassador

    @hehlijah First of all, make sure you keep backup copies of your work - File001, File002, and so on. Then try an uninstall and re-install the latest version of HF. Please also list your system specs so we can all agree on the status of your hardware.

    Also make sure your drivers are updated from the manufacturer (not M$ updates which can actually downgrade your drivers). This is especially crucial for your GPU (which I suspect may be the culprit).

    The next thing to check is the media clips themselves. A MediaInfo (tree) report would be helpful to rule out any problems there. How to install and use that here.

  • dejavu1987
    dejavu1987 Website User Posts: 1 Just Starting Out

    For me as well the issue mostly seems to occur when I try to delete a cut from the timeline.

    Process:        HitFilmExpress [50556]

    Path:         /Applications/HitFilm Express.app/Contents/MacOS/HitFilmExpress

    Identifier:      com.fxhome.HitFilmExpress

    Version:        2021.1 (16.1.1265)

    Code Type:       X86-64 (Native)

    Date/Time:       2021-07-24 13:05:53.271 +0200

    OS Version:      Mac OS X 10.15.7 (19H1217)


    Crashed Thread:    0 CrBrowserMain


    Exception Type:    EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes:    EXC_I386_GPFLT

    Exception Note:    EXC_CORPSE_NOTIFY


    Termination Signal:  Segmentation fault: 11

    Termination Reason:  Namespace SIGNAL, Code 0xb

    Terminating Process:  exc handler [50556]


    External Modification Summary:

     Calls made by other processes targeting this process:

      task_for_pid: 35

      thread_create: 0

      thread_set_state: 0

     Calls made by this process:

      task_for_pid: 0

      thread_create: 0

      thread_set_state: 0

     Calls made by all processes on this machine:

      task_for_pid: 30034191

      thread_create: 0

      thread_set_state: 0


    VM Region Summary:

    ReadOnly portion of Libraries: Total=1.0G resident=0K(0%) swapped_out_or_unallocated=1.0G(100%)

    Writable regions: Total=2.1G written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=2.1G(100%)

     

                    VIRTUAL  REGION 

    REGION TYPE            SIZE  COUNT (non-coalesced) 

    ===========           ======= ======= 

    Accelerate framework        256K    2 

    Activity Tracing          256K    1 

    CG backing stores         1160K    2 

    CG image              672K    10 

    CoreAnimation           236K    24 

    CoreGraphics             8K    1 

    CoreImage              28K    3 

    CoreUI image data         1200K    11 

    Foundation             24K    2 

    Kernel Alloc Once          8K    1 

    MALLOC               1.7G   672 

    MALLOC guard page          32K    7 

    MALLOC_LARGE (reserved)      64.0M    1     reserved VM address space (unallocated)

    MALLOC_NANO (reserved)      128.0M    1     reserved VM address space (unallocated)

    OpenGL GLSL            384K    5 

    PROTECTED_MEMORY           4K    1 

    STACK GUARD            56.4M   110 

    Stack              183.4M   110 

    VM_ALLOCATE            17.7M   143 

    VM_ALLOCATE (reserved)       256K    1     reserved VM address space (unallocated)

    __DATA              55.7M   472 

    __DATA_CONST            144K    8 

    __FONT_DATA             4K    1 

    __GLSLBUILTINS          5176K    1 

    __LINKEDIT            422.9M    60 

    __OBJC_RO             32.3M    1 

    __OBJC_RW             1908K    2 

    __TEXT              593.2M   442 

    __UNICODE             564K    1 

    mapped file           282.0M    60 

    shared memory           656K    18 

    ===========           ======= ======= 

    TOTAL               3.5G   2174 

    TOTAL, minus reserved VM space   3.3G   2174 


    Model: MacBookPro15,2, BootROM 1554.120.19.0.0 (iBridge: 18.16.14663.0.0,0), 4 processors, Quad-Core Intel Core i5, 2,3 GHz, 16 GB, SMC 

    Graphics: kHW_IntelIrisGraphics655Item, Intel Iris Plus Graphics 655, spdisplays_builtin

    Memory Module: BANK 0/ChannelA-DIMM0, 8 GB, LPDDR3, 2133 MHz, Micron, -

    Memory Module: BANK 2/ChannelB-DIMM0, 8 GB, LPDDR3, 2133 MHz, Micron, -

  • Stargazer54
    Stargazer54 Moderator Moderator, Website User, Ambassador, HitFilm Beta Tester Posts: 3,338 Ambassador

    @dejavu1987 First of all, thanks for posting your specs and error output. I can only assume your issue is the same as the OP's, but may not be. More information on what you are experiencing would be helpful.

    In any event, I question the GPU in your system as it is on the low end. Plus you look to be under spec for the OS which requires OS 11 (your system - Mac OS X 10.15.7). Check against minimum system specs here. https://fxhome.com/support/hitfilm-express

    That said, make sure that your GPU drivers are up to date by following the instructions here. https://fxhome.com/faqs/view/10