Hitfilm Express pixilated my video in some parts

FKPhil
FKPhil Website User Posts: 3 Just Starting Out*

Can anyone tell me why HitFilm Expresspixilated my video in some parts?

Video was fine before editing, but some parts (not all) were pixilated afterwards, see the before & after screenshots.

I’ve used Hitfilm for many videos and this is the first time it’s happened. But of course I’d want to make sure it doesn’t happen again.

Comments

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,571 Ambassador

    Raise the Export bitrate if you're using an mp4 export, or try exporting Cineform (PC) or ProRes (MAC).

    These are compression artifacts caused by the mp4 file format. That's highly visible macroblocking.

    Hitfilm doesn't offer full control of mp4 parameters, so you might need to export Cineform/ProRes, then use an external program, like Handbrake, with more encoder control to prep the final mp4 for upload.

  • FKPhil
    FKPhil Website User Posts: 3 Just Starting Out*

    Thanks Triem. That pointed me in the right direction.


    In short, I found increasing the bitrate for MP4 export in Hitfilm Express doesn’t help, but this works:

    Export from Hitfilm as GoPro Cineform YUV 10-bit (MOV).

    Handbrake at default setting (MOV to MP4.) gives an m4v file about twice the size of the original pixilated YouTube 1080p HD export from Hitfilm, but good quality & no pixilation.



    In long

    Working with a video running for 1 min 38seconds.

    On default Youtube 1080P HD this gives a file of 0.13 GB


    (1) I found increasing the bitrate for MP4 export in Hitfilm Express doesn’t help.


    (2) Export as uncompressed AVI.

    Uncompressed AVI with Alpha. Gives a massive file (48 GB)

    Using Handbrake at the default settings (“Normal” preset) give an mp4 file of 0.23 GB with no pixilation.

    So this is a working option if you have enough memory for the massive intermediate file.


    (3) Export as uncompressed Cineform.

    GoPro Cineform YUV 10-bit (MOV) gives a big file of great quality. (4 GB)


    (3a) Handbrake at default setting (MOV to MP4.) 0.26 GB

    File is m4v rather than mp4 and I can’t get it to export as mp4.


    (3b) VLC will do it but it comes out as very poor quality at default settings.

    After a bit of experimentation, I found quality setting to 36 will give a file size 0.21 GB, a bit bigger than the YouTube 1080 export I was using (0.13 GB) but good quality no pixilation… although noticeably not as good a quality as the handbrake (0.26 GB) file.

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,571 Ambassador

    If Handbrake gives you an M4V file, you can literally rename it to MP4 and you're good to go.

    Bear in mind YouTube processing might reintroduce pixelation again.

    I'll just repost my earlier long rant on the topic here. The TL/DR version is YouTube, Vimeo and streaming services like Netflix absolutely mangle files and there's nothing you can do about it. The linked comment will use images from Rogue One taken from YouTube that look terrible. You've got your master file looking good and that's all you can do.


  • FKPhil
    FKPhil Website User Posts: 3 Just Starting Out*
    Thanks again Triem23.
    Yes I’ve noticed the YouTube quality drop. But at least now they’re not looking bad before they get there.

    “If Handbrake gives you an M4V file, you can literally rename it to MP4 and you're good to go.”
    I just found there’s an easier way!
    In handbrake:
    Tools > Preferences > output files
    There is an item there saying “MP4 output Extension”. Click on the dropdown menu button and select “Always use MP4”.
  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,571 Ambassador

    Duh! Of course you can tell Handbrake to always record MP4 and I'm embarrassed I forgot to mention it. The rename trick was just to save time on a re-transcode so you didn't reframe files.

    Anyways, good luck with your videos. Looks like you had a good and fun day to edit.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!