Hitfilm 16 and 2021 keep crashing

FunnyParadox
FunnyParadox Posts: 7 Just Starting Out*
edited May 2021 in HitFilm

Hitfilm 16 and 2021 keep crashing

I was doing video editing, and on the scene there's only 2 videos (1080/60/mpeg4), 1 artwork (4K), text box (for lyrics), and 4 audio files (mp3/224kb), and it was working very well like usual since i've got Hitfilm years ago, BUT the next day, Hitfilm (on the same project, i've didn't added anything or installed a program since) start crashing and lagging (mostly when i edit a text box, and also it makes my whole computer lag by the way, tho when i close it there's no problem it's fluid again), so i've made the 2021 update bc it said it solves crash in Windows 10, but it didn't do anything, it's been 2 days and nothing got solved and my previous post got deleted after not even a minute, but for hours (now days...) i've done everything and gone to every forum post about HitFilm crashing but nothing worked...

-------------------- SPECS --------------------

SOFT : HitFilm Express 2021

CPU : Intel Core-i5 / 8300H 2.30GHz

GPU : NVidia GTX1060

RAM : 1/16go DDR4

OS : Windows 10 Family

Comments

  • FunnyParadox
    FunnyParadox Posts: 7 Just Starting Out*
    edited May 2021

    My Hitfilm 16 & 2021 (i've updated but it didn't solved the problem) always crash, like my project isn't heavy, just 2 1080p/60fps/MPEG-4 videos files, lyrics, an 1084x2048 artwork, and that's it, yesterday i've started it and it worked really good, then it started glitching a bit and it was late so i've gone to sleep then today i've re-opened the project (with 16) and it keep crashing every 2 minutes when i edit the text a bit too much (it's like after editing only 1 box of text it start lagging and after 2/3 box of text it crashed by freezing for a bit then just closing itself) so i've decided to update because it was writted it fix the crashes, it didn't do anything, then i've read every forum page about Hitfilm Crashing since 2 hours rn, and i've tried everything (even installing light saber plug-in, bc it worked for someone) and it does nothing at all too, tho for month HitFilm was running perfectly and i've didn't installed anything between, and my computer is only a few months old, so i don't know why HitFilm keep crashing and how i can solve it... (tho when it freeze i save the file to not lost everything, but having a laggy/crashy HitFilm really slow down every thing on my computer :c tho when i close it there's no problem anymore)

    -----------------------SPECS-----------------------

    GTX1060 / RAM 16GO / i5-8300H 2.30GHz / SSD / Windows 10 Family, ver.20H2 (64bits) / HitFilm Express 2021

  • TheBenNorris
    TheBenNorris Posts: 2,042 Staff

    Have you tried contacting support directly? No one will have intentionally removed your post so there is a chance that it was flagged by the automod, so I'll have a look.

    I do recommend contacting support directly for issues like this however, including as much information as possible, including a DxDiag if you know how to do one, otherwise they can guide you through the process.

    www.fxhome.com/ask

  • Triem23
    Triem23 Posts: 20,280 Power User

    If you ran a Windows Update you should recheck your GPU drivers. Windows Update is known to revert GPU drivers to earlier versions.

  • tddavis
    tddavis Posts: 5,219 Expert

    @FunnyParadox I found this post in the Spam Queue and saw that you had flagged it as Spam I assume accidentally the day it was created. It is easy to accidentally hit that flag icon especially on a phone screen, I know. I cleared it from Spam and Merged it with this thread on the subject.

  • spyresca
    spyresca Posts: 279 Enthusiast

    It's weird, I've never had windows do that and I've probably had a few hundred updates over the years (primarily nvidia product).

  • tddavis
    tddavis Posts: 5,219 Expert

    FWIW, I had it do it to mine once for sure, but I thought it might just be an NVidia thing or when they do a major overhaul with the update like the recent one to 20H1.

  • FunnyParadox
    FunnyParadox Posts: 7 Just Starting Out*
    edited May 2021

    "so there is a chance that it was flagged by the auto-mod, so I'll have a look" oh yea i know, it was removed my auto-mod, i've edited the post then when validating the edit got a message it was removed, but didn't understood why an edit removed it XD but yea i'll ask the support with a DxDiag ^^

  • FunnyParadox
    FunnyParadox Posts: 7 Just Starting Out*

    Also i've done every Windows and GPU update and it didn't got any better sadly ^^" i'll see with the support what can i do about that, thank you ^^ (sorry i didn't knew they were a support)

  • ofarofa
    ofarofa Posts: 7 Just Starting Out
    professional support my friends :(
  • NormanPCN
    NormanPCN Posts: 4,371 Expert

    Ditto. I've never seen it when I have a manufacture driver installed. W7, W10 eras.

    Some time back, maybe W7 era, when there was a "major" (feature) update, those were not updates but were actually fresh windows installs with stuff copied from the current to the new. During that Windows may have thought they "owned" a specific driver and could/would therefore use the current Windows driver for said product. When a driver model spec was updated I suppose it could/may happen then in some cases.

  • TRjobb
    TRjobb Posts: 2 Just Starting Out*
    I have the same kind of stability issues! I have had the issues before, so it is not specifically tied to 2021.2. The program can randomly crash (a little too often)... but for me the absolute worst part is rendering (exporting) the project to a video. I can get like some 70% crashes to get a (10-15 min) video rendered.
    I have an AMD 5900X processor, 16 GB RAM, and 6800 XT GPU, win 10.
  • Triem23
    Triem23 Posts: 20,280 Power User

    @NormanPCN @spyresca of my three in-service laptops, one, TWICE had drivers rolled back by Windows. I think - as Norman implied - it was one of the major "full" updates, but don't remember.

    That same laptop also didn't correctly report GPU driver updates through GeForce Experience. I eventually got it to work, but I had to uninstall GeForce Experience, clean the registry and reinstall.

    So it's rare, but it can happen. In the case of GeForce, I suspect it was something the OEM setup - it's the same computer that had the driver reversion AND incorrect reporting of new drivers, and it's a CyberpowerPC machine (the others are Sager and HP). That's why I think it might have something to do with OEM installation. Admittedly, it's a small sample size, but shows me, from direct experience, it can happen.

    Either way, it's still best to double check a driver after a Windows update if a new problem arises, and to check drivers directly from the manufacturer's website as general advice, rather than a long run of if/then.

  • NormanPCN
    NormanPCN Posts: 4,371 Expert

    @Triem23 My stuff has always been hand built/assembled by me. As generic/general as it can get. I don't have a use for a laptop PC.

    I wonder if OEM drivers, OEM "manufacture" drivers, are marked as system drivers that can be replaced by a Windows update should the update think it necessary. Such a thing may relieve the OEM of potential driver update/support issues. At some level.

  • Triem23
    Triem23 Posts: 20,280 Power User
  • Sumeriansun
    Sumeriansun Posts: 1 Just Starting Out*
    edited November 2021

    I have the same problem. It crashes no matter what I modify. Did reinstall, delete cache, reboot, check driver. Nothing works. And I have a deadline in 3h.

    Later edit. It was the graphic card. I messed around with it and in the end I just went back to factory reset. It is fine now. It's working pretty fast(er).

  • juanito_deforme
    juanito_deforme Posts: 2 Just Starting Out

    I fixed the constantly crashing in special while trying to use the Viewer

    Please, I only tried with my PC so it might not work for all of you (I have and Radeon RX6600XT graphic card)

    Uninstalled the Radeon software from the control panel

    Uninstalled HitFilm and deleted every folder related (good idea make a list of which folders it used before)

    Press Win+R to summon the Run dialog box. Type Regedit and press Enter.

    Look in each of the 5 HKEY.... folders for the subfolder "Software > FXHome"

    Delete all the FXHome folders

    Go to Radeon drivers web site https://www.amd.com/en/support and choose your graphic car model

    Download the one which says Radeon™ Pro Software for Enterprise, and install it

    Install the HitFilm software again

    Voila!!! since then is faster and not crashed at all

  • fxhomer26856
    fxhomer26856 Posts: 9 Just Starting Out*

    I hate to revive a dead thread, but HFE 16 through 2021.3 were crashing upon launching until I disabled my GPUs built overclocking utility.

    For reference:

    i9 9700k

    Asus ROG RTX 3060 OC

    Asus GPU Tweak 3 Utility

    32 GB RAM

    500 GB NVMe and 8 TB HDD