Objects are visible even if behind an imported 3D object

philmad
philmad Website User Posts: 4 Just Starting Out
Hi, I imported two 3D imports in format fbx. One is a hangar and the other one an objects that arrives in the hangar. However the ariving object is visible even if it is still behind the walls of the hangar. What's wrong? Any ideas? Unfortunately I can't add a frame I rendered with the problem. Kr, Phil

Comments

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,970 Ambassador

    There are "Compositing Modes" for 3D model layers. 2d, 3d, 3d Unrolled.

    2D is the default. A 2D model layer calculates, renders and passes to the layer's Effects Chain. You're rendering a picture of a 3D model to a 2d layer. In 2D mode composites happen in layer order. The top layer always renders above the lower layer. This is what you're seeing. In 2D mode sometimes you have to break a layer up. Split the plane's layer and, when it's behind the hanger, you put the plane under it, then swap to a plane layer above the hanger as needed.

    3D mode is like 2D except the image layer itself is a flat 3D card that can move in 3D space. You'll never use this mode for models.

    3D Unrolled calculates all 3D layers but does not render until reaching a full 2D video/photo/plane/grade layer (or the top of the layer stack). In 3D Unrolled mode models occlude correctly in Z-space but, because the render is delayed you cannot add Effects to individual layers.

    If you are in Pro (Only) you have another option called "Depth Layer." Using Depth Layer you leave your models in 2D Compositing mode but, on the top model layer (your plane) you'd go into the Layer Controls and choose the bottom layer (hanger) as the Depth Source Layer. Now Hitfilm will calculate occlusion for the plane based on the hanger, render, and send the render to the Layer's Effects. If you're in Pro this is your best solution.