Issue with importing 3d models in to hitiflm

Maneskane
Maneskane Website User Posts: 4 Just Starting Out

I want to import a 3d model that I made in Blender in to Hitfilm. I used a tutorial from the FX home yt channel. https://www.youtube.com/watch?v=kBFqPSq49mc&t=155s

My problem is when I've already imported the .fbx model and I want to add the .abc animation file the model becomes invisible. Would appreciate some help :)

Tagged:

Comments

  • GrayMotion
    GrayMotion Website User Posts: 1,594 Enthusiast
    edited January 19

    Are you using the AT-AT that is used in the video by FXHome by chance?

    Scratch that. I didn't read properly but it might be the same issue that they show in their own video.

    @spydurhank is the resident Blender guru and he knows what's going on for sure. I do know whats happening but cant articulate to you what you need to do like he can.

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,953 Ambassador

    As @GrayMotion says, Frank, @spydurhank, is the leading Hitfilm/Blender expert. Until he chimes in, I have one idea.

    Try exporting your animation as FBX instead of ABC? I think FBX works better in Hitfilm, and, of course, FBX MODELS are supposed to work with FBX ANIMATION.

  • Maneskane
    Maneskane Website User Posts: 4 Just Starting Out

    Thanks for the suggestions I Will try to do that!

  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,177 Expert

    Thanks @GrayMotion and @Triem23 :)

    Hey @Maneskane how are you? :)

    If you could post a few screengrab pics or even better, a screen capture video of how you're exporting your model from Blender... it would also be massively helpful if you could show yourself importing the Model and animation into Hitfilm. If not then maybe answer a few questions please? I can spot the issue right away but I just need to see it with my own eyes first. :)

    If any of the following is incorrect, it will for sure mess up your model and animation.

    Is the scale applied to your 3D object?

    Does your 3D object have a single Material or does it have several?

    Does it have several texture sets or does it have a single UV Atlas?

    Does it have Animation groups? Is your model made up of one object or several?

    Was your model built with Modifiers? If yes then apply them first before export. Very important.

    Does it have smooth/hard/sharp edges marked? If not then mark your edges accordingly with Sharp edges... but only if you know what your doing because Sharp edges actually split faces in two which creates more geometry, which could be inverted or even overlapped on export. Modifiers use marked "Sharp edges" which is the correct thing to do to get proper shading in a 3D app but as I said, they also have the unwanted side effect of creating extra geometry as the mesh is being exported. The modifiers and stuff is what messes up an alembic file most of the time so make super duper sure, that you apply modifiers before export.

    Is it made from Quad faces? Triangle faces? N-gon faces? Or all three types of polygons? Hitfilm can import all three types of polygons and display them correctly and with your specified shading angle but only if the 3D object was built properly. If you used a poor mans technique to build your 3D asset and you either don't know how to repair or simply just don't want to start over "be lazy" :) , then you can use another poor mans trick which is used by damned near everyone on this forum... and that is to triangulate your mesh on export. But this doesn't always work with N-gons. :)

    I'd take that tutorial which you're following with a grain of salt and don't expect it to be gospel or even work in your situation because fbx and alembic animations do not always work as described in either Blender or Hitfilm. The Alembic format has been around for a while but it's practically brand new in Blender and Hitfilm. Alembic animations and exports still need a lot of work but you can always track down an issue which most of the time leads to an improperly built mesh.

    Any tut "Except for my tuts" that you've ever seen anyone import a 3D model with an animation into Hitfilm... they've had to adjust the smoothing angle to around 20 degrees because the model imported with the incorrect shading angle. Changing the smoothing angle itself will destroy any smooth edges and or smooth bevels. Shading angle and bevels are supposed to be nailed down during the modelling phase of a 3D object... if you do this incorrectly... then you're gonna have a huge domino effect of errors that you'll need to attempt to fix in Hitfilm during import. And being that Hitfilm is not a 3D modelling program... it can only do so much. So again, it's important to get this correct at the beginning.

    Josh had to do the things he did in that video tutorial because that AT-AT model was both weirdly built with modifiers and the model also has several N-gon faces that logically depend on modifiers to display proper shading, which is the most likely culprit that throws off the shading when you import to Hitfilm plus, although fbx animations are supposed to work with 3D fbx models... that doesn't always work depending on how the 3D model was built and animated. If you need to adjust the shading angle of your mesh on import to Hitfilm because the shading looks off... it means the model was built improperly.

    Now here's some stuff that you can try in Hitfilm if you can't or don't feel like starting over in Blender. This is where most people end up when they become frustrated and are all like... this is good enough which is part of the domino effect that I mentioned..

    If your mesh will not be seen up close to the camera, then you can go ahead and change the smoothing angle depending on how you want your mesh displayed. Like I said, use 20 degrees to make flat faces look flat and. Again... this ruins smooth faces and smooth bevels. This basically destroys your shading but most people don't care at this point so they simply ignore all the shading errors and in most cases... it's like people don't even see the shading errors... it don't matter if your object will be a good distance from your camera so don't worry too much. :)

    If your Alembic animation is turning your 3D model Black... it's actually inverting your normals and shading angle by about 70 degrees in the wrong direction. To fix this and not have to go back into Blender... you'll need to change the smoothing angle in Hitfilm to 30 degrees. Do this after you apply the Alembic animation so that you can see the change and fix at the same time. You should see your faces flip over. This won't save your hard edges or smooth bevels but at least the normals and faces will be facing in the correct direction. :)

    This might be a little rough on you if you're using FBX because that animation format doesn't support correct shading angles when imported into Hitfilm and it never has. Sharp edges on an fbx file are simply not imported into Hitfilm and FYI... FBX models in Hitfilm always reqiure you to change the smoothing angle so whenever you have an FBX file...be prepared to change the shading angle because fbx shading angles in Hitfilm always looks like balloons that are slightly overfilled with air. Again you can simply change the shading angle in Hitfilm. You should be just fine if your model will be far from the camera and you don't care about those nice bevels that you built into your model. :)

    I code and build my own version of Blender named Filmer because I literally know all of the proper ways to export anything and everything into Hitfilm without a problem because I build all of my own 3D assets... but exporting 3D objects over to Hitfilm has to start at the beginning... meaning that it's best to use proper modelling techniques when first creating a 3D object. Most people give up here because they have become frustrated. They've watched too many videos which show them techniques which are out of context because most 3D modelling techniques are not meant for export. For example... any modelling techniques using modifiers are not meant for export to Hitfilm so you've really got to watch out for modifiers because those things will mess you up sooooooooooooo bad. You've also got to watch out for most hard surface models that were built for game engines... mostly because they'll have overlapping UVs caused by a "mirror modifier". You won't need to worry about objects that were created with a mirror modifier if... you don't plan on using a Normal and Specular map, or plain ole Ambient Occlusion in Hitfilm because Normal and Specular maps as well as AO, easily display shading errors in a mesh.

    Here's my website if you're interested in learning about Filmer.

    owmycgi | Home

    Here's my YT channel

    spydurhank - YouTube

    And a few demos of me exporting an entire 3D scene to Hitfilm with no shading errors.

    Hey Greg @GrayMotion , if you watch the two videos directly below... you'll understand everything right away after our chat a few weeks ago. Give it a try dude... it'll give you more insight. :)


    In this demo I export a 3D scene with an alembic animation... The 3D hero asset has several materials but a single UV atlass, I get no shading errors when I apply the .abc file. The Optimus Prime and building, had to be cleaned up. Prime came from Sketchfab and the Apartment block came from Gumroad. So even though the 3rd party 3D assets had many shading. inverted and overlapping geometry... I was still able to export with no shading errors. :)

    A short video demo of me creating a 3D Monitor screen and importing it into Hitfilm.

    Longer version of the video directly above.


  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,953 Ambassador

    @spydurhank for me this is your best explanation yet. Definitely something I save to my reference file.

  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,177 Expert

    Hey thanks for the Mike @Triem23 :)

  • Maneskane
    Maneskane Website User Posts: 4 Just Starting Out

    @spydurhank

    thank you for taking the time to Write such a long and well thought out answer! I actually managed to fix the issue by only exporting as a fbx and changing the settings from what was shown in the fx home tutorial.

  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,177 Expert
  • tddavis
    tddavis Moderator, Website User Posts: 5,062 Moderator

    @spydurhank Archiving...of course! 🤣

  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,177 Expert

    Thanks @tddavis . :)

    @Maneskane , hey I forgot to ask,

    Could you post the settings that you used differently than the settings which are used in the video tut? It could help others with the same issue.

    Another question... what did you do about shading issues that automatically happen when you export as .fbx?

    Did you simply change the shading angle in Hitfilm to get rid of that bubble wrap shading issue? or...

    did you leave the model as is on export from Blender?

    If the .abc turns your model black when you apply it... then the only way to get around that is to change the shading angle.

    Just wondering what your settings are. :)

    I'm also interested in checking out your model. Could you post a few screen grabs of it? Unless it's for a job, then you probably can't.

  • Maneskane
    Maneskane Website User Posts: 4 Just Starting Out

    @spydurhank

    Here are the settings that I used:

    I didn't notice any shading issues? Maybe i just didn't notice them since Im not very experienced. This is actually my first 3d work and my first time using blender.

    Here are a few screen grabs of my model, it was just a quick camera pan with a 3d environment that I made using free environment models from different websites. The animation was just my monster character moving their arms and standing there. But I'm actually quite pleased with the result especially since its my first 3d work. :)



  • spydurhank
    spydurhank Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 3,177 Expert

    @Maneskane ,

    Ha... the whole time I thought your model was hard surface. :)

    This is a sculpt yeah? Looks pretty good. :)

    I only see a few seems in your UV unwrapping and just a tiny bit of stretching in your textures. Still came out pretty good though. :)

    Thanks for the settings. :)