Hitfilm Pro - Element 3D and OpenGL errors

GrayMotion
GrayMotion Website User Posts: 1,594 Enthusiast
edited January 17 in HitFilm

I have had several inquiries about an OpenGL error and Element 3D. Many users are experiencing difficulties when trying to use Element 3D with Hitfilm so I thought I'd point out things that are a must when using E3D.

  1. Recommended Video Cards. Please see Video Copilots support page
  2. Windows 10 ONLY - updates tends to overwrite GPU drivers. It is best to go directly to the card manufactures website for the latest GPU Drivers. Nvidia Drivers and AMD Drivers
  3. AMD Radeon Software - General Settings: Anti-Lag=Enabled, Image Sharpening=Enabled Advanced: Anti-aliasing=Enhanced Application Setting, Anti-aliasing Method=Multi Sampling, Morphological Anit-aliasing=Enabled, Anisotropic Filtering=Enabled, Anisotropic Filtering Level=2, Surface Format Optimization=Enabled, OpenGL Triple Buffering=Enabled
  4. NVIDIA - Try turning OFF Hitfilm's hardware-decoding. File -> Options -> Render -> Uncheck Use Hardware Decoding.

By far the biggest thing is making sure your GPU is supported. Intel Graphics cards are NOT supported.

*Do a clean-driver install.

**Support for Select AE Plugins was added at version 14 Pro. You cannot install VC plugins in earlier version of Hitfilm. Hitfilm Pro ONLY.

***Support for:

  • Red Giant – Trapcode Particular – organic 3D particle/motion graphics
  • Video Copilot – Element 3D – import and animate realistic 3D models
  • Video Copilot – Optical Flares – customizable, realistic lens flares
  • Video Copilot – Saber – high energy beams, neon lights, and other similar effects
  • Video Copilot – Orb – 3D spheres and planets
  • Video Copilot – Heat Distortion – realistic heat waves and mirage effects


Tagged:

Comments