Blending of two (or more) layers

FlyxOinti
FlyxOinti Posts: 4 Just Starting Out

Hey guys,

Since about the last 2 updates I've been experience a very frustrating bug (or feature?).


(Watch the screenshot for more clarity)

I want to blend out a clip using the opacity feature (100% -> 0%) and in that exact same timeframe, I want to blend in a clip, that lays beneath the first one. For some reason, the program is only able to display the bottom clip, even though the two clips should overlap at some point so that the upper clip blends into the lower clip.

Do you guys experience similar issues or do you know how to fix it?

It's really frustrating because I can't work with the program as I have been for the last 2 years.


Comments

  • EvilDaystar
    EvilDaystar Posts: 301 Enthusiast

    So I tried it and it works perfectly fine for me.


    You don't need to keyframe opacity on the bottom layer. you'll get the same effect leaving opacity at 100% on the bottom layer.

    Upload a copy of a test project where that happens and maybe someone can have a gander.

  • FlyxOinti
    FlyxOinti Posts: 4 Just Starting Out

    Hey! :)

    First of all, thank you for answering! I didn't know that you can just leave the bottom layer alone, so thank you for your advice, it saves me a lot of time ^^

    So... I made some testing and I found out some interesting interactions



    My composition:

    • "final" is a composite shot that contains composite shots (see the structure in the image below)



    • "Composite Shot 18" is a composite shot that only contains a video (as you can see, it's labeled as [Media])



    • "blueprint" is another composite shot that contains composite shots (similar structure to "final")



    My results:

    • Overlaying "final" about itself causes the editor to brake and not apply the opacity change:



    • Overlaying "final" about "Composite Shot 18" doesn't cause any issues and applies the opacity change:



    • Overlaying "final" above "blueprint" doesn't cause any issues and applies the opacity change as well:



    • Overlaying "blueprint" above itself causes the editor to brake and doesn't apply the opacity change (similar to "final" above itself"


    So... it seems like you can't overlay the same composite shot. that already contains composite shots, twice.




    My questions:

    • Is that a known feature or a bug? If it is a feature, why is that in place? To prevent some issues with the program?
    • Can you replicate that same in your program?
    • If no, do you have any ideas how I can fix that bug?


    Thank you for answering! Looking forward to your answers :)

  • CleverTagline
    CleverTagline Posts: 3,316 Ambassador

    You didn't talk about this specifically, so I'm going to ask: in the case where it's the same composite shot layered over itself, is the lower layer from a different part of the composite shot than the upper layer?

    To make my question clear, imagine that I have a 26-frame composite shot, with each frame assigned a letter of the alphabet:

    ABCDEFGHIJKLMNOPQRSTUVWXYZ
    

    In another composite shot, I bring in two copies of that 26-frame composite shot and stack them above each other:

    ABCDEFGHIJKLMNOPQRSTUVWXYZ
    ABCDEFGHIJKLMNOPQRSTUVWXYZ
    

    I trim off the end of the upper layer and the beginning of the lower layer, which gives me something like this (I'll refer to this below as Overlap A):

    ABCDEFGHIJKLMNOP
              KLMNOPQRSTUVWXYZ
    

    Notice how the letters (frames) match between layers. If I fade out the top layer, I won't really notice it because the top and bottom layers have matching frames. However, if the bottom layer is from a different part of the composite shot, then I'll see the change (this is Overlap B):

    ABCDEFGHIJKLMNOP
              EFGHIJKLMNOPQRS
    

    With that illustration done, I'll ask my question again: is your lower layer from a different part of the composite shot than the upper layer (like Overlap B), or does the content match between layers (like Overlap A)?

    If the footage matches in the upper and lower layers, then that explains why you're not seeing the transparency change: because you're transitioning to the same footage. The editor isn't breaking because you're fading out KLMNOP on top of KLMNOP. The fade is still happening, but because the content matches, you can't see it.

  • CleverTagline
    CleverTagline Posts: 3,316 Ambassador

    @FlyxOinti Your latest comment got posted three times, but two were held in the spam queue. I just released them, then deleted them to avoid the duplication. Just an FYI going forward, if something doesn't post right away, or you see a spam warning, please refrain from re-posting and wait for the pending posts to be moderated.

  • Triem23
    Triem23 Posts: 20,080 Ambassador

    There's a bit of a regressive bug in 15 that's causing oddities with Comp Shots.

    Composite Shots are PROCEDURAL media - calculated per-frame. The bug seems to be causing glitches with procedural Comps.

    Generally, PRE-RENDERING the Composite clears up the problem. A Pre-rendered comp has been written to a cache file and is now treated as a VIDEO CLIP.

    Basically pre-render you nested comps and see if that fixes the render errors.

  • FlyxOinti
    FlyxOinti Posts: 4 Just Starting Out

    Well, first of all thank you for your comments. I experienced some issues with the post, so thank you for clearing them! :)


    About the composite shots:

    I've made the time difference between the two clips as large as possible to avoid this. So e.g. the first clip of that same composite shot starts at 5 seconds and ends with 10, while the second one starts at 30 and so on. So that shouldn't be the problem, I think. The problem, for me, is always there when working with the exact same composite shots.

    Pre-rendering unfortunately doesn't help either, as it basically switches from the upper to the lower layer without any transition.

    I'm working with very fine margins of frames, so maybe that's the problem while editing. Maybe I'll need to be a bit more spaced out work, so that this bug doesn't occur.

  • tddavis
    tddavis Posts: 5,096 Moderator

    @FlyxOinti Something you mentioned, "... lower layer without any transition."

    Are you trying to use a transition in a composite shot? I don't think you can if you are.

  • CleverTagline
    CleverTagline Posts: 3,316 Ambassador

    @tddavis Based on the original post, the transition is just an opacity change on the upper of the two layers in question.

    I'm working with very fine margins of frames

    @FlyxOinti What do you mean by that?

    Do you have a way of recording a screen capture video to show the problem? Maybe there's something going on that we're not aware of because we just can't see it in realtime. On a related note, there's a slim chance that the problem might be isolated to that project. Try making a new project from scratch that has a similar setup (perhaps with not as many layers in the comp that you're embedding) and see if the problem is still there.

    This question hasn't been asked yet, so I'll ask for the sake of covering all the bases: What are your system specs? OS, CPU, GPU, RAM, and free hard drive space. Are your video card drivers up to date?

  • FlyxOinti
    FlyxOinti Posts: 4 Just Starting Out

    It actually was an issue related to the project. Maybe it was corrupted or something like that. I tried to re-create the transition and it worked perfectly fine.

    Thank you for your help!