Speed Plugin not working

TTSProd
TTSProd Posts: 69 Just Starting Out
Hi fellow Hitfilm users, this is my first post here although I've been lurking around awhile finding answers to my many, many questions!
I have not found another post where anyone mentions that the speed plugin does not work for them.  In my projects, if I insert the speed plugin and make an adjustment, up or down, the viewer just goes black and I can no longer see the video.  I can't figure out what I'm doing wrong.
The video is Prores 422 HQ 1920x1080 59.94fps
My computer is...
Processor i7 3770k
Ram 16GB
GPU GTX 660Ti 2 GB
Other than this one issue... HitFilm 2 Ultimate ROCKS!
Ken 

Comments

  • Ady
    Ady Staff Posts: 1,517 Staff
    Hi fellow Hitfilm users, this is my first post here although I've been lurking around awhile finding answers to my many, many questions!
    I have not found another post where anyone mentions that the speed plugin does not work for them.  In my projects, if I insert the speed plugin and make an adjustment, up or down, the viewer just goes black and I can no longer see the video.  I can't figure out what I'm doing wrong.
    The video is Prores 422 HQ 1920x1080 59.94fps
    My computer is...
    Processor i7 3770k
    Ram 16GB
    GPU GTX 660Ti 2 GB
    Other than this one issue... HitFilm 2 Ultimate ROCKS!
    Ken 


    Hi Ken,
    The Speed Effect applies to the Layer itself - it's not the same as a rate stretch tool in something like Premiere. (incidentally, I'd love to see a proper rate stretch tool added in the future)
    You can't go backward from the first frame, as there are no frames available before it, so negative values in Speed will just give a black frame, unless you keyframe into the negative value partway through the clip.
    So as an example, if your clip is 30 seconds in total length and you want a 0.5 slowdown then you're only going to see 15 seconds worth (over 30 seconds) of the original 30 second clip.
    To get around this problem, first embed the video into a new Composite Shot, and set the new comp to be twice the length of the video.
    Then embed that composite shot and apply the Speed Effect to that. This means you can change it to speed 0.5 and see the whole thing.
    I hope this helps & at the very least makes sense!
    Thanks,
    Ady

  • TTSProd
    TTSProd Posts: 69 Just Starting Out
    Thanks Ady,
    It helps and makes sense!  Thanks for taking the time to respond.
    Ken
  • Micha3D
    Micha3D Posts: 29
    Could be great if the speed tool could be used to stretch a clip without to lost a part. I tried to animate the speed factor without to loose a part and it's disappointing that it isn't possible. Looks like a simple task but ... . :(