A Few Bugs I've Found

SojournerKai
SojournerKai Posts: 1 Just Starting Out

Hello, I couldn't find an appropriate location to report bugs, so I'd figure that I'd ask if this is a thing specifically on my machine or if these are a more widespread issue.

Bug #1 - Changing Font Type Causes Text to Crash

I was trying to find the perfect font to use for a text layer in a composite shot and when you click on the font type, you usually can navigate with the arrow keys to see what each font looks like. However, when I was scrolling through fonts this time around, about ten or less switches in, the layer and subsequently my viewer froze completely. I can still hear audio and manipulate other parts of the video just fine, it's just when I've been going through font family options that my viewer freezes. I can't delete the layer either, it's just permanently pasted on there and have to restart my program to clear the error.

Bug #2 - Switching to Composite Shots to Edit Text

When I switch from the editor to a composite shot and try to modify a text layer, about 50% of the time HitFilm won't read what I'm typing into a text layer as text but rather as shortcuts (V = select tool, I = in point, etc.). If I click back on the editor and then back on the composite shot, it's fine, but it's still a weird bug nonetheless.

Bug #3 - Naming Composite Shots

This one's a bit harder to explain, but when you create a new composite shot it gives you the option to change the title. If I start typing in the title box, then hit Ctrl+A and try to delete the text in the title box, it won't clear on the first try. Instead, it usually takes two or three attempts, using Ctrl+A, to clear the title. From what I can tell, the program is deleting the text in the box one word at a time, regardless if I've input a command to select all, though I'd have to double check that.

Are these bugs things that I've just run into and is a result of my machine? If so, is there some way that I can avoid them?

PC Specs: Win 10, 64 bit, 8 gb, Ryzen 5 2400, RX 570 8 GB

Tagged:

Comments

  • Andy001z
    Andy001z Posts: 3,152 Ambassador

    What's the version of Hitfilm please?

  • Triem23
    Triem23 Posts: 20,080 Ambassador

    Bug #1. I tried to recreate this on all three of my laptops, but could not. It might be specific to your system. Your specs would help - CPU, GPU, OS, RAM and storage. Also, with any odd Hitfilm behavior it's always a good idea to check GPU drivers. Old drivers can cause all kinds of problems.

    Note: Windows Updates sometimes roll back GPU drivers. Last week's update rolled back one of my machines.

    Note: Some manufacturers lock drivers to one they like and block updates. I have this issue on one of my machines.

    Bug #2. Not a bug. Keyboard shortcuts are panel-sensitive. The last clicked "active" panel determines what keys do. When you click to a comp shot or click a layer the layer stack becomes active. Yeah, you then have to click the viewer to make that active before typing. You're seeing layer panel shortcuts activate.

    I've never noticed this and didn't test it. Does strike me as odd behavior. I just always hold down Backspace.

  • FilmSensei
    FilmSensei Posts: 3,108 Expert

    @Triem23 I believe the OP's specs are on the bottom of his post.

    I can't get #1 or #3 to replicate on my machine. #2 happens to me all the time! 😀 I often will click off the panel and still think it is activated.

  • Triem23
    Triem23 Posts: 20,080 Ambassador
    edited October 2020

    Oops, apologies, @SojournerKai! You did list specs. You're in spec, that's cool. Still recommend double checking drivers.

    @FilmSensei #2 gets everyone. Panel-sensitive is used in a lot of programs and it always sucks with the text tool.

    Why d'ya think so many text tools have a pop up panel to enter text? 🤔😉

  • [Deleted User]
    [Deleted User] Posts: 1,995 Just Starting Out

    #2... Deary me. Imagine if there was a hockey that youd press which locked the panel but still allowed interaction with other panels. Million dollar idea fxhome