I can't run the program

eduardogarnica
eduardogarnica Posts: 1
edited March 2020 in Post-production techniques

I installed your program but at the time of opening it it sends me the error that the OpenCL.dll file is missing, what can I do to remedy it?

Comments

  • Triem23
    Triem23 Posts: 20,073 Ambassador

    This is a Windows error, not actually Hitfilm related.

    https://windowsreport.com/opencl-problems-windows-10/

  • NormanPCN
    NormanPCN Posts: 4,082 Enthusiast
    edited March 2020

    Reinstall your video driver and make sure it is the current version. OpenCL is installed by, and is the responsibility of, the video driver.

    This all assumes your machine meets minimum specs.

  • wotsmyname
    wotsmyname Posts: 1
    edited March 2020

    this issue drove me crazy. Loads of disk space, all the latest drivers, running latest Windows 10..... None of the suggestions here and other places worked. 

    The solution for me.....

    After installation, navigate to C:\Program Files\BorisFX\ContinuumHitFilmOFX\12\lib\

    Here you should find OpenCL.dll

    Copy this ( leave the original file where it is ), and paste here..

    C:\Program Files\FXHOME

    By placing this file in the route of the FXHOME folder, Hitfilm Express 14, the progams for me now runs fine.

    As this OpenCL.dll file is what the installation creates, I'm sure it's the correct one, as I've had no startup or running issues since doing this.

    I hope the HF technical team pick up on this, as their continuing suggestions of loading the latest drivers, re-installing, just didn't work for me.

  • NormanPCN
    NormanPCN Posts: 4,082 Enthusiast
    edited March 2020

    You do what you want but OpenCL.dll normally comes from \Windows\System32\. Installed there by the video driver. In that location it is available for all apps.

    Certainly someone like Boris can have their own copy/install of the Khronos OpenCL.dll but then that is never updated with new versions of video drivers.

    OpenCL is a language for parallel compute on GPUs. This is why it is best handled by the GPU/video driver.

  • [Deleted User]
    [Deleted User] Posts: 1,995 Just Starting Out

    "I hope the HF technical team pick up on this, as their continuing suggestions of loading the latest drivers, re-installing, just didn't work for me."

    The FXhome advise isnt the best in regards to driver installations. The provided "clean" install options from both brands GUI is far behind a third party solution like "Display Driver Uninstaller". Its better than a decade ago but obviously youve noticed its still not where it should be since OpenCL is included in every driver installation if done correctly.

  • fxhomer72400
    fxhomer72400 Posts: 1 Just Starting Out

     For me, it worked by following Wotsmyname's advice! But instead, I had to place the OpenCL.dll copy one folder deeper in C:\ProgramFiles\FXHOME\Hitfilm Express. 

    This worked and the program finally ran!

  • funmode
    funmode Posts: 1

    THIS IS A WINDOW 10 THING. 
    HERE ARE THE STEP YOU MAY TAKE 
    STEP 1 - ON THE TYPE HERE TO SEARCH, TYPE IN opencl.dll 
    STEP 2 - RIGHT CLICK AND COPY  
    STEP 3 GO TO THE FOLDER SYSTEM32 AND RIGHT CLICK AND PASTE
    STEP 4 - RESTART COMPUTER AND RESTART THE PROGRAM AND THAT SHOULD DO IT. 

  • TheBenNorris
    TheBenNorris Posts: 2,033 Staff

    @funmode we don't recommend manually editing and moving DLLs. The solution to this should just be a re-installation of graphics drivers.

  • TheGift
    TheGift Posts: 1 Just Starting Out*

    This worked for me, putting it in the Hitfilm Express folder itself. Good stuff guys! Thanks so much.

  • Stargazer54
    Stargazer54 Posts: 3,438 Ambassador

    Again, as @TheBenNorris says, fooling around with moving dll's and/or fiddling with the registry is not recommended. Any future users with this issue should contact FXHome support directly before doing potential damage to the computer OS.

    Ben, you might consider closing this thread, as it is over a year old.

This discussion has been closed.