Can't add fonts

NeilHelfNeilHelf Website User Posts: 5

I've been trying to get a font in to work but it doesn't show up. 

It's a ttf font that works with all the other programs I've tried. The font is in the windows folder and shows up and everything else seems to be clear 

Any help?

Comments

  • AxelWilkinsonAxelWilkinson Staff Administrator, Imerge Beta Tester, HitFilm Beta Tester Posts: 5,240 Staff

    Which font, specifically?

    Are you trying to use it in the Text tool, the Text effect, or one of the other, more specific effects involving text (End credits crawl, Pulp Sci-fi Title Crawl, etc.)?

  • NeilHelfNeilHelf Website User Posts: 5

    The font is called Lazer 84. I'm trying to use the text tool

  • AxelWilkinsonAxelWilkinson Staff Administrator, Imerge Beta Tester, HitFilm Beta Tester Posts: 5,240 Staff
    edited February 28

    The font works for me, but it doesn't appear properly in alphabetical order in the font list. Possibly HitFilm is handling it weirdly because the name of the font isn't properly capitalized, I'm not sure. But anyway, if you scroll all the way to the bottom of your font list, do you see it there, down below the Z's??

  • NormanPCNNormanPCN Website User Posts: 3,945 Enthusiast

    @AxelWilkinson "The font works for me, but it doesn't appear properly in alphabetical order in the font list"

    Hitfilm seems to sort/order the font names in a case sensitive manner. With that "A" < "a". Maybe the order should not be case sensitive.  To normal humans "A" is "a". The same letter. Should be a simple change if a Dev decides to go that way.

    Most fonts have the font name in the metadata with the first letter of the name capitalized. Not so with this font. Actually in my experience, the fonts I have used, all fonts have the name  capped in the first letter.

    Tag @TheBenNorris

     

  • NeilHelfNeilHelf Website User Posts: 5

    I can't seem to change the capitalization and I can't find it at the bottom of the list

  • NormanPCNNormanPCN Website User Posts: 3,945 Enthusiast

    @NeilHelf

    The font works for me also. As described by Axel. Windows 10.

    In my case I tested with the text tool. Installed for all users. Installed with a the font copied to the Windows fonts folder or not. Both mechanisms worked. I did not try installing for a single user account (assuming you are on Windows).

    I think you need to be very specific about how you installed the font, your version of Windows, and while you are at it, your version of Hitfilm.

    I also tried the text effect and it works fine so long as the font file is copied to the Windows font folder as a part of the install. The font enumerator, and especially the styles, of the various text effects is kinda fubar.

  • NeilHelfNeilHelf Website User Posts: 5
    edited February 29

    I am running Windows 10 and I've installed it as all users. My version of hitfilm is Hitfilm express 2017 (the free version). https://www.dafont.com/lazer84.font this is where I downlaoded it

  • NeilHelfNeilHelf Website User Posts: 5

    I got it to work again. Thanks everyone for your advice

  • NormanPCNNormanPCN Website User Posts: 3,945 Enthusiast

    @NeilHelf "My version of hitfilm is Hitfilm express 2017 "

    That is an old version of Express. In part, that is why I asked about the exact version specifics. Express 2017 (V5) may behave different than the current V14.

  • triforcefxtriforcefx United StatesModerator, Website User Posts: 1,059 Moderator

    @NeilHelf If you’re on Windows 10, then you should at least be able to run up to HitFilm 11, and quite possibly, up to the most recent version of HitFilm 14. You may be surprised to see just how many new features and improvements have come about since 2017. Give it a go! You can get the most recent versions without even uninstalling 2017 if you like.

Sign In or Register to comment.