[SOLVED] Processor Trouble: 6700K

Hictor
Hictor Website User, Imerge Beta Tester, HitFilm Beta Tester Posts: 342 Enthusiast
edited February 2020 in General

So, I have an i7-6700k that runs 4.0 GHZ.
 
By the naming convention, I'd say its a 6th Gen processor.

I had my doubts for a while, but I felt like something wasn't quite right until I recently opened VEGAS PRO 17 and for whatever reason, cannot see the Quick Sync Video feature showing. That's ridiculous, considering a much inferior laptop of mine has it.

And when I checked these specs right here: (Details about the Processor) I knew I wasn't crazy to think something's a lil off.

I went over to the Drivers section though and tried downloading a driver, but I get the error that the file I downloaded isn't associated with what's on the board. What's more puzzling is Intel's very own detector can't figure out what the hell my PC's housing, so...I'm kind of dumbfounded. 

Is it something in the bios? I don't mess with those settings, normally. 

Comments

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!