Starting to get fed up with trying to adjust my freehand mask to the moving object.

rudefuk_rudefuk_ Website User Posts: 3
edited December 2019 in Post-production techniques

New issue: 

Used Mocha Hitfilm to crop out the animated object. But when I apply the shot to the 'Editor', the footage became very laggy, showing about 2-4 frames of the footage instead of a smooth 52 frames...

-------------------------------------------------------------Version 1------------------------------------------------------------------

Hi all, 

I am a beginner when it comes to using HitFilm. Recently got the Pro version from HumbleBundle but I have used the software previously (Hitfilm Express) a few years back.

Been watching the Beginner Tutorials and playing around with the software.

 

Current: I want to crop out an animated object and am using the Freehand Masking Tool to crop out. At every frame, I will adjust according to the object. After like an hour of adjusting each frame, I tried to replay back the video to realize that the latest masking shape is being applied to the whole scene.

 

Want to know: If there is an easier method (maybe integrating the Tracking feature) to mask out the animated object quicker - having every frame mask out the background apart from the moving object.

Comments

  • JBaymoreJBaymore Website User Posts: 334 Enthusiast
    edited December 2019

    I'm sure someone here who knows far more than I will post a link to a tutorial on this. But to get you started,................

    What I am thinking you want to do here is what is known as 'rotoscoping'.  I'm still using HF 11... so not sure if things have changed in 14.... but Mocha Hitfilm applied to the clip in question will give you the tools you need to have a frame-by-frame mask that follows the edges of the object you want to mask out in " animation".

    Be warned, the trackling of the edges you select can be vey loose and almost always requires manual keyframing.  It can still be tedious and time consuming.

    best,

    ......................john

     

  • NormanPCNNormanPCN Website User Posts: 3,947 Enthusiast

    "If there is an easier method..."

    Mocha. Included in Pro and is an Add-On for Express.

  • triforcefxtriforcefx United StatesModerator, Website User Posts: 1,060 Moderator

    It sounds to me like you didn’t turn on keyframes when you first animated your mask. In the mask’s drop-down controls, there are properties for Position and Path. On the left side of those properties is a circular button that you can click... when it is blue, keyframes are on. When it is grey, keyframes are off. 

  • spydurhankspydurhank Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,829 Ambassador
  • tddavistddavis Moderator, Website User Posts: 4,182 Moderator

    @rudefuk_ Also, you want to keyframe the PATH property of the freehand mask not the position or anchor point in case you might be doing that.

  • rudefuk_rudefuk_ Website User Posts: 3
    edited December 2019

    **HI NEW ISSUE PLEASE READ THE POST (UPDATED)**

    @triforcefx @tddavis

    I roughly know what keyframing is but i saw a grey box on every frame in my timeline so i assumed i was in the right direction.. but i activated Postion instead of Path ...

     *Update 1: Wrong, I used Path but it didnt work. The OVERALL masking shape stays relative similar with some points adjusted in some frames.

    Does it matter if... I delete the the masking points and create a new one in the next frame.. Maybe that is why the masking shape was the most updated one.. lol..

    https://imgur.com/a/AzTzKAj

    @NormanPCN @JBaymore

    Thanks guys I will learn about it now! 

Sign In or Register to comment.