Element 3D not working

FXhomer249348 Website User Posts: 3
edited December 2019 in HitFilm

I'm hoping that someone can help me to get the Element 3D plugin working. I'm new to Hitfilm Pro and just purchased the latest version, and have Element 3D v2.2 installed.I'm running the software on Windows 10.

Here are the steps I followed:

I created a new project in HF and a new composite. I dragged a piece of video footage into the composite window. I then dragged the Elelment 3D effect onto the video footage. I selected create scene to open the E3D window and used the 'create' option to create a sphere. I've also tried adding an additional layer (type Plane) above the video clip and adding E3D to it. In either case When I select ok to return to HF my preview window is either completely black or it shows the video footage without the sphere added. I suspect its something simple that I have not done. Any ideas?

Thanks in Advance,

 Edit: added system specs here to aid in fixing bug

I7 CPU @ 4.5ghz. 980TI GPU running latest driver

16GB RAM.   Windows 10 with all updates





  • GrayMotion
    GrayMotion Website User Posts: 1,569 Enthusiast
    edited December 2019

    You have not done anything in error. A gremlin has been identified by FXHome as being the culprit that is nagging at Element. Your problem as described is not exactly what happens for others although I've seen it in my testing the past week. It might be related.

    When the gremlin is captured FXHome will release an update to fix known issues that crop up after every update. Be patient. ?

  • rick1
    rick1 Website User Posts: 217 Enthusiast

    Sorry I see my question was answered in the other posts

  • GrayMotion
    GrayMotion Website User Posts: 1,569 Enthusiast

    @rick1 - To answer your question in the other post. You do don't need Adobe products installed to use Element 3D and yes...Jetstrike was  designed for E3D so those model assets will work perfectly.

  • FXhomer249348
    FXhomer249348 Website User Posts: 3

    Forum moderator: Feel free to close this thread. I tried again when I got home and I'm now able to see E3D shapes in HF. I'm not sure, but I may not have set up my composite shot correctly.

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,580 Ambassador

    I'll pass that to @OliThomspon or @TheBenNorris.

    Mods aren't FXHOME Staff, only user volunteers, and closing threads isn't something we have access to. But one of the Staff will git this. :-)

    Glad you have it working now!

This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!