HitFilm Pro 12 and Express Windows 10 getting slower and less responsive over time

Strings123
Strings123 Posts: 34 Just Starting Out

Hi everyone.

HitFilm Pro (12) and Express is getting slower and slower on every Windows 10 PC I have.

I have 3 PCs with HitFilm Pro (I only use 2), and one PC with Express. One PC is kept pretty clean - no Office installs, no extraneous software not needed for video and audio work.

I've tested old projects, and even the simple ones it just takes longer to load over time, and opening projects even seems to crash.

I know...upgrade....and I will at some point (gotta pay tuition). 

Anyone have any hints or answers regarding this? Maybe there's program combinations that are bad, Windows updates, patches, etc.

I've seen rendering go slower as well. Sometimes it looks like it stops rendering, and Task Manager says not respond, then all of a sudden it updates that it's done a bunch of rendering. It looks frozen sometimes for a minute or two.

Of course more complex Composites take more time. This is all relative.

Not all programs on my PC are doing this. I've run virus scans and malware checks.

Let's see, I hate computers almost as much as people (ha!).......but LOVE HitFilm.

 

Comments

  • TheBenNorris
    TheBenNorris Posts: 2,033 Staff

    @Strings123 of course the important question is: what are the machine specs?

  • Andy001z
    Andy001z Posts: 3,152 Ambassador

    Which version of express is it you are running, if you have not got the latest it might be worth downloading it. 

  • Strings123
    Strings123 Posts: 34 Just Starting Out

    First - thank you all for taking the time to respond! It's always appreciated - ideas spread and things to think about are brought up....maybe common experiences with other people...

    So - I will first try an uninstall and reinstall. I will test with Express before I run a Pro re-install.
    I can't update Pro because there are no more updates since last year. v12. 
    My main PC is quad core 3.0GHz with nVidea 1060 something. All flash drives. 16GB RAM.
    When I started using Pro on that, it was great.

    Remember, this is degrading across all machines. It's relative. All machines - regardless of version or specs - slows down relative to what it used to do on HitFilm more than other programs I use. 

  • NormanPCN
    NormanPCN Posts: 4,082 Enthusiast

    There were some reports on this forum about timeline slow downs in 12 of unchanged projects. Back then, I did a couple of tests and I did identify a timeline scenario with noticeable slowdown. This being with Cineform media. Prores as well but I could easily be mistaken here. I compared against Hitfilm 2017, which is the last Hitfilm I could have installed in parallel with current Hitfilm versions. For *me* this only showed when the Hitfilm timeline was pushed hard with multiple media streams being composited (at full res). Also, to stress my PC I needed to use UHD media.

    If my memory serves me this appeared to be cleaned up some by 12.2(?). I did not really redo my tests, but checked a sample test case playback and it seemed smooth(er) than previous. I still have those results written down, but I have a new PC, so those results cannot be compared to anything current. Same GPU (GTX 1080), but a big change in CPU.

  • Strings123
    Strings123 Posts: 34 Just Starting Out

    NormanPCM - thanks for the add on that.

    My situation actually occurs regardless of the project. Anything is slowed down to what it used to be. Not all of a sudden. Somewhat incrementally. 

    I'm always curious if added Windows updates cause issues.

    I even recently went back and cleared out unused programs and cleaned up hard drives. I have large hard drives with hundreds of Gigs free space and lots-o-ram. But who knows. I keep other programs closed (mostly).

    One thought is that for video I apply tracking, I usually film at 2.7K 30 or 60 for better pixel resolution but my projects are all 1080. However, that doesn't explain 

    Anyway - I'll keep at it.

    THANKS!!!!

  • triforcefx
    triforcefx United StatesPosts: 1,300 Moderator

    @Strings123

    I believe it’s been FXHome’s practice to allow you to download “patch” updates to your current version even if your year has expired.

    In theory, this means that you could download 12.3 and get it activated. HitFilm 12 was indeed a very buggy release, and most of that was fixed by 12.3. Before you do anything else, I’d recommend trying to download and activate 12.3 and see if it works. 

    Something else to note is that the 12 series upped the minimum spec. Some older hardware that used to be supported, no longer is.