Model Import - What controls the Groups?

In Blender 2.8 I have a model and I have separated out key parts for animation but it always sees just the basic model group.  I've tried putting them into new collections, creating separate discrete-named materials (this does show under the materials section but not the groups) but no luck getting them to show up as separate groups for animation.  Any ideas or hints?  @spydurhank @GrayMotion @Stargazer54 you all seem to the most up on modeling.

Comments

  • spydurhank
    spydurhank Posts: 3,156 Expert

    Can you post a screenshot to get a better idea?

  • FilmSensei
    FilmSensei Posts: 3,155 Expert

    @tddavis Each group is essentially a different Mesh. So if I were to create a Cube, a Sphere, and a Torus and then export all three as a model, In HitFilm there would be three groups labeled Cube, Sphere, and Torus.

  • spydurhank
    spydurhank Posts: 3,156 Expert

    He's talking about Blender.

  • FilmSensei
    FilmSensei Posts: 3,155 Expert

    Oh, in Blender only! I see... sorry about that! My mistake. :)

  • tddavis
    tddavis Posts: 5,221 Expert
    edited August 2019

    Thanks all for the quick responses.  Here is a shot of what I have set up in Blender 2.8 as far as the collections. When I moved the rotors after separating in Edit mode an after image of it stayed under the 1st Collection and they may be the problem, but when I clear the parent it resizes them and mucks about with the rotations and locations.

    https://www.dropbox.com/s/vh9ynjko1ib7i0e/Blender Model Screen.PNG?dl=0

    I export it as an FBX and bring it over to Hitfilm and this what the import screen looks like:

    https://www.dropbox.com/s/v1bhjf7c6k4pmpp/Hitfilm Import of Model FBX.PNG?dl=0

    This is the cheaper version of HeySiri's model that had several versions and rigging to it; this one doesn't and it also doesn't have the landing gear his did but I can live with that. Ima just playing :)

  • GrayMotion
    GrayMotion Posts: 1,632 Enthusiast
    edited August 2019

    I'm back from my project...and way behind the discussions here...but..... Inquiring minds...FBX export  from Blender doesn't have groups??????

  • spydurhank
    spydurhank Posts: 3,156 Expert

    Give each animation group a different color.

  • tddavis
    tddavis Posts: 5,221 Expert
    edited August 2019

    @spydurhank Even if they are using a texture map?  It's the same map but named differently in Blender and applied as a new material.  Those show up in the materials import of Hitfilm.  So, shoukd I add a diffuse node and set the fact to use the texture?

    @GrayMotion You aren't behind by much. :)   I just started the discussion a few hours ago. Welcome back from working.  FBX export so far is only showing 1 group which I'm trying to get it to be 4.

  • spydurhank
    spydurhank Posts: 3,156 Expert

    @tddavis ,

    I'm gonna set the next two weeks or so aside, to focus on tutorials to get everything properly exported to Hitfilm in the simplest manner possible. But first I'm re-writing my old FBX OBJ and Alembic exporters to cut down on the glitches that you're seeing because that is a common Blender pitfall that is fixed by my Filmer tools. I should be done with that sometime today if I stop being distracted by this comedy special on Netflix. :) I'll have a new Filmer update for you guys as well with a few more tools and stuff. You don't know Hell until you run into all the problems with exporting from Blender to Hitfilm. :)

    If you can describe in detail from start to the point at which your project has stalled, step by step, from first import to export, I can focus my first mesh export tutorial so that it at least will have the correct info to help you and everyone else. 

  • tddavis
    tddavis Posts: 5,221 Expert

    @spydurhank Was at the daughter's and now headed to another daughter's babysitting so I only had a chance to make this quickie video showing what I'm doing exactly to export in Blender and what it does to the animations.  I'll try and add notes or narration later.

  • Triem23
    Triem23 Posts: 20,288 Power User

    @tddavis yeah, even with texture mapping, make each group a different color. Do the same with materials for safety. Blender's been known to merge groups or materials with identical Diffuse colors when exporting meshes to different formats. The colors don't have to be radically different - just a point or three. 

  • spydurhank
    spydurhank Posts: 3,156 Expert

    Thanks @tddavis ,

    I'll have some videos started soon with the help of a nice voice over lady that I know. I've gotcha covered.

    By the way... Showing me the issues in a video is perfect for me, thanks for doing that. 

  • tddavis
    tddavis Posts: 5,221 Expert

    @spydurhank Thanks so much for taking the time on this.  The video was super quick when pressed for time so I may try and make it better if it helps you.

    @Triem23 I tried adding a diffuse node and mix shader in Blender to the texture and made sure they were different colors with the factor all the favoring the texture map, but it didn't keep the group from being the whole model and not the separate parts sadly.  They do show up as separate materials as before just not animation groups.  I'm going to try breaking the parents on the rotors and adjust them back to where they need to go and see if that helps.

  • spydurhank
    spydurhank Posts: 3,156 Expert

    It is not you @tddavis or your textures or materials and diffuse colors or any of that other jazz. It is the built in Blender exporters that are the culprit. I'm working on them right now and it won't be too long till I complete my re-writes.  

  • tddavis
    tddavis Posts: 5,221 Expert

    @spydurhank Ok, thanks for the modeling know how boost.  I tired what I mentioned about the parent and nope it still on sees the main ship group..  I'll wait to see your magic. :)

  • spydurhank
    spydurhank Posts: 3,156 Expert

    No worries @tddavis ,

    You'd go insane trying to figure out how to export an Alembic file that will support multi materials and correct animation groups. Don't worry, my simple little tools will take care of all the guess work for you. :)

  • tddavis
    tddavis Posts: 5,221 Expert
    edited August 2019

    @spydurhank I've tried alembic and got nowhere :)  Looking forward to your improvements and I'm sure a lot of others will ge too.

    EDIT:  I got the rotor groups to finally show up by using Filmer to export to FBX instead of Blender 2.8 proper.  I hadn't even thought about trying that until you said your simple little tools and it clicked in my head.  I got the tail rotor spinning in Hitfilm now but the wing rotors are going to take some finagling cause they are slanted and the axis doesn't line up. (FWIW, I had a devil of a time getting that worked out in Blender as well.  Had to go to the stack exchange and ask about it.)  I also figured out the illumination texture in Blender but haven't got it into Hitfilm...yet.

    Here is what I have in Blender now: