Lagging & momentary freezing

DCBOutdoors2
DCBOutdoors2 Website User Posts: 1

Good afternoon everyone, I am looking for help,  recently hitfilm express how I started wagging whenever I insert a media clip and will momentarily freeze. I can’t really edit film  and I have a lot of projects coming up for my YouTube channel. When I first got hitflim  Express and it worked great and now I am continually having this problem ?  I thought maybe I had too much memory on my laptop so I put a ton of pictures and clips on a next ternal hard drive, I restarted my computer hoping this would fix the problem and it did not. The next step I took was uninstalling and reinstalling the program and you still did not fix the issue. I don’t know a whole lot about computers but I am learning, could someone please help me out on this issue. I restarted my computer hoping this would fix the problem and it did not. The next step I took was uninstalling and reinstalling the program and you still did not fix the issue. I don’t know a whole lot about computers but I am learning, could someone please help me out on this issue 

Comments

  • Triem23
    Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 19,580 Ambassador

    Can you try to determine your PC specs? CPU, GPU, OS, RAM and Storage? Try to determine if your GPU needs driver updates (There's a FAQ on this: https://fxhome.com/faqs/view/10 )

    Hitfilm 12.3 raised the minimum system specs for the first time since Hitfilm 4. My initial guess is you'll either have obsolete drivers (which can cause issues), now under-spec hardware, or both. It's likely you'll need to revert to an earlier version of the software.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!