Particles

stuckon3d
stuckon3d Website User Posts: 12
Hi guys,
im working on a shot where i have mist on the ground made out of particles and im making it split apart as a person walk across it. The problem is that every time i try to move the forces or blockers the machine chugs down because it tries to calculate realtime as i move it across. Is it possible to make the software pause calculation until after I move the force/blocker, and release the mouse button. That way i can move them without slowdown.
thanks for listening,
stuckon3d

Comments

  • AxelWilkinson
    AxelWilkinson Staff Administrator, Imerge Beta Tester, HitFilm Beta Tester Posts: 5,247 Staff
    In the General section of the Particle Controls, there is a Preview option. Tick it on, and the textures will temporarily be hidden, so everything will render much quicker, but you can still see the motion of the particles and their positions. Once you have the animation done, you can untick the Preview to re-enable the textures.
  • stuckon3d
    stuckon3d Website User Posts: 12

    In the General section of the Particle Controls, there is a Preview option. Tick it on, and the textures will temporarily be hidden, so everything will render much quicker, but you can still see the motion of the particles and their positions. Once you have the animation done, you can untick the Preview to re-enable the textures.
    Hi Axel,
    im aware of the preview mode, and i am using it but even then is very slow, I have hundreds of particles to cover the floor, and its really slow. I cant use big particles or the effect im shooting for will not work visually. I'm running a pre particle run up so that the first frame starts with the bed of mist, which is why is so slow. So if you guys could make the particle calculation stop while moving the blocker/forces it will stop the slowdown and keep the interactivity until i release the mouse then it can start to calculate again. At least have a toggle option, for those rare situations.
    thanks,
    Stuckon3d
  • AxelWilkinson
    AxelWilkinson Staff Administrator, Imerge Beta Tester, HitFilm Beta Tester Posts: 5,247 Staff
    What are your system specs? Hundreds of particles shouldn't be a problem. Hundreds of thousands, and things might well start slowing down, but hundreds of particles shouldn't be adding much of a strain. What graphics card are you running?
  • stuckon3d
    stuckon3d Website User Posts: 12

    What are your system specs? Hundreds of particles shouldn't be a problem. Hundreds of thousands, and things might well start slowing down, but hundreds of particles shouldn't be adding much of a strain. What graphics card are you running?
    Hi :)
    my system is i7 extreme sixcore 3.33
    580gtx with 3gigs of ram
    12 gigs of ram
    7200 rpm drives
    i should have said thousands, sorry, im emitting 50 per second on a wide area, with a ten second build up, im also stopping the emission and letting the particles live for the full 30 seconds. I'm also using multiple images so that it ramdomizes the look of the mist. and making the particles fade out using the lifetime parameters.
    cheers
  • AxelWilkinson
    AxelWilkinson Staff Administrator, Imerge Beta Tester, HitFilm Beta Tester Posts: 5,247 Staff
    Particles are basically going to be handled by the graphics card, what card is in your system?
  • stuckon3d
    stuckon3d Website User Posts: 12

    Particles are basically going to be handled by the graphics card, what card is in your system?
    Hi Axel,
    i know hitfilm is gpu based, and as i mentioned on my specs, i do have an NVIDIA 580GTX with 3 gig of ram on it. So unless you support sli i dont think the gpu can get any faster. Anyhow, I was just making a suggestion on how to optimize your software when dealing with lot of particles when all other measures are taken and it is still slow to work with.
    Cheers,
    Stuckon3d
  • Emma
    Emma Staff Administrator, HitFilm Beta Tester Posts: 79 Staff
    edited August 2011
    Sounds like you're pushing the particle engine to its current limits, which is good to hear! I believe particle rendering is one of the areas that will be optimized in the coming months, and we'll certainly take your feature suggestion into consideration.
    In the meantime for intensive particle effects, I'd suggest that if you know roughly where you want to position your deflectors and forces, try manually entering the value for the position property on the composite shot timeline rather than using the viewer controls. Taking this approach means the particles won't be continuously updating as you drag the viewer controls. Hope this helps you out!
  • AxelWilkinson
    AxelWilkinson Staff Administrator, Imerge Beta Tester, HitFilm Beta Tester Posts: 5,247 Staff
    Ah, sorry, without any brand or model name I overlooked the graphics card being mentioned. MY fault.
    Thanks for the suggestion though, we will look into it further and see what can be done.
    In the mean time, here are a couple more options for you:
    First, if you know basically how many particles you need for the final effect, you could greatly reduce the particle count while animating your blockers (perhaps 10 rather than 50 particles per second), then once the animation is done, reset the particle count to 50 to create the final effect. The reduced count will still allow you to see particle movement, but without as much strain on the system.
    Second, If you created a small plane to use as the shape of the deflector, then you could animate the plane to get all the movement done before you link it to the deflector. That way the particles would remain unaffected whilst you move the plane, but when it is linked to the deflector action, it will still exert its influence on the particles as it moves through them.
  • stuckon3d
    stuckon3d Website User Posts: 12
    thank you guys. :)
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!