Scaling clips on the timeline doesn't function anymore

Cervier
Cervier Posts: 156 Just Starting Out

My project is 720p, but some of my media are 1080p. When I drop one of them on the timeline and change its scale to 67% (Transform > Scale), the paused image is scaled, but when I play it, it goes back to 1920x1980 and I can only see a cropped portion of it in the 1280x720 frame.

I hadn't used HF in a while, but I don't remember ever facing this issue, not before v.12.

Comments

  • Triem23
    Triem23 Posts: 20,238 Ambassador

    Which version of Hitfilm are you using? Make sure you're on 12.2, which had some GPU bug fixes. 

    Remind us of your system specs and double check your drivers? Note, if you have an Intel GPU only Intel changed their update policy last November. The current Intel drivers is March 9, 2019. See this thread for more information  https://fxhome.com/forum/discussion/49168/updating-intel-gpu-drivers-windows-for-2019#latest

    Double check your playback/preview settings in the viewer? Set everything to Full Resolution/Final Quality to test.

    Test render one of the problematic sections. 

    If the issue still exists, let us know and I'll tag in a dev in case you have an unresolved bug. Memory says this was a known issue with some Intel GPUs that should have been squished in 12.2, but I could he wrong  

  • Cervier
    Cervier Posts: 156 Just Starting Out

    - systems specs:

    CPU = core i3-2120 at 3.300 GHz, GPU = ADM Radeon HD 6450 (drivers are up to date), RAM = 8 Gb, Windows 10 (64) up to date.

     

    I had already tried setting playback quality to "Final", didn't change anything. Export works fine though.

    I did some experiments to try to understand that strange behavior and realized the issue maybe isn't with the "scale" property but rather with the scaling of playback.

    For instance, if I just drop the clip on the timeline, leaving its scale to 100%, there are still some differences between the paused and playback displays. "Paused" will give me a cropped image (the central 1280x720 pixels), whereas playback will show an image that looks as if those central 1280x700 had been scaled up to 1920x1080, and then cropped to 1280x720 to fit the window (thus making it look like a zoom-in).

    If I set the scale to 50%, the image is, as expected, smaller than the 1280x720 frame (so, probably 960x540, I didn't check) and the paused image is, as expected, the 1920 one scaled down. But the playback image, while still being 960x540, is like "zoomed-in" compared to the normal paused one.

  • Cervier
    Cervier Posts: 156 Just Starting Out

    I had an idea and quickly checked something: it seems the clips I'm having trouble with don't have the same framerate as the project. I usually set my projects to be 1080p at 25fps, or sometimes 720p but still 25fps. I get 25fps files from my Lumix camera, but also 29.97 fps files from my phones --and I believe those are the ones I am having trouble with.

    I just tried this experiment: I opened the "Renegade" files (1080p, 29.97 fps) in a matching project. Then I changed the project settings to 720 and scaled down the clips (67%). Everything worked fine.

    Then l changed the framerate of the project to 25 fps, and *boom* the clips were correctly displayed when paused, but recovered their full scale when I hit "play".

This discussion has been closed.