Viewer (and export) broken?

I've updated to HitFilm E12 yesterday after re-installing my PC and started working on a little video.
I imported my video and it looked atrocious from the get-go.

On the left here is VLC with the video file.
On the right is my viewer (also, you can see the same kind of thing in the Media browser).
As you can see, the video file displays just fine in VLC indicating the video should be fine but for some reason, it looks like this pixelated blurry mess in HitFilm E12 :\ 
I thought to myself: "maybe it's because my drive might be slow?" (It's loading from a NAS) so I pre-rendered it (pre-renders will be on my high-speed PCIe SSD), but to no avail.

Does anybody here have a clue what might be going on?
I rebooted my PC already but no success either.

the video is made using Streamlabs OBS, using NVENC.
Swapping Streamlabs OBS to x.264 doesn't create this issue, however, due to the specs of my PC, using NVENC is a must (as my CPU can't handle gaming and encoding at the same time)

Comments

  • tddavis
    tddavis Posts: 5,096 Moderator

    @FinlayDaG33k In the picture I can't see what you viewer quality settings are but I would suspect that they are in a reduced mode.  Some effects and picture quality in the viewer are reduced to help with slower GPU machines.  It should be at the top right corner of the viewer window Draft is most likely what yours is set on to give that sort of result.  Sorry, I'm on a phone or I would attach a screen cap of the settings.

  • Triem23
    Triem23 Posts: 20,069 Ambassador

    @tddavis is mostly correct, but the Quality Settings got moved to the bottom right of the viewer in HF12 

  • @tddavid they are all in "full" and "final".

    The final export also had this weird mess going on so I doubted those quality settings had anything to do with it.

    After fiddling around I noticed it is likely that HitFilm doesn't work nicely with videos encoded using NVENC as the exact same settings in HitFilm with an x.264 encoded video works without a hitch.

  • tddavis
    tddavis Posts: 5,096 Moderator

     @FinlayDaG33k That is good to know for future reference.  I assume you got it to work for you by transcoding to the different format for that file, or did you use a different one in x.264?

  • @tddavis I found the "cause" by switching to x.264 to test it and saw it worked fine.
    I then used Handbrake to convert the video clips with the issue to x.264.

This discussion has been closed.