Problems logging in. (and addon help)

I have two email accounts, one for gmail and one for Hotmail.

I recently upgraded from HitFilm 17 to 18, but not without great difficulty.

I could not remember which email I used to purchase addons, so I tried my Hotmail account.

Oops, that's not it (however, you do recognize that account) so it pops up asking for password, country, and age.

I remember now, I had forgotten the password a long time ago, which is why my active account is a gmail.com one.

That would be fine - just log out of the Hotmail.com hitfilm login screen - but there is no way to do this (even though you have not entered a correct password).

I had to cut and paste the links to download, register, view account, check addon status, etc by copy and pasting the links from "Chrome" web browser to "IE" browser.

I was able to get HF18 installed properly, it asked for my email and password at startup and is working.

However, my purchased plugins are not appearing in the left panel at startup.

At File, Settings, Activation it lists the addons I have purchased, what am I doing wrong?

 

Comments

  • Triem23Triem23 Moderator Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 18,319 Ambassador

    I assume you've upgraded from "Hitfilm Express 2017" to "Hitfilm Express (v12)?"

    The add-on packs got shuffled with the release of Hitfilm Express (v8) in May, 2018. Individual effects purchased with older packs should be active on your system, although the current pack itself might not show as purchased.

    What old packs did you have? I'll have to dig a bit to find my chart, but we should be able to check for those specific effects. 

Sign In or Register to comment.