Why is this transcode flickering?

CleverTaglineCleverTagline ModeratorLas Vegas, NVModerator, Website User, Ambassador, HitFilm Beta Tester Posts: 3,039 Ambassador

Take a gander at this video, containing two overlaid versions of the same footage, with one transcoded differently than the other:

Short version: I'm trying to figure out why the version on the right is flickering at certain times, while the one on the left is not, and whether or not I can just use the left version, or if it would be better to find a solution to fix the flickering.

Long version: This is footage from an old facial animation tutorial series I did about 14 years ago using Animation:Master. It was originally distributed on a 2-CDROM set through Anzovin Studio, but once the interest in the set had waned a good bit, Anzovin returned all rights back to me. For a while I had it hosted on MindBites until that service went kaput, so I decided to just release it on YouTube for free.

The original files all use Sorensen compression, which a lot of apps (including HitFilm) won't even read, so I have to transcode it before I can edit it for YouTube. QuickTime automatically converts it to H.264, and I'd originally (several years back) started saving those conversions, with the plan to use them when I finally got around to editing (which is soon...I think). Now that I'm more savvy about transcoding, I thought I'd do the "smart" thing and run the originals through Handbrake using the settings suggested by @NormanPCN. That's what's bringing me here.

The video on the left in the sample above is the converted output from QuickTime. The video on the right is the output from Handbrake using the Norman AVC settings. As you can see, the UI is flickering at seemingly random times in the one on the right, and I have no idea why. I've tried tweaking all sorts of settings in Handbrake, thinking that I'd eventually find the magic bullet and nix that flicker, but nothing kills it.

Different frame rate? Nope.
Different Constant Quality RF values? Nope.
Changing to the Average Bitrate option, with various values? Nope.
Various options in the Tune menu? Nope.

I could keep randomly testing stuff, but I thought I'd throw this out here and see if anyone (*cough* Norman *cough*) can look at it and say, "Of course, it's [insert setting]. Just change it to [value] and that should take care of it."

Or is it okay to just use the version spit out by QuickTime? Those are already at a constant frame rate, and a pretty low one at that (this is 5fps; there are 13 other screen capture files, with the highest fps being 15), so it might not necessarily need further optimization.

Comments

  • NormanPCNNormanPCN Website User Posts: 3,947 Enthusiast
    edited December 2018

    The first thing I would try is to make sure everything in the Handbrake filters tab is off. Nothing there should be applicable to your video.

    Then try to drop the extra x264 settings I added.  keyint=8:bframes=0

    If that corrects it then try them separately. First knock off bframes. Then the keyint. I wonder if there is some strange interaction with the low frame rate of the sources. There could also be a problem with the decode of the Sorensen.

    Using the Quicktime output should be fine. In other AVC encoders the closest way to get to fast decode settings is to use a BaseLine profile setting. Most AVC encoders should give you at least that level of encode setting control. Baseline has no CABAC and no B-frames.

  • CleverTaglineCleverTagline Moderator Las Vegas, NVModerator, Website User, Ambassador, HitFilm Beta Tester Posts: 3,039 Ambassador

    Yes! The filters were the problem. It was apparently auto-detecting interlacing, and the deinterlace process was messing it up. Turning that off fixed the flickering. Thank you!

    There's another one-time glitch (not visible in the video above) that is still annoying me, but I can probably kill that in HitFilm.

  • NormanPCNNormanPCN Website User Posts: 3,947 Enthusiast
    edited December 2018

    I edited my fast decode AVC thread to add a note and screenshot to turn deinterlace off when you know your source is not interlaced. Just a safety measure in case the auto detect has a brain fart.

This discussion has been closed.