Preview of comp does not play. Scrubbing timeline DOES play.

DataDesignDataDesign Website User Posts: 440 Enthusiast

I have a 5 second comp of a photo. I added a logo I made from a picture on a green screen. I used color diff to key out the green and animated the logo to go from very small to full size using key frames. This worked well and I played it several times to get the position right. I added a text layer and parented it to the logo and it worked correctly.  Probably should have quit then. :-)

I was trying to get the text to the correct color and size, and it seemed to be working, but now it has stopped playing unless I do a Ram Preview. Then it plays very jerky and slower than normal and shows the blue bar below the preview screen. If I then  jump back to the beginning and click the "Play" button, nothing happens. If I scrub through the timeline, it shows the movement as it should. I am going to export this bit and see what I get.

Exported it and it plays on Windows Media player. ????? Any ideas?

Pro 11. Asus i5-6400, 16gb ram, 1tb HD, 500gb SSD for C: drive. Windows 10. GPU Nvidia 1050i 4gb.

Comments

  • NormanPCNNormanPCN Website User Posts: 3,945 Enthusiast

    It sounds like your playback settings are such that effects are disabled on playback.

    https://www.youtube.com/watch?v=umHH_3FYWaw

  • Andy001zAndy001z Moderator, Website User, Ambassador, Imerge Beta Tester, HitFilm Beta Tester Posts: 2,864 Ambassador

    Any other assets like audio or video added? Maybe step back a couple of times to see if the problem goes away.

  • DataDesignDataDesign Website User Posts: 440 Enthusiast
    edited December 2018

    @NormanPCN @Andy001z

    After saving and going  back later, it now worked so I saved the project under another name. But when I tried to play the original exported file, Windows Media Player gives an error "Windows Media Player encountered a problem while playing the file." The only choice you get is "Close". After that the HitFilm project file will not play in the timeline. Just like the original question.  I was able to play the exported file with Quicktime Player, although it was jerky and seemed to change to brightness toward the end. This is spooky. Now neither project file will play in the viewer, Over 4 hours spent on this 5 second clip. :-(

    Note: the play head does not move at all. It is not like it moves and nothing happens in the case of Playback Quality setting is wrong.

  • CleverTaglineCleverTagline Moderator Las Vegas, NVModerator, Website User, Ambassador, HitFilm Beta Tester Posts: 3,036 Ambassador

    Very odd. It sounds like something might be faulty with the HitFilm install. Perhaps uninstall HitFilm then reinstall it fresh?

  • FilmSenseiFilmSensei Moderator, Website User, Ambassador Posts: 2,297 Ambassador

    Another possibility is that you do not have speakers or headphones plugged into your computer. HitFilm won't PLAY if you do not have an audio device, however you can still scrub the play head. I hope this helps!

  • DataDesignDataDesign Website User Posts: 440 Enthusiast

    @FilmSensei

    I have speakers built in to the monitor. HDMI cable from the GPU. No sound is in the video clip because it is just two photos. I know the speakers work because I watch all your tutorials and @CleverTagline's too.

    @CleverTagline

    Really? I demand a recount. Oh well, if nothing else works, I will try re-installing.

  • CedricBonnierCedricBonnier Staff Administrator, HitFilm Beta Tester Posts: 1,189 Staff

    @DataDesign I assume playback does not work in either the Trimmer panel nor the Timeline? What error do you get when trying to play a video in the Trimmer? It sounds like there's an issue with audio on your computer and HitFilm cannot access audio to be able to mix samples, meaning that playback cannot start.

    If you would like staff answer, I suggest you contact us directly. I suspect there will be a lot of activity on the forums over the Christmas / New Year period and most of us will be on holiday.

  • DataDesignDataDesign Website User Posts: 440 Enthusiast

    This is a long post and I would not blame anyone for not reading it.

    @CedricBonnier

    I never played it in the trimmer panel as I do not have a trimmer panel open while compositing.

    Update:

    When I started HFP this morning, the playback worked normally. Full speed. I tested exporting and that worked normally. So, I added a key frame on the background photo to set the opacity to zero  and then go to 100% by two seconds. This worked, but the playback started, then stopped, then jumped to 3 seconds, then jumped to 4 seconds and stopped. Ram preview did the same. After a while I noticed the playback stopped at 3 seconds and would not restart. I could click the Play button again and it would play a few frames and stop again. I could continue this until it reached the end of the 5 second clip. While playing it would show the pause icon instead of the play icon. Then it stopped and the icon became the Play icon again.

    UPDATE:

    OK, after exiting HFP as I was just looking at the screen, I got a Windows error that it had encountered a problem and would have to restart. I had no choices and it just restarted. After restarting, I tried HFP again and the play worked as normal and played all the way through many times without pausing. So, what does that mean? Bad HFP install? Bad Windows install? Bad computer? It seems that the problem with Playing the video starts after I make any change to the project. Which seems to point to HFP. But then again, I know nothing about this stuff.

     

This discussion has been closed.